teamviewer.com link icon
or
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?


Download the new version and let us know what you think about it! 👉 Please click here 👈

TeamViewer 12 not connect in Fedora 25

Hi everyone.

I can't connect my Teamviewer 12 in Fedora 25.

Can you help me about?

Comments

  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear jliberato,

    Thank you for contacting TeamViewer

    The reason that TeamViewer is not working properly on Fedora 25 is because Fedora is using by default Wayland instead of Xorg.

    Actually, TeamViewer supports X11. When TeamViewer is run under Fedora 25 with Wayland enabled it's not able to get an ID.

    However, it's possible to enable X11 under Fedora. A default installation will include Xorg. All you need to do is enable that support.

    To make TeamViewer running and work properly under Fedora 25, please disable Wayland support by running the following instructions:

    - Open the file /etc/gdm/custom.conf with your favorite editor (vi, nano, gedit, etc).
    - Uncomment the line 'WaylandEnable=false'
    - Save and reboot the system.

    After that, The system will run using Xorg support and TeamViewer will work properly.

    Commands tested under Fedora 25 with Gnome and GDM (Default installation).

    Let us know if this solution worked for you. We are looking forward to your comments.

    If you have any other questions please don’t hesitate to contact us.

    Best Regards,

    Christian

    Did my reply answer your question? Accept it as a solution to help others, Thanks.

  • @ChristianCay wrote:

    Dear jliberato,

    Thank you for contacting TeamViewer

    The reason that TeamViewer is not working properly on Fedora 25 is because Fedora is using by default Wayland instead of Xorg.

    Actually, TeamViewer supports X11. When TeamViewer is run under Fedora 25 with Wayland enabled it's not able to get an ID.

    However, it's possible to enable X11 under Fedora. A default installation will include Xorg. All you need to do is enable that support.

    To make TeamViewer running and work properly under Fedora 25, please disable Wayland support by running the following instructions:

    - Open the file /etc/gdm/custom.conf with your favorite editor (vi, nano, gedit, etc).
    - Uncomment the line 'WaylandEnable=false'
    - Save and reboot the system.

    After that, The system will run using Xorg support and TeamViewer will work properly.

    Commands tested under Fedora 25 with Gnome and GDM (Default installation).

    Let us know if this solution worked for you. We are looking forward to your comments.

    If you have any other questions please don’t hesitate to contact us.

    Best Regards,

    Christian


    The change does not enable the service before login into an X session.

    I can however login via the console and login into the service manually in the foreground, this makes the system appear on the remote client for connection, but after a reboot its the back to square one.

    The teamviewer deamon runs perfectly. The ps -ef and systemctl status show everything is fine.I just think it has somethig to do with automatically authenticating the user into the teamviewer core service and not the deamon itslef. I even disabled selinux and the firewall to see if it makes a differnce but that does not seem to interfere in anyway whether it is on r off.

     

     

  • ChristianCay
    ChristianCay Posts: 182 [Former Staff]

    Dear joeyraj,

    Thank you for your feedback.

    Please run the following command to check TeamViewer daemon status.

     

    teamviewer info

    And have a look at the following lines

     

     

    Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)

    Active: active (running) since Wed 2017-02-15 14:02:34 PST; 3min 8s ago
    Process: 1082 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)

    If the service is enabled and it's active, TeamViewer daemon is working properly.

     

    To make sure that I'm able to understand your issue, would you like to connect to a TeamViewer device at the GUI login prompt?

    Thank you in advance.

     

    Best regards,

    Christian

     

    Did my reply answer your question? Accept it as a solution to help others, Thanks.
  • I'm afraid removing the quote to disable Wayland renders X Windows useless in conjunction with Nvidia Geforce drivers.

    Removing the rhgb option from grub.conf was necessary to resolve my issues.

     

  • It's definetely the Wayland/Xorg problem you are facing.

    I'm on TV v11 and upgraded 3 days ago to Fedora 25 (Wayland by default) - And as the daemon ran nicely after upgrading, I didn't discover the problems until 20 mins before I had an online appointment with a customer.

    Luckily I still have a workstation running Fedora 24 and I could fallback on that.

    The problem descriptions/errors are the same in TV11 and TV12 - So TV better get working to make the 12 work with Wayland if the want me so badly to buy the TV upgrade :-)

    Wayland has come to stay - It solves numerous security issues with Xorg.

    Brgds,

    Axel

  • absorbek
    absorbek Posts: 1

    Hello, I have solved this issue by installing same version of Wine, that TV uses.

     

    When you update Wine to latest version, it somehow collides with the wine included in TV package and TV cant connect.

    Ondrej S.

  • Hi,

    Checked out the Wine versions - I'm still having only one issue - The Wayland.

    With Wayland, no TV - With Xorg, TV works.

  • Diftraku
    Diftraku Posts: 1

    @ChristianCay wrote:

    Dear jliberato,

    Thank you for contacting TeamViewer

    The reason that TeamViewer is not working properly on Fedora 25 is because Fedora is using by default Wayland instead of Xorg.

    Actually, TeamViewer supports X11. When TeamViewer is run under Fedora 25 with Wayland enabled it's not able to get an ID.

    However, it's possible to enable X11 under Fedora. A default installation will include Xorg. All you need to do is enable that support.

    To make TeamViewer running and work properly under Fedora 25, please disable Wayland support by running the following instructions:

    - Open the file /etc/gdm/custom.conf with your favorite editor (vi, nano, gedit, etc).
    - Uncomment the line 'WaylandEnable=false'
    - Save and reboot the system.

    After that, The system will run using Xorg support and TeamViewer will work properly.

    Commands tested under Fedora 25 with Gnome and GDM (Default installation).

    Let us know if this solution worked for you. We are looking forward to your comments.

    If you have any other questions please don’t hesitate to contact us.

    Best Regards,

    Christian


    Unfortunately, disabling Wayland cannot be considered as a solution to this issue. Fedora uses Wayland as the default composito with GNOME, so any other distro that runs GNOME might also be running Wayland as the default in the future.

    This should be considered as a defect in the Linux version and prevents day-to-day usage if someone runs a Linux computer with Wayland.

  • Thanks, It's worked fine after following your steps and restarting the PC.

  • marav_1
    marav_1 Posts: 2

    Hi,

    Xorg is a **bleep** and it's gonna be discontinued. TeamViewer team need to deliver a support for those who use wayland, not just by saying "you need to use an insecure and **bleep** software, sorry". 
    "your Ferrari has a problem, take a bike" ...

  • marav_1
    marav_1 Posts: 2

    And, when do you think TV can support Xwayland ?

  • cdusrsbin
    cdusrsbin Posts: 2

    TV works flawlessly under F24,25 and beta. You may have to re_read Fedora/RHEL 7 install guide and jump to troubleshooting.

    I configured as per previous post. I would hate to say it but I would say that the configuration error is on your side. like I said as per previous post you can configure this and make it work epic with any version of a Fedoraa and gui display interface

  • Well, when Fedora/RH suggests Wayland is the way to go and TV can't run under Wayland due to somewhat higher security/separation in Wayland vs Xorg, I think you need to reconsider your point of view.

    Wayland is the problem but not the cause - TV needs to deal with a world in change as everybody has - Even Microsoft - Don't think they ever imagined they had to reactivate security updates on their deprecated systems, but guess what - They just had!

    I won't change my OS, but I might change TV to some other alternative if they keep on not solving the Wayland issue.

    Brgds,

    Axel

  • dvd7227
    dvd7227 Posts: 1

    This worked thanks :-)