teamviewer.com link icon
or
Ask The Community

[Update: 13.1.3026] Spring Update

DanielStm
DanielStm Posts: 224 Staff member 🤠

Spring_Release_Harley.jpg

Dear Linux community,

last week we have released the spring update for TeamViewer Host (13.1.1548), leveraging under-the-hood improvements of the TeamViewer 13.1 code base. In addition, the Host now notifies the user about Wayland limitations in the same way as the full version. It also informs the user when started to run in the background and no tray icon is available. Separate SUSE packages are available, too.

Benefiting from the same code base improvements, today we are releasing the full TeamViewer 13.1 client for Linux.
As indicated in the previous announcement, this release is mostly about stabilizing. But still, a bunch of useful additions snuck in.

Computers & Contacts
The C&C window is now restored at its previous position. Groups can now be collapsed. And, most notably, service cases in the service queue now show up in the list.

Remote Control
The toolbar has a new look and learned to start a file transfer within a running remote control session. You can now also change the resolution of the remote screen. We expect to have most of the missing items ready for the next release.

TAR and SUSE Packages
The TAR package learned to check for QtQuickControls when running tv-setup checklibs. This should resolve the confusing situation that checklibs did not find missing (shared library) dependencies but TeamViewer still did not start.
Much to our dismay, it is not possible to express RPM dependencies in a way that can be satisfied on both, RedHat and SUSE based distros. Again, QtQuickControls.
Therefore, SUSE packages are now available as a separate download which also makes the repository work.

SUSE package migration
Note: If you have previously tinkered your way to make the RPM package or repository work on SUSE, we strongly recommend to remove it and replace it with the new SUSE package. While the binaries are completely identical, the dedicated package should enable smooth updates in the future.

Note: Removing the package also removes an existing account assignment. Therefore, after installing the new package, you might want to assign in again.


What's more
As some desktop environments do not support status notification icons (a.k.a. tray icons), we added a notification to let the user know that TeamViewer runs in the background (if the start-with-system option is enabled) and no icon could be created. If you start TeamViewer manually, it should always become visible.

On DEB systems, the teamviewer repo list command now lists available packages.

Linux specific documentation has been greatly revised, reworked and extended. Please have a look:

Linux Knowledge Base

Further Reading

As always, packages are available via repositories and on the TeamViewer Linux download page.

All the best,
Daniel

Linux Developer
«1

Comments

  • Any news on a new Linux Host?

    If you touched it and it stopped working, the first question to ask is "Did anyone see me touch it..."
  • JM325
    JM325 Posts: 1

    TeamViewer on Linux has come a really long way since the switch to native support and I think you guys deserve a ton of credit. I've been checking as new versions come out and the current state of it (bordering at least for me on 100% feature-complete) is super impressive, especially relative to the first release.

    I do however want to mention one issue that, while small, has kept me from actually upgrading from 12 to 13. Are there plans to add keyboard shortcut support to the Linux version? It might be minor to a lot of people, but I rely heavily on ctrl+C/X/V in particular, to the extent that having to handle everything with right click context menus (often after replacing all the text I've highlighted with a 'c') currently has me downgrading. It's pretty much the only thing I care about that still seems to be missing.

  • Windows Authentication is not possible with version 13 anymore. This makes it impossible to use TeamViewer for administrative work on Windows hosts.

  • CSylvain
    CSylvain Posts: 13

    attempted to install  moments ago. package complains it conflicts with itself  :-P

    sudo rpm -Uhv teamviewer-suse_13.1.3026.x86_64.rpm   
    warning: teamviewer-suse_13.1.3026.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 0c1289c0: NOKEY
    error: Failed dependencies:
           teamviewer conflicts with teamviewer-suse-13.1.3026-0.x86_64

    currently have teamviewer-13.0.9865-0.x86_64 installed

  • CSylvain
    CSylvain Posts: 13

    @JM325 you sure you don't mean ctrl+shift+c and ctrl+shift+v for copy and paste, respectively?

  • CSylvain
    CSylvain Posts: 13

    <double post>

  • Many Thank for upgrading the linux client, it deserve it, and it's really appreciated to see TeamViewer company provide native application on OS that represent less than x% users (hope 10% but I guess it's lesser).

    As many users, I really missing feature available on version 12 like
    - revert screen control
    - Meeting session

    But i'm sure it will come soon, now the code is cleaned, and ready to receive features, at least the same as was available on other platform for the same client version

  • CSylvain
    CSylvain Posts: 13

    had to remove teamviewer_13.0.9865.x86_64 at remote system
    in order to install teamviewer-suse_13.1.3026.x86_64
    otherwise package manager would report a conflict.

    after that, had to (re)assign remote system to my account again to complete the upgrade

  • M4CC4
    M4CC4 Posts: 4

    Daniel, like most of the posts on here so far...thanks to you and the team for this update... I am now more confident in my choice to upgrade my multi OS environment up to 13 now that linux is usable...Great job so far, please keep going.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @richardfoleher: Yes. Press Ctrl+F, "host" to jump there.

    @exactt, @JM325, @FlorianATM, @M4CC4: Thanks, I apreciate it :robotvery-happy:
    Actually, market share is way below 10 percent. 1%...2% is realistic. Higher numbers usually include ChromeOS. But world dominance is only 35 years away. :robotwink:

    Ctrl+C (or Ctrl+[CVXYZ]) should work just as well as using the context menu. It would be helpful if you could try to isolate in which cases it doesn't. (e.g. a certain desktop environment, OS, working again after a reboot...) You can use the Help/Feedback form to send a detailed report and possibly attach log files.

    @MalteGerth: I think you still can do most things, as you can gain Administrator privileges after connecting as well. Of course I understand that you miss it. It's scheduled for the next update.

    @CSylvain: That is by design. You are expected to remove teamviewer in order to install teamviewer-suse. Unfortunately, yes, removing the package also removes the assignment. I added that in the article. Thanks for the pointer. :robothappy:

    Best regards,
    Daniel

    Linux Developer
  • Thank you @DanielStm, but gaining Administrator privileges is not possible, as the password dialog is not be visible in TeamViewer, if you only connect with TeamViewer authentification.

    The Windows Client still has the feature to use the Windows Authentification Mechanism connection to a Windows host.

  • cowst
    cowst Posts: 8

    Hi, I did not use my mobile (Android) device) for a while, but today (and yesterday I updated my Linux host) I get from the phone a license not matching the host.

    They are both 13.1 (no further updates visible).

    Any idea?

    Thanks

  • mozo
    mozo Posts: 28 ✭✭

    Thank you for your great work, it's appreciated :)

    Hotkeys doesn't work for me either. If I use Ctrl+C, Ctrl+V, Ctrl+Z etc. it begins spaming the related letter C, V, Z etc. infinitely until I press Esc. This problem is present since the first native version 'till now.

  • duki92
    duki92 Posts: 2

    Thank you for your commitment.

     

    However, I rely on communication with the person on the other part of remote connection. Either audio or simple chat, however as this isn't possible due to current limitations. I was hoping it will come soon, but... Due to it being neccessary for my work, I'm forced to use Windows, which is driving me you know where.

     

    Looking forward to incorporating at least chat in a remote connection.

     

  • ndit
    ndit Posts: 9

    Great update Daniel, this version will be 100% usable for me as it looks by the features. Just did my first "quicksupport session" with a costumer. Working great.

    I know there is many missing features and possible improvements still, some of the very important for some. But for me, the important stuff is now covered. I won't have to rely on my windows VM for teamviewer daily anymore, but maybe still on some occations.

    Good work, keep it up.

    For me personally, chat and meeting would be the next wanted features.

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @MalteGerth: okay, fair point. (I think it's only if it's a non-installed TeamViewer). As said, it's scheduled to be fixed.

    @cowst: As far as I can tell, the license activated on your account is TV11, which likely is the issue. If you need help to activate a newer license, please contact support.

    @mozo: On the Ctrl+C issue, please join this thread: ctrl key not working.

    @duki92, @ndit: So both of you want the in-session chat rather than the Computers'n'Contacts Chat? That's good to know. So far, I didn't think it to be as important as the other one.

     

    Linux Developer
  • mozo
    mozo Posts: 28 ✭✭

    Thank you DanielStm, it's already done :)

  • duki92
    duki92 Posts: 2

    Yeah, in-session chat. Let me explain my situation as I don't really know a lot about these things:

    I work as an online teacher. When there are issues, connectivity or any other kind, they connect to my computer to test my connection, check platform related stuff and so on. Once they get connected, I need to inform them of issues I have so they can help me. I guess I can do that only via in-session chat or audio communication.

    I have no use of computers'n'contacts chat (since different it person connects each time) and to be honest, I didn't even know it existed until it was announced in previous update and I thought it was about in session chat, hah. :)

     

    I guess audio commmunication may be a bit easier for me, but it doesn't really matter, I would be happy with any of these 2.

     

    Thank you for your support. 

  • CSylvain
    CSylvain Posts: 13

    user feedback: sessions timeout *even while i'm actively typing*
    Linux 13.1.3026 local -> Win10 13.1.1548 remote

  • cranesmart
    cranesmart Posts: 4 ✭✭

    So... where have all the management options gone in TV13 for linux? The windows and linux UI's are now completely different, and Linux UI is missing all of the remote management options (ie: remote update, meetings, etc).

  • QPG
    QPG Posts: 21 ✭✭

    The ability to collapse the menus in the computers & contacts is a serious usability improvement. I'm not confident enough to upgrade my endpoints to TeamViewer13 host yet in case I need to revert to TV12, but I have manged to keep TeamViewer 13 installed on the Linux workstation that I make all of my connections from.

    One item that hasn't come up in the community is the inability to call this version of TeamViewer with "teamviewer --control %f" while passing it a .tvc file. This has broken integration with Solarwinds MSP RMM. Will this capability be returning at some point?

  • Looks like doesn't work.

    I have installed TV QuickSupport 13.1.8752QS on Android 4.1.1 tablet -- and then TeamViewer (teamviewer_13.1.3026_amd64.deb) on Ubuntu 16.04 LTS (had to install libqt5x11extras5 and qtdeclarative5-controls-plugin as a prerequisite). Started QS, got ID. Started TV, entered Partner ID, tried to connect. A dialog "Allow Remote Control?" appears on tablet, I confirm. On Ubuntu the button reverts to "CONNECT", no windows open etc. **bleep**?

    I tried with UDF switched off, no difference.

  • exactt
    exactt Posts: 22

    I think this is not working yet. Some sort of notification would be nice though...

  • What about the Sound Support?

  • @apesofhoveThanks for your reply, I never got any indicator that tells me that it would be a "commercial only" Function. It's simply nowhere visible inside the Software anymore, the whole settings Tab is gone for Audio-Settings.

    Neither is it listend unter the Features of a Commerical License:
    https://www.teamviewer.com/de/pricing/

    I would even consider the "Business" License when it's sure that it's a commercial only-Function! But i don't buy the License blindly just that a Support Member (which you can just approach with a license) tells me that this doesn't work.

    So can a Teamviewer-Staff Member please confirm this?

    @ThePooNSwitching to a different OS is no Option for me, not even in a VM.

    First of all is most of the Software i use Linux specific
    Secondary are there a couple of good Reasons why i gone away from Windows

    I can't believe why no one of the Staff can tell me when the Audio Support will come back :smileysad:

  • sidhant
    sidhant Posts: 1
    gg
  • yolor
    yolor Posts: 1

    1. It says wayland session is detected even on X11 session, not a big deal though.

    2. On 32 bit system i can't connect and i can't see some symbols and menu, on 64 bit everything works. (example in a screenshot). I've tried different themes, launched under new user, nothing is working out. However 13.0.9865 version works on 32 bit system.
    Screenshot_20180419_105121.png

  • Dino3
    Dino3 Posts: 1

    I would like to have fullscreen mode back again!

  • JNA
    JNA Posts: 6

    I can only second @duki92 and  @ndit request. For us, the in-session chat is the blocking feature that prevents switching to TV13 for now. No sound is needed as our support sessions often take place in very noisy environments and with people not fluent in english.

    Basically, in our remote support sessions, we use in-session chat every time, and sometimes file transfer.

    When chat capability was announced, that was relief (the chat feature is already a bit clunky in TV12, because the chat window can't get the focus), just to discover that it is in fact instant messaging. So please, please, please, push this feature closer to the top of the requested features.

Sign In or Register to comment.