teamviewer.com link icon
or
Ask The Community

Black screen after updating to Winver 1803

When connecting to machines I've had no problems connected to for years, the screen is now just a black box after updating to Windows 10's newest "feature" update (winver 1803).

Confirmed all three machines (this one and the two remote PCs) are using the most up-to-date version of Teamviewer. I updated one of them to Winver 1803,  stillsame issue.

issue_tv.PNG

Best Answers

«13

Answers

  • dube920
    dube920 Posts: 11

    Just as a note, I'm having similar problems with other programs (particularly Snagit just being a gray blob) after the Windows feature update. So that's definitely the crux of the issue.

  • przeban
    przeban Posts: 2

    workaround

    the problem is caused by Intel drivers ( in my case HD Graphics 4600)  . turn off the Intel Graphics device in your computer and the Teamviewer will work properly

     

  • ericortner
    ericortner Posts: 1

    Having the same issue with WIndows 10 after 1803 update with Nvidia Geforce 1080GTX video card.  TeamViewer works like normal if I have an external display connected, in my case via HDMI.  I've updated to the latest Nvidia drivers and that did not resolve the issue either.

  • Julia
    Julia Posts: 292 Staff
    Hi all,
    Thank you for informing us - we will have a look at this and keep you updated.
    Cheers
    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • przeban
    przeban Posts: 2

    HI

    I check Team Viewer on may other updateted computers (all with Intel Graphic only) and everythink work fine. I have problem only on my XPS 15 2014 laptop with Intel and Nvidia graphics. I think the problem is in Nvidia card or cooperation between Intel and NVidia.

    I am IT guy if you need person for some tests I will be happy to help

  • theHawxie
    theHawxie Posts: 1

    Same here after upgrading to 1803. I can see some pre-login stuff, I can even confirm some dialogs before loading desktop but then black box. Remote cursor works.

    The device runs with integrated Intel GPU and dedicated Nvidia GPU.

  • F_Henkel
    F_Henkel Posts: 1

    I can confirm that the problem is related to the Intel HD 4600 Graphics (in my case a combination with Geforce GT 7300 M in a Lenovo T440p). Unfortunately disabling the Intel card completely is not an option as I'm using a Lenovo Ultra Dock with two external monitors which are not recognized by Windows when Intel graphics is disabled (but this behaviour is by design). Currently Lenovo does not offer newer drivers for Intel HD 4600, the original Intel driver for HD 4600 can't be used, only the Optimus driver that seems to be a combination of two older versions of drivers and applications for both Intel and NVidia GForce (the Intel driver is from June 2016). I've also tried to start Teamviewer with NVidia graphics via NVidia control panel but this didn't work when external monitors where connected.

  • angelogiordano
    angelogiordano Posts: 1

    Hi, same problem with an Asus ROG 752 VT (Nvidia Video Card).

    But I found a little workaround (if you have a VPN with the network in wich the pc is located):

    1 - install openssh server (it's an easy task, google for it)

    2 - connect via ssh to your pc

    3 - stop and the start teamviewer's service:

        * net stop TeamViewer

        * net start TeamViewer

    4 - then reconnect and wait 20 - 30 seconds: for me the black screen disappears and the regular desktop retuns.

     

  • dube920
    dube920 Posts: 11

    For the record, the machine I'm connecting with just a laptop and has the Intel onboard graphics and the machines I'm connecting to have Nvidia graphics cards (one's a 1070, the other is an older one. 900 series maybe?).

    All 3 machines are on winver 1803 and have the most recent graphics updates. 

    When connected with the laptop to either Computer 1 or Computer 2, I just get that black screen. However, Computer 1 and Computer 2 can remote control each other just fine. So the issue seems to be isolated to this laptop, for some reason. Which isn't great because Computer 1 and 2 are at my house, I use the laptop to remote in when I'm, yaknow, not at home.

    Anything on this problem from Teamviewer yet?

  • Julia
    Julia Posts: 292 Staff
    Hi all,
    Thank you for your feedback in this thread.

    After talking to customers and users we figured out that most of the problems can be solved by installing a graphic card driver update. Not all manufacturers are yet compatible with the new Windows update but please check if there is an update for you graphic card driver.

    Cheers
    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • dube920
    dube920 Posts: 11

    I tried that with both my remote computers, no dice :c Hopefully it helps others though!

  • Mark_W
    Mark_W Posts: 3

    Discovered another way - press "refresh screen" under "view options" in the view menu. See if this works...!

  • dube920
    dube920 Posts: 11

    No dice with the screen refresh either :c

  • zsuraski
    zsuraski Posts: 13

    First off, I believe I have some good news.  There is a *REAL* workaround for this issue, and I can confirm that it's working fine for me on an Intel HD 4600 machine.  No, it's not asking TeamViewer to refresh the screen or anything of the sort, and it doesn't involve updating drivers (even though I did that too, and it is possible[*] to install the latest Intel driver on OEM machines like Lenovo's or HP's, but it doesn't solve that problem).

    The solution is simple:

    - Right after you connect to the remote system and experience the blank or otherwise corrupted view - hit Ctrl-Alt-Del to access the Windows security screen, and then hit ESC or Cancel to exit it.

    That's it - problem solved - the TeamViewer window will be redrawn, and from that point onwards - everything seems to work fine (you don't have to continue doing it or anything of the sort;  The window will be properly drawn until you disconnect from the remote computer).

    Yes, it's annoying to have to have to use this workaround - but honestly, it's not that much of a big deal to do this once per connection, and it's certainly much preferable to practically not being able to use TeamViewer at all in the relentlessy pushed 1803 update.

    TeamViewer folks - perhaps this can help you in some way to fix this problem outside the realm of a particular driver?

    Zeev

    [*] https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

  • dube920
    dube920 Posts: 11

    ctrl+alt+delete didn't work for me either D: 

  • zsuraski
    zsuraski Posts: 13

    Hmmm, that’s weird.  Are you on an HD 4600?

    It might be that you still need the latest driver installed as well for this workaround to work - as this is the only setup that I tested.  But it’s been working remarkably well for about a week now.

  • dube920
    dube920 Posts: 11

    I'm on Intel HD 5500, graphics drivers are fully up-to-date. Super frustrating, Windows needs to stop pushing these updates out before they're actually tested.

  • zsuraski
    zsuraski Posts: 13

    I wholehearted agree with you...

    Just one last ditch question - when you say they’re fully up to date, did you manually install the latest ones from intel.com?  Using the workaround that I mentioned in my first post?  Because the ones I for from Windows Update were a lot older.

  • dube920
    dube920 Posts: 11

    I manually installed the latest ones from Dell for my machine. But that's a good point, I'll have to try Intel's and cross my fingers they have an update Dell didn't.

     

    edit: The driver from Intel's website told me to use the one from Dell. Bah.

  • zsuraski
    zsuraski Posts: 13
    It was the same on my HP - but see the link in my first post to see how to bypass it!
  • natan069
    natan069 Posts: 1
    It worked for me.
    Click View > Screen Resolution, and change
  • dube920
    dube920 Posts: 11

    Still no dice after trying everyone's suggestions </3

     

    Unfortunately at this point, I'm going to have to start looking at alternative programs. 

  • Waratino
    Waratino Posts: 1

    View > Refresh Screen works great for me.

  • vfallico
    vfallico Posts: 2
    You've demonstrated that this is a bug and not the video adapter driver issue. I hope Microsoft can patch the error at some time.
    This workaround works nice. Thanks!
  • dube920
    dube920 Posts: 11

    Update from my end:
    Still not working despite everyone's fantastic ideas. For now, I'm just stuck using Microsoft RDP.

    However, Snagit support did fix their similar issue (just a grey screen) by changing a registry key:[HKEY_LOCAL_MACHINE\SOFTWARE\TechSmith\SnagIt\18]
    "ForceSoftwareRendering"=dword:00000001

    TeamViewer doesn't seem to have a similar reg key for me to piggyback that fix off of, but I'm sure a TeamViewer dev would be able to reverse engineer that fix for TeamViewer, if I could somehow get that information to them.

     

  • I have this issue also. When logging in from the desktop version of teamviewer to a windows 10 1803 client (AMD Ryzen, 8GB, GTX 1080ti) I get a black screen which will not clear.

    However, if I use the mobile (iOS) version of TeamViewer, even though I get a black screen upon connection it clears after 30-60s.

     

  • Variazioni
    Variazioni Posts: 1

    Intel HD 4000 is black screen too!

    After update 1803.

  • DavidIQ
    DavidIQ Posts: 4
    I'll add my name to the list. Using a Lenovo ThinkPad with an Intel HD 5500 graphics card and having the same issue. I've forced it to use the latest drivers version from the Intel site using the generic drivers, but that didn't help. This is definitely a Windows issue though since I'm having major issues with the BlueStacks application as well.

    Today, while browsing around for a solution, I found out that there is a TeamViewer Remote Control Windows native application in the app store so I've tried that one and it works fine. So, for now at least, that will have to do for logging into remote computers instead of the standard full Windows version.
  • solonsky
    solonsky Posts: 1

    Same issue here with Intel HD 610 and Nvidia GPUs. Both drivers are up to date.

    The fact that 'View > Refresh' trick does the job means that the issue CAN be fixed by TeamViewer team (with an automatic force-refresh or smth) in the future updates.

    'View > Refresh' workaround works fine when connecting from a PC, but if you're connecting from mobile the first attempt will fail (asks for a password for some reason), only the second one will be successful, which is annoying.

    Enabling Multi-Monitor Support for iGPU in the motherboard BIOS solved the main issue for me: now the black screen refreshes itself in a second or so, no need to dig into menus. The mobile issue is still there however.

    Hope this helps.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!