Host only working if someone is logged in

mawadidres Posts: 1
edited May 2023 in General questions

I installed teamviewer host on a Windows Server 2016. The teamviewer service is installed and running (under local system).

The problem is that it is only possible to use teamviewer as long as someone is logged in at the server (local or RDP). If no user is logged in and I try to connect teamviewer says that teamviewer is not runnung.


  • Scotty
    Scotty Posts: 493 Staff member 🤠

    Hi @mawadidres

    Thanks for posting!

    I would reccomend you check out our Knowledge Base article on Working with Windows Servers

    You need to Check under "Help" > "About TeamViewer" and make sure you are connecting with the server ID. You can only connect to a User ID if that users RDP session is running.

    Windows server have Multiple TeamViewer Id's. Both the server itself and each user with their own RDP profile will be given their own TeamViewer ID. This is called "Enhanced Multi-user Support" and is so you can jump directly into someone elses RDP session if needed.




    I hope this answers this for you.


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • jlowder_wccs
    jlowder_wccs Posts: 1

    I am having the same problem, but I dont have those options...  whether or not I am logged into teamviewer on the server.



  • peteviewer
    peteviewer Posts: 2 ✭✭

    I have the same issue.

    I understand I can get the "server id" and connect that way.

    But how do I add that "server id" to my list of computers/address book associated to my account.

    I tried changing the ID of the machine in the address book, but that field is read only.

    Weird that I only have this issue on one server.

  • peteviewer
    peteviewer Posts: 2 ✭✭

    I tried deleting the existing contact from the list and then readding the contact with the "Server ID" as the ID, but it keeps telling me the contact is already in the list.  I double checked.  it is deleted from my contacts, even stopped and restarted the application.