Teamviewer is running an old version which is out of date / no connection anymore !!



  • JoshP
    JoshP Posts: 895 Community Manager 🌍

    Hello @CTCOSystems 

    Thank you for your post.

    If you are licensed for TeamViewer 9, you would have no issue connecting to said devices from your licensed version. Connections from later versions would require a newer license.

    If you do encounter any issues when making connections to/from your licensed devices, I would recommend reaching out to our support team directly so we may further assist. You can find local numbers here.

    Josh P.

    Senior Community Moderator


  • obnoid
    obnoid Posts: 1

    This is incredible. I have the same problem; I'm on the free version - using version 14.4.2669 I had my father update his version to the same because it wouldn't let me connect to his computer. I still can't - it says he has an out-of-date version, which is false. He, however, can connect JUST FINE to me! Now why is that? Why can it connect in one direction but not the other?

    What is the fix for this already, TeamViewer mod? FIX THIS NOW.


  • I solved my problem by updating Teamviewer software in my computer and client computer. (Same version) .

  • I thought higher version TeamViewer has backward compatibility with the older versions?

  • enano
    enano Posts: 1

    I completly agree with you. I have that insane problem with my clients which i must give technical support and I cant do it because they keep updating the office TV to v14 so they can connect from their homes. Really BAD strategy from Teamviewer. I hope they go steps backward on that harmful decision

  • itchibahn
    itchibahn Posts: 8 ✭✭

    I originally bought lifetime license at version 9, then upgraded to version 10 lifetime license.  I have been, and still am constantly battling with my client's host being updated, requiring me to visit onsite to reinstall.  Now, in addition to it, I get this "Version out of date" message, and cannot connect.

    What happened to Lifetime License?!?!  Legally, isn't TeamViewer liable for breaking the promise?

  • JeanK
    JeanK Posts: 6,981 Community Manager 🌍

    Hello @itchibahn,

    Thank you for your message.

    If you have a lifetime licence in version 10, you shouldn't get this message.

    If you have this message, this means the license is not correctly activated on your (or the remote) device.

    Please open your TeamViewer 10, go to Extras --> Activate license and enter the license key that is indicated on your invoice.

    I hope this could help. If not, do not hesitate to ask your questions here.



    Community Manager

  • itchibahn
    itchibahn Posts: 8 ✭✭

    @JeanKAs long as the client's host is version 10, I don't have problem login in.  But client's other support guys with newer version, or any free version (including v10), they cannot login.  So they upgrade the client's host, and I cannot login.  I have to visit onsite and reinstall version 10..  And the cycle repeats over and over.  After few times of this nonsense, I gave up.

  • My flavor of this problem was: using current full version of TV on a PC, and using Quick Support for Mac on remote.  On connect, got message that remote needed an update. 

    If only the system had allowed me to connect, in order to perform the update!  The update instructions don't work for Quick Support, which doesn't have an update option in its help menu.  So instead had to coach my 90 yr old mother on finding, downloading and installing the latest version, without being able to see: so difficult and time consuming!   

    After update to latest version of Quick Support, STILL got the message.  Came here, read this and other threads, got frustrated, searched for alternatives.  Surprised to learn that Chrome browser offers a remote assist tool. 

    [Removed per Community Guidelines]  Uninstalled TV both ends.  

  • testerdavi
    testerdavi Posts: 6 ✭✭

    I am getting an error that the remote Team Viewer is running an old version which is out of date.  Therefore you cannot connect to this Version anymore. But i Installed latest version 14.6.4835.

    But this error is shown even if there is no remote system.

    And also getting error," A connection could not be established Reason Unknown "


  • Natascha
    Natascha Posts: 1,591 Moderator

    Hi @testerdavi 

    Thank you for your message. 

    Can you please make sure to install the latest version 14.6.4835 on BOTH sides of the connection?

    Maybe it helps to uninstall the remote TeamViewer with all settings and download it again from our homepage and instal it completely new. 

    Please try it and let us know, if it worked. Wish you a great day. 

    All the best, Natascha

    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • testerdavi
    testerdavi Posts: 6 ✭✭

    hi @Natascha 

    It throws the error even before connecting from remote.I cannot connect from the otherside.

    I installed  14.6.4835 version in my system.

  • Natascha
    Natascha Posts: 1,591 Moderator

    HI @testerdavi 

    Thanks for the fast answer. 

    There is no other possibility, but to update it manually now. 

    Please make sure to run V14.6.4835 on the remote side as well. 


    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • testerdavi
    testerdavi Posts: 6 ✭✭

    hi @Natascha 

    I am getting the error even before connecting from the remote side(Didn't even start the teamviewer on remote side)

    Actually i am getting this error while trying to start a remote session .This error popup before no partner joins the session.

  • testerdavi
    testerdavi Posts: 6 ✭✭

    Hi @Natascha 

    Thanks for your support.

    Let me explain the problem in detail.

    I am creating a seesion code , in my system(Service queue -> create session code), a End Customer Link is generated.


    Then while giving connect (In sessions tab in Service queue) for that session,it opens the teamviewer application. And i get this error.


    The problem here is I'm not able to initiate the session which I have created in my teamviewer which has been updated to version 14.

  • Kuppo
    Kuppo Posts: 11

    Remote Support Sessions were not supported in Free License. If you are in Trail Period you could use could use them for limited period. Once trial is expired you have to purchase the license to continue using it.

    It would have been better if proper error message is shown up.

    Have a good day!

  • Whitedavidp
    Whitedavidp Posts: 14 ✭✭

    Yes, I too have found that older versions of Android have no upgrade path for Host or QuickSupport. This ia a real shame. When something is working, why does it have to be "fixed" in such a way that long time users are cut out? Not everyone needs or wants to buy new hardware all the time.

  • jbsbigboy
    jbsbigboy Posts: 2 ✭✭

    Has TeamViewer considered improving the dialogue prompt?  As a licensed user of TV 12, it caused a lot of hassle until I figured out I just needed to be logged-in to TV.  I use the same TV app to provide friends quick support as I do for work PC's.  In the past, you never needed to be logged in to do this.  You justed needed their ID and password.

    Perhaps the dialogue could indicate that logging in is a possible solution?  Also, provide a Cancel button on the dialogue please.

  • yes... magically transport yourself to the other side of the globe to admin a machine that you installed TV on to be able to do remotely!

    Incredible short sidedness by TV!

    (also no i dont use auto updates because I like to test stuff deployed on remote machines before i use it.)




  • francwalter
    francwalter Posts: 5 ✭✭

    OK, I think that last nag-action did it for me: I will try **Third Party Product**.

    I used TeamViewer mostly to help my remote mother. Up to TeamViewer 11 (since some versions before) there was this (free) feature to block the user imput. Very important with helping people who cannot stop to move the mouse etc. That for,  I had installed TV11 on my mothers Computer, as Admin and she is working as normal user. I disabled updates to keep v11 there. Now I cannot connect anymore (even not if I use TV11 as well).
    My next visit will be only in months, so till then I cannot help her (no, she is not able to install an update etc.).

    Goodbye TeamViewer, I followed your business policy from v3 to now, it went worse and worse. I had several "Commercial use detected" attacks from you, now this.
    Now it is enough.


  • Tired thus and still claims to be out of date 

     Are you trying to get people to pay for the version 

  • Hi,

    are there any solutions for unlicensed older versions? I use TV to provide accasional support to remote art installations. One of these installations is a 2011 mac mini which cannot be upgraded to Mojave (10.14) and therefore cannot be upgraded to TV V14. I tried downgrading the manager PC to V13 but this gave the same error.

    As an artist there is no money available to pay the license fee for such an occasional (but important) use. Alternatively, are there any cheaper license options for a non-commercial user ? (ie MUCH cheaper).

    TV seems to be a great solution for my infrequent use and I have only had to use it three times in 12 months; it is unfortunate that the last time failed due to this upgrade issue.



  • Hello,

    This new update is useless.

    I have an older version of the iMac, which makes it impossible for me to update the iOS system and without it I can't update to the newer version of Teamviewer.

    My macbook is compatible but I can't even use it to login to my iMac due to this version out-of-date problem.


  • Same problem, but I ve got a valid licence with 8 "canaux".

  • arminems
    arminems Posts: 1

    What makes no sense is the following situation:

    I have a computer that is not only remote but in a different country. I used to easily access files. now, i want to update the teamviewer to the newest version but from afar. Joke of the year is: I cannot log / connect to that computer via teamviewer in the first place to do the update as all the teamviewer posts claim. 
    Don't you think it would have been more logical to grant the user a one-time connection alert to update on BOTH ends and THEN block connection possibility in case they ignore the message????????? 


  • The remote TeamViewer is running an old version which is out of date

    This refused me to connect to the remote machine. With Error : Unknown

    Can you please update the TeamViewer to the latest version on both sides?

  • The point of a remote control app is to remotely manage remote machines. Unfortunatley this update killed the ability to manage remote machines, even for Team Viewer update purposes.

    At a company level we are global positioned aka..... remote machines.

    The company (2300 employees so reasonable!) took the decision to remove TeamViewer as a solution due to this.

    On a personal note, my family lives 5000 miles away in Europe, I personally cannot update the machines from the US I have to wait until i next visit them. I also plan to remove TeamViewer on a personal tool basis.

    Once you are their just update? Yes I could, but I no longer trust TeamViewers management to do the right thing and not screw me again in the future. I'm sure this experience taught them something, but I havent even seen a public recognition of the issue... At least Sonos put their hand up and admitted they had made an error when they suggested a similar direction... 

  • Way to go on breaking a good product.  This new license model stinks and there too frequent upgrades forcing us to upgrade everything.  This is not feasible.  Way to go Teamviewer on forcing us to look for an alternative product due to idiocracy policy decisions.  Prior to TV 13 everything was perfect.  we could upgrade when it was right for us not for you.  And now a yearly subscription model with as many upgrades to new versions making Microsoft Windows Feature updates look slow.   You should fire whoever made this decision and bring back the good old Teamviewer company that made you great in the first place. Now you've gone to **bleep**