teamviewer.com link icon
or
Ask The Community

Updating to the latest and greatest version of TeamViewer.

I am now a pensioner (I was an IT engineer 20 years ago) and cannot afford to upgrade my home systenm. Currently I run Windows XP SP3 on all my 4 systems here (CCTV, File Store, workstation & laptop) with Teamviewer 9 on all  (for instance the file store is running on an Intel Pentium 500 as it is stable and doesn't need a fast processor)
I tried Teamvewer 11 but had a bad experience a couple of years ago. and reverted to back version 9 
What is the latest stable version of Teamviewer that will run on all my systems

Comments

  • Ying_Q
    Ying_Q Posts: 853

    Hi @DavidC ,

    Thank you for your post.

    As you are using Windows XP, you may check out the lastest version compability by clicking here. Also you may visit the page of Enjoy using the best version of TeamViewer we made so far! to start the lastest TeamViewer.

    Hope you like it. Have a great weekend.

    Ying_Q

    Chinese Community Moderator [on leave]
  • DavidC
    DavidC Posts: 7

    Unfortunately that link did not answer my question regarding a version compatible with Windows XP

  • DavidC
    DavidC Posts: 7

    According to the link you mentioned the version I should be using is version 4, I sucessfully run version 9 but I am told that I will not be able to use that in less than a months time. What doi I do then please?

  • Ying_Q
    Ying_Q Posts: 853

    Hi @DavidC,

    If you are still using Windows XP SP3, you should be fine to use TeamViewer 14 on it. 

    Please note that TeamViewer are no longer actively servicing Windows XP, Windows Vista, Windows Server 2003 and Windows Server 2008. You can continue using the last supported version of TeamViewer on those operating systems, but we are no longer providing updates or fixes which are specific to them.

    Regards

    Ying_Q

    Chinese Community Moderator [on leave]
  • DavidC
    DavidC Posts: 7

    I am surprised that you say version 14 will be fine, I tried 11 some years ago and it would not run on my systems, hence the revertion to verion 9. At the moment I am unable to use even 9 as I keep getting " suspected commercial use" warnings and my ability to remote control is terminated after 42 seconds, making it pretty useless. Also I keep getting warnings that my use on Teamviewer will terminate on the 18th of June

  • Ying_Q
    Ying_Q Posts: 853

    Hi @DavidC,

    Feel free to visit the post of TeamViewer thinks I am using the software commercially to submit the form for TeamViewer usage reset.

    Regards

    Ying_Q

    Chinese Community Moderator [on leave]
  • DavidC
    DavidC Posts: 7

    Thank you for the link, I have sent a usage report and hopefully they will remove the block

    David

  • I can not log in

  • DavidC
    DavidC Posts: 7

    I sent in yet another request and all I get are acknoledgements of receipt but so far nothing else. I still cannot use Teamview as it dumps me after 42 seconds

  • how can i register my teamviewer id  with license..please guide me...Thanks in advance

    Sanji
  • The is not acceptable to me. The computer I want to control is at my winter home running the security system. Now I cannot connect and have to wait until I travel there in a few months to update Teamviewer because I cannot update remotely anymore.

  • There is NO REASON that all these versions cannot be backward compatible!

    The same shyte is going on the Mac side also. I cannot upgrade my system..yet I have clients and family that need my help. They are not exactly the elite types who can change their systems every 2 **bleep** years!

    No excuses.

     

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!