teamviewer.com link icon
or
Ask The Community

unable to activate privacy screen ( black screen)

Hello everybody

i try to use the privacy feature to make my laptop go black when i connect to it.. but it doesnt work.. drivers get installed properly and correclty shows up in the device manager.. just the screen doesn't go black

how can i fix it?

i have a nvidia gtx 1070 and i'm clueless about how to do that.. i also have an IPS  g sync monitor 

 

thank you!

Comments

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @crushy888

    I assume that you have configured the laptop device from your TeamViewer Host as shown here. Alternatively by assigning a specific policy.

    How many video cards are installed on your laptop?

    Let me know

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • crushy888
    crushy888 Posts: 8

    hello

    ty for your answer

    yes i set up everything as in that thing you posted

    i just have one graphic card ,gtx 1070 nvidia( laptop version)

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @crushy888

    I just saw that you also spoke of a secondary monitor. Do you have a special configuration to handle this second monitor (duplicate monitor or extend monitor) made by operating system (Windows 8-10)?

     

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • crushy888
    crushy888 Posts: 8

    wait where did i say that? i have no secondary monitor, it's just a laptop with his ips panel 

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @crushy888

    I've read "I also have an IPS  g sync monitor" Probably that word ("also") has deceived me. I was pretty sure your laptop was equipped with its built-in monitor...

    In any case, I'd suggest trying to uninstall and reinstall the TeamViewer Monitor Driver from your laptop.

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • crushy888
    crushy888 Posts: 8

    oh sorry.. i explained my self wrong.. and ty for helping.. i've been trying install and resintall it many times  but it doesn't work

    thank you anyway :))

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @crushy888

    don't worry!

    One test: automatic black screen doesn't work. But what if I set up the black screen during the connection? Screen turn off or remain switch on?

    You can find this setting from action panel during connection: if it is set ON (black screen) so swich OFF, then again ON.

    What happen?

    Let me know.

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • crushy888
    crushy888 Posts: 8

    i tried that too! nothing works..

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @crushy888

    let's look at TeamViewer logs

    Could you include here all the lines that are relevant to the word "blackscren"? We search for phrases related to: tvdesktop::BlackScreen::SignalBlackScreenStateChange

    Regards

     

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • crushy888
    crushy888 Posts: 8

    017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::UserInteractionHelper::ChangeServerInput (inputMode 1)
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::InputBlocker::DisableInputAsync(true)
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::UserInteractionHelper::SendInputChangedCmd : inputDisabled:1; blackScreenEnabled: 0
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::BlackScreen::DisableBlackScreen
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::BlackScreentNotifications::Stop - already done
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::BlackScreen::BlackScrState - moving from BSCR_OFF ---> BSCR_INPUT_DISABLED
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::BlackScreen::SignalBlackScreenStateChange (0)
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::UserInteractionHelper::SendInputChangedCmd : inputDisabled:1; blackScreenEnabled: 0
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::BlackScreen::SignalBlackScreenStateChange (0) -- done
    2017/05/08 00:28:43.408 12612 12388 D1 tvdesktop::BlackScreen::DisableBlackScreen -- done

  • crushy888
    crushy888 Posts: 8

    there's so much more but i could send you my entire logs if you wanted 

  • DomLan
    DomLan Posts: 490 ⭐Star⭐

    Hi @crushy888

    if you want yes, but via private mail. REMOVE INITIAL DATA, with specific information of your PC (TV ID, machine data and so on...)

    Please note for your privacy: This information is not useful and is obviously related to your privacy.
    Only log elements. If you detect IP addresses (unless they are those of TeamViewer servers that are public), delete the value!

    n.b.: I will try to analyze your log, but it will be difficult to complete the operation in the short run. Can I answer you tomorrow?

    Regards

    Domenico Langone
    MCSD: App Builder
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • crushy888
    crushy888 Posts: 8

    sure! i'll send you a pm !

  • any chance i can send you my logs too?

    i got the same issue as OP.

  • MichaelG
    MichaelG Posts: 18 ✭✭

    Please see the message here:
    https://community.teamviewer.com/t5/TeamViewer-12/Black-screen-not-working-Windows-10/td-p/8940

    Install NVidia Driver ver. 378.92 (3-20-17) or older. Versions 381.65 - 385.28 do not allow the black screen to work.

Sign In or Register to comment.