Samsung Knox and TeamViewer



  • Dolphe
    Dolphe Posts: 1

    After the update here are these conclusions.
    QS version 15.2.41 installed on Xcover4 and xcover4S terminals in work profil

    - no blackscreens anymore
    - remote support in personnal side => not working
    - remote support in work profile => Working only if a work application is launched

    for example impossible to go to the terminal settings.


  • @JeanK 

    We are having the same issues with 15.2.41, as we have with the two previous releases.  The new application now displays a disclaimer about screen capture being possible which you have to accept.  We are then presented with a black screen.  As stated previously our organisation actively blocks secure capture (as in taking manual screen shots) on the whole for users however the old version's of quick support, used in conjunction with the Samsung add-on worked even though screen capture was blocked.

    We are using Android Device Admin with Intune.

  • Pierre_Aberg
    Pierre_Aberg Posts: 3 ✭✭

    We have the same problem as ashdroid.
    A fix that we are currently testing out is a restriction policy that enables screensharing, however the policies we can create demands us setting a whole lot of other on/off-features.
    Can you confirm that you are still working on a fix that makes sure that we don't have to use any inhouse restriction policies?

  • DFI
    DFI Posts: 2 ✭✭

    Ridiculous... we pay for a product that doesn't work... I have TeamViewer 15 and android host.  Latest versions.  Continually get a yellow android device in my computer list using TeamViewer fully licensed manager and android host.   We are trying everything in settings found on your site but always issues. We get some many app and device related black screens. We can't use the screen lock, app like lexmark printer app setup we can reas the black screens.  We face angry customers as we have to get then involved in the support. If the TeamViewer worked, we actually need the ability to do unintended support with their screen display frozen with a message stating under support contact your support team for help.... with an option for the customer to break session.  So we can do support without the user seeing us work... That is required when the devices are sole purpose devices that we configure for the app process that we do not want our customers to see. These are all android Samsung Galaxy or Active PRO products  running android 9 and 10.

  • Pierre_Aberg
    Pierre_Aberg Posts: 3 ✭✭


    See the comments in this thread, this is still not working for our organisation and others that has commented.
    For a supportdepartment like ours, this is an utter disaster. We are paying for a service that you basically broke when trying to make things easier for us.
    When will we see another fix that actually works?

  • Hi,

    I am able to connect to samsung mobile through PC.....even able to access and control apps on mobile but can't access apps which have disabled screenshots on their app (shows black screen)...... Earlier it was possible due to samsung Add on..... Please help

  • Hi, @Esther 

    I have downloaded the Teamviewer Host (version 15.2.22 HM) for my Samsung phone (Android 8.1.0). It activated the remote control successfully (no add-on is needed), but the new problem is that the device just goes offline as long as the screen is locked. So it cannot realize the unattended remote control from another device. But the old version of Host does not have such problems.

    Is there any solution to this? Or is there any new versions can be downloaded to fix this? Thanks!

  • @JeanK  @Esther

    We are having the same issues with 15.2.41, as we have with the two previous releases.  The new application now displays a disclaimer about screen capture being possible which you have to accept.  We are then presented with a black screen.  As stated previously our organisation actively blocks secure capture (as in taking manual screen shots) on the whole for users however the old version's of quick support, used in conjunction with the Samsung add-on worked even though screen capture was blocked.

    We are using Android Device Admin with Intune.

  • Hi.

    Any news on a fix for these issues? We have the same problems with black screen and connection loss on our devices. We are using quicksupport on managed devices and host on unmanaged devices.


  • I've logged a support call and received the following response that basically implies that remote connection, using the new Quick Support application, is no longer possible unless you permit screen capture through your MDM solution:

    "The screen capture option is needed since Samsung reverted back to use Knox as a remote control solution instead of using our dedicated Add-On.

    Therefore that needs to be allowed as it's a Knox requirement."


  • Pierre_Aberg
    Pierre_Aberg Posts: 3 ✭✭

    Thanks for the reply to this board. That's an odd answer given the previous replies from the staff here.
    Still keeping my fingers crossed that they will find another solution, since this one is a pain given our endpoint managment tool.

  • For a personal (non-paid) user, Teamviewer does not allow a ticket to be created, and they don't read emails to [email protected].  So, this forum is the only way to find out about common issues and to submit requests for support.  This thread has recently focused on issues relating to support for corporate device fleets, but the original problem has not been addressed in the latest versions of the software, or discussed here.

    Several months ago, Teamviewer stopped working for me.  When I access my Samsung Tab A using Teamviewer Host on the tablet and Teamviewer Remote Control on either my Windows PC or Android phone, I can connect, but the connection locks within 5 to 15 seconds of the connection.  From earlier posts here, it appears that the recent failure of Teamviewer to provide remote control and quick support connections to Samsung Android devices stems from the fact that Samsung changed the way that the Knox security service interacts (or doesn’t interact) with Teamviewer.  The only capability I need is remote control – I’m not in a corporate or support environment, so I don’t have to deal with any security issues like screen capture.  All I need is remote control.  I believe I have updated everything to the latest released versions, as follows:

    Samsung Tab A model SM-T380 running Android version 9 and Knox version 3.3

    Teamviewer Android version 15.3.49

    Teamviewer Android Host version 15.3.30

    Teamviewer Windows version 153.2682

    Are there newer or beta versions that will work to provide remote control of my tablet device?  If not, is there any likelihood that this issue is going to be resolved?  This application worked so well for me in the beginning that I was ready to purchase a license, but I’m not interested in paying for something that isn't functional.  If Teamviewer isn’t going to be able to address this issue, it appears that **Third Party Product** will be my only solution.  I’d prefer Teamviewer.

    Thanks for any information or update you can provide.


  • Hello, thanks for your attention about the guidance. 

    I have a technical question about breaching the knox by TeamViewer!

    Yesterday was my first experience of working with Teamviewer and bought the enterprise version on PC then remote my Samsung Galaxy A50 and Huawei Honor, on the Huawei device it just asked me to start over screen and installed add-ons on device then remotes correctly. But on Samsung device i faced with a problem about Knox! After the installation of Teamviewer i didn't look what I'm going to click! And just touched YES and ALLOW button! But after the approval process my Knox didn't work correctly and now my internet connection is not stable (the downstream is good but the upstream has a huge problem) on this device i hadn't any problem over the network section before installing the Teamviewer but now it's a nightmare and i don't want to reset my phone! (For your information, i tested the network by wifi and cellular also on other devices like pc, laptop and other phones by connecting through the same wifi and used the same SIM CARD for tests)

    Now I want to exactly know the truth! What changes are made by Teamviewer on my d Samsung device?! What was that notification Teamviewer popped up for me? How do I remove the privilege of Knox's Breaching by your Apk?

    Please let me know about the breaching the Knox technically. 


  • ABCD_Systems
    ABCD_Systems Posts: 2 ✭✭

    This, Standard Samsung s9 phones, with knox, cannot be remote controlled. The screen is black whether in the password screen or logged in, it does not matter. We own these phones, we need to be able to manage them.

  • Hi @Esther ,

    I am hoping to find some help here. Your post looks good, BUT...

    I have just setup intune with teamviewer integration. However, I am experiencing the problem that I can only VIEW the screen of the Android device, but NOT CONTROL it.

    A have purchased a Teamviewer license separately for this, I have have the teamviewer connector in intune configured, and I have the QuickSupport app ( enrolled on devices All phones are Samsung brand - S9, S9+, S10, S10+, and the QuickSupport app is inside a Knox Workspace Container.

    What is my problem here? Why can I only view the screen, but not control anything?

    Any help appreciated. Thanks in advance!

  • Do I really need to press it on each device to make the remote session work? 

  • tw_mama
    tw_mama Posts: 6 ✭✭

    Sadly, incorporating Knox into TeamViewer renders QuickSupport unusable for older Samsung devices that do not have Knox technology.

    I have been using the Teamview QuickSupport with the Samsung addon to manage my 94 year-old mother's Samsung Tab4 tablet (Galaxy Tab 4 7.0" , Model Number: SM-T230NYKAXAR) running Android 4.4. It's worked great and has allowed me to operate her tablet remotely from my Win10 computer to solve problems she encounters. This ability has proven essential since my mother is now isolated in her retirement community with no visitors allowed due to the coronavirus. She is having problems with her eyes. By connecting to her tablet I could use the camera in selfie mode to look at her eye, take a picture for the doctor, and email it to myself.

    When I connected to the tablet on April 27, everything worked fine; I was able to check Mom's eye using the camera. Two days later, on April 29, I was no longer able to control the tablet remotely through QuickSupport.

    I've traced the problem to the app update to the Android QuickSupport app that was posted on Google Play on 4/28/2020 (version 15.5). As a result of this update, I can no longer remotely control the tablet. I can successfully connect but all I can see is the device information (similar to what you see with the Windows Task manager). I cannot reach the GUI to operate the tablet remotely.TeamViewer QuickSupport on Samsung Tab4 after latest update.jpg

    After contacting TeamViewer through their Facebook page about the problem I am having with QuickSupport, I was informed of the following:

    "I have checked with our technical support team.
    Could you please check if you have turned on KNOX support? New Samsung app is done through Knox in TeamViewer app settings. Without knox, you cannot control the phone with TeamViewer. Activating knox is a requirement and is part of our agreement with Samsung to allow remote control of their devices. (Remote control requires manufacturer co-operation).... Unfortunately we do not provide version 15.4. We only provide version 14
    However, if you are private user, you need to use the latest version which is version 15.5."

    From what I can determine, KNOX is a new chip-level technology that Samsung has added to all of their new devices. Since the Samsung Tab4 is over four years old it obviously does not have this technology; nor have I been able to find an app-level method for implementing it. Purchasing a new tablet is not an option.

    The only reason that I am in this pickle is because I was dutifully trying to keep the apps on the tablet up to date, primarily for security reasons, by enabling auto-update. TeamViewer seems to have updated the QuickSupport app without any consideration of the impact their change would have on older devices that do not have the KNOX technology but are still in active use.

    I need the version of the TeamView QuickSupport that was available on Google Playstore before 4/28/2020. TeamViewer has been an indispensible tool for helping my mother. I hope that there's a way for it to continue to be so.

  • tw_mama
    tw_mama Posts: 6 ✭✭

    Where did you find version 15.0.4? I desparately need to downgrade my four-year-old Samsung Tab4.

  • tw_mama
    tw_mama Posts: 6 ✭✭

    Hurray! After downgrading to the previous version I can now control my Samsung Tab4 tablet remotely once again!!! Thanks.

  • Fran-Lima
    Fran-Lima Posts: 8

    After 5 months using version 15.0, it seens the version 15.5.39 HM of the Host app works fine.
    Run smootly for 15 minutes without crash. Samsung S5 Duos G900MD. But it's my spare phone without loging to a Samsumg Account. Maybe the Knox services are disabled.
    When I update the Host app on my main phone, I'll report here.

  • Bayon
    Bayon Posts: 3


    So, how can we remotely control our samsung Devices without Knox (M21 and others). New QS version supports only screen sharing.

    TeamViewer pls help.

  • TVchris
    TVchris Posts: 2

    connection from Win10prof (Teamviewer 15.7.7) to Samsung Galaxy Tab A 10.1 (SM-T515NZSDDBT with Android-10, newest Quicksupport from PlayStore)) does not work. Samsung Knox is allowed, new installation didn't solve this behaviour.

    Connection itself is established, but access to Galaxy's desktop is refused from Galaxy Tab, pls refer to attached screenshot:
    "Ihr Partner hat die Verbindungsanfrage abgelehnt"

    How to get it working?

    Thanks and best regards, Chris 

    Also posted in:

    Best place?

  • There is a problem with Host app at Tablet Samsung Tab-A (T295). It alway ask for permission on tablet to allow remote access.
    Is TeamViewer planning to address this issue?


  • Hi @ashdroid ,

    Have you find a solution? I am facing the same problem.
    Or is there a competitor who can provide remote access without this disclaimer? 

  • It has been more than 9 months since this problem with the Samsung Tab A tablets has been discussed here. Teamviewer has never so much as acknowledged the problem. I think it's safe to say that they have no intention of fixing this problem any time soon. I have moved on, and am using a competing product, which works just fine. If I mention it here, they will delete the link or the post. Just search on "remote desktop apps to control an android device". You'll find the one that works. Pity those who paid for a license.
  • catmouse
    catmouse Posts: 1

    Same issue as others; cannot take control once connected and get "your partner rejected your connection request" from either PC or tablet.

  • Fran-Lima
    Fran-Lima Posts: 8
    Dear Samsumg and TV Host users.
    The TV Host with Knox support has created a lot of problems for new and
    old devices.
    Just for the record, on my S5 Duos (G900MD) the only problem was
    that the app crashed after 1 minute.
    Returning to version 15.0.4 HM + the correct version of the Addon
    solved my problems during these long quarantine months.
    Today I decided to roll the dice and allow the Host to update.
    Now I have version 15.8.77 HM. It's been online for an hour while
    I'm typing this post.
    So I will assume that the problem, at least for me, has been solved.
    For the other problems, some happened to me with the old version,
    so I have some tips.
    Black screen, or no touch response: it happens sometimes.
    Just try again.
    "Without partner authorization" or similar:
    Wait for the timeout and try again.
    Yellow icon does not wake up:
    Eco Mode is a lazy **bleep**. Sometimes I have to try 10 X to wakeup the app.
    And 10 more to start the session. But it works.
    For the other problems I only have one tip.
    Try to delete the Samsung account. It may be that with Knox enabled
    but without a Samsung account, the problem will be solved on some devices.
    Good luck. With TV or other app ...
  • What exactly do you mean by "Try to delete the Samsung account"?

  • Fran-Lima
    Fran-Lima Posts: 8

    Go to Settings / General / Accounts

    Delete the account "Samsung account"

    If don't work, just add again with the previous login data.

  • For the record this problem still exists as of September 28th, 2020.  Teamviewer support stated the fix will be in the next release.  I've dealt with this problem for over six months without any acknowlegement of it being a problem until just last month.