link icon
Ask The Community

Commercial use - Connection time out



  • hdtvguy
    hdtvguy Posts: 3 ✭✭

    Yeah good luck, their site keeps crashing when I try to do this and there is no way to contact them. Can;t wait for when my comapnies commercial license is up for renewal, time to move on as their support **bleep**. 

  • Not had any major problems in the past four years and I now have 200 clients linked to my Premium Account. So unless Brexit causes any problems I will stick with TV for the time being.

    I used **Third Party Product** in the past which I think is US based, so any Brexit spin off problems will not apply, but we will see how things go.

  • TDC
    TDC Posts: 1

    Same here.  Unfortunately, I cannot even subit a reset request.  Gives me a black "error" overlaid on screen after attempting to upload the signed PDF (720kb in size).  If a attempt to start a new post here about it, it won't post either; tells me to correct error displayed before posting but there is no error.  Hitting submit again results in a spam ban for 3600 seconds.  This is infuriating.  

  • So I can't use my personal teamviewer account because I get a message for excessive usage. I haven't used teamviewer in for a few months now aside from using the wake on wan/wake on lan feature as a test with my smarthome usage. Why did my account get locked from remote access for excessive usage? The teamviewer account is on a personal computer.  My account says non-commerical usage but I suspect that teamviewer management thinks my account is for commerical use. I do use my cell phone for work but only to receive calls when my work phone goes down. My cell is for personal usage too. What's going on?

    I can't pay $45 a month for teamviewer for when I am just going to use TeamViewer for personal usage. I don't have the money for that kind of fee. 

  • Whenever I try to go to the Reset management page (  to get my ID reset since TeamViewer thinks that me helping out my Grandparents is commercial use, one part of the page or another gets a 404 and I can't proceed. I have the PDF, but at this point I can't reupload it. getting "Error"2020-11-30_09h08_47.png

  • Yes, I've tried multiple browsers

    Yes, I've tried multiple computers

    Yes, I've tried on mobile

  • Carlyle7
    Carlyle7 Posts: 2 ✭✭

    Teamviewer drops out after 1 minute?

  • I uninstalled TV from all my PCs. I created a new userID under a different eMail address. I reinstalled TV. When I try to connect it tells me I am a commercial user.   Clearly something is broken and TV refuses to even acknowledge that they have problem  If they don't want to allow free users, why don't they just say so?    

    I give up. I'll find an alternate product.

  • I use Teamviewer exclusively for personal use (mostly to help my mom out when she messes things up on her PC and to communicate with my home desktop when I am traveling) and do not use it commercially at all.  For some reason, I was flagged for suspected commercial use.  A week ago, I followed the procedure and submitted the form attesting to personal use only and requesting to be reinstated.  It has been a week and I have not heard anything back and still cannot use Teamviewer.  Does anyone know roughly how long it takes for these situations to be resolved?  Any input would be appreciated.  Thanks!



  • Chuk
    Chuk Posts: 3 ✭✭

    I have same issue (COMMERCIAL USE DETECTED) when I updated to version 15.12.4   Seems to be something in that vers that is blocking 1,000's of free non commercial users.

  • Apparently my Team Viewer ID has been flagged as Commercial.  I don't understand as I only use this software to help my 80 year old mom with her computer when she has problems.  Can someone please help me out?  I don't understand what to do now.  Thanks!

  • Chuk
    Chuk Posts: 3 ✭✭

    Try doing the reset. I did it a week ago, still waiting.  Keep your fingers crossed and hope for the best.

  • Aggravateduser5
    Aggravateduser5 Posts: 2 ✭✭

    I have just spent 2 hours trying to resolve this issue.  Clicking "Generate PDF" does NOTHING!  I have tried it on two separate computers, 3 different browers on every computer, checked my downloads, and NOTHING.  This unsolicitated "decision" teamviewer's algorithms made that I was commercially using when I'm clearly NOT, followed by a broken ability to even submit a request for reconsideration, followed by teamviewer providing NO avenue through customer service for getting help/support is the EPITOMY of poor design and customer service.  Although my use is 100% personal, I do work for a company that is in the middle of evaluating teamviewer and similar products, and believe me I fully intend to provide my 2 cents on how horrible this experience was and recommend against!  Maybe teamviewer just treats their free users like garbage and commercial is a different story, but I'll never know from this experience.

  • gcoleman
    gcoleman Posts: 1

    I've had teamviewer free for a few years and have used it occasionally to help my 78 year old dad with email, etc. A couple months ago I started working from home and use my personal computer to connect to work over a VPN. I have a commercial teamviewer license at work, for work use - but I don't use that to help my dad. That license is for work.

    A few weeks ago he called and wanted help to sort his emails in a certain way. While I was connected to work through the VPN, I used my home computer to open up the home - free version to help him. Teamviewer instantly complained about commercial use (false of course - check my ID and history please). I went through the process to request a review of my ID and a reset so I could continue to help my dad on occasion. I have heard nothing back from teamviewer and I believe its going on three weeks now.

    How long does the process usually take and how are you notified whether or not the reset would be done? I would hate to have to purchase a commercial license for those few times a year my dad needs help. (He lives 117 miles away). I tried to go through the reset process again, but the page tells me "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request."

    Thanks for the input or suggestions.



  • Not working for me

  • Teamviewer stopped working. Every time I try to connect to my mother's computer (PERSONAL USE!!!!) it says connection is blocked after timeout. It then sets the timer for a minute out and still does not allow to connect. I tried using latest version, prior version, all the same. This software simply DOES NOT WORK. 

    fix it???


    ... and it thinks I am flooding the message board, so it is not even letting me post this message. GREAT!

  • Didn't understand a word of this - and appears to be not really relevant to the previous posts.

  • Aggravateduser5
    Aggravateduser5 Posts: 2 ✭✭

    It's still not fixed.  The "Generate PDF" button does nothing, on multiple computers and multiple browsers. And with Teamviewer not allowing free users to contact customer service (and this forum apparently being manned by frustrated users and no teamviewer staff), what is a person to do except give up and switch to other software platforms?

  • Natascha
    Natascha Posts: 1,553 Senior Moderator

    Hi @Aggravateduser5 

    Thank you for your post and the heads up. ?

    I will let my colleagues know that it's currently not working. Will keep you posted in this thread if there's any news on that. 

    Thank you for your patience and I'm really sorry for any inconveniences caused. 

    Have a great day. 
    All the best,

    German Community moderator 💙 Moderatorin der deutschsprachigen Community

  • [removed per Community Guidelines]

    TeamViewer has been uninstalled from all my PCs.   

  • Saw your original post before TV removed it.  Thanks for the suggestion - I've been trying to find something else to use.  I will try it.


  • Best to get a cheap paid account in that case.

  • gcoleman
    gcoleman Posts: 1

    How long does it take for teamviewer to review a trouble ticket? I use teamviewer at home to help my dad, and also have a paid version at work for work activities. I work from home and had my VPN running when I logged into my home teamviewer to help my dad. I was instantly shut down with the commercial use warning. I submitted a ticket almost a month ago now and have not heard anything back. I tried to submit another ticket and the message says something like please be patient your request is being reviewed. Do the requests ever get reviewed or do I need to search for another remote software? I'm not buying a license to help my dad 4 times a year, and I am not using work resources for personal use.

  • I really shouldn't be wasting more time writing this here, but I might as well see if there's anyone home that cares:

    I found a link you put into a comment response to a license reset:

    Like a fool, I followed it and thought I could just ask for a reset. Instead, it erased my input over 10 times, I had to use two different browsers, erase cookies 25 times, RE-Log in another 25 times.... Just to see if I could try to hit a button that said,: "Saving to PDF", watched for about 90 seconds, and then a cryptic message that said ERROR --- nothing more!!

    Here's the last message.... Maybe someone could post some REAL email addresses I could just use instead of form pages that are obviously broken and won't work. If not, I might take on the mission of finding anyone and everyone I can find, until someone listens:

    "" Can I get my TeamViewer ID reactivated?

    If you're using TeamViewer for personal use only and you have received the messages 'Commercial use suspected' or 'Commercial use detected', we're here to help you.

    'error' ""

    Really?? ""ERROR"" with NO explanation??

    • < ----------------------------------------------> NOTE that the following could NOT be submitted, since the previous error prevented it, evidently.
    • Oh, and the message that says you can SAVE your work, log out and come back later to submit it??
    • There is NO WAY to save your work that I could find-- it simply erased it and forcefully logged you out instead.
    • Minus the two ID's I tried to submit, and my name and home address this is what I tried to submit: < ------------------ >

    15th try to log in --- this time using a different browser ---  last time it was "Request for permission" on a pure black screen. before that "504 Gateway Time-out"

    I was LITERALLY 10 seconds from hitting SEND, and you LOGGED ME OUT and ERASED all my work.

    PLEASE just POST an EMAIL ADDRESS -- this are ridiculous hoops to jump through!

    I've had about 10 errors just trying to submit this form --- I'll try once more time and then just give up. 504 errors, and the last time, it TIMED OUT and erased everything I was entering here!!!  --- The login screen goes to a BLANK screen, and most of the time, NOTHING is showing, so I have no clue what to do next on this page ---

    I use this T.V. at Home -- ONLY at home, unless I am, or was, at my Mother's retirement community in St Pete --- (Which is now impossible to visit-- COVID.) --- I have these devices at home, with just my wife and myself: 2 laptops (Windows PC's) 2 phones, 2 tablets and a few TV dongles, 2 Fire TV's, 2 Roku's, and 1 Android TV. -- ALSO, OLD PCs that I still have, but are replaced -- One of which is ON, but only displaying the TIME and not logged in. -- NOTE that various OLD devices that are not turned on are most often used, just to get OLD data from them to my current devices.  

    In the past five years, TV failed me when I needed it most. I couldn't make it work for more than 20 seconds -- after not using it at all in the past year. At home, 99% of the time, it is easier, faster, and quicker to use VNC. On rare occasions when I am out, I now use "Remote Utilities" 10 user license, which covers all my devices. Luckily, Remote Utilities did what I needed. FYI, your 5 minute timeout STOPS after 20 seconds now.  And, it says I can reconnect in x minutes, but then I never can--it just gives a new time, and then fails immediately, and then an new time.

    Check my logs --- I haven't used TV now for years --- maybe 10 minutes at most-- total time. I promise, I won't install it on anything new. And, I won't recommend anyone try to use it, unless they erase it, lest they think it will work when it will (or might) fail when needed the most.

  • same thing happened with me

  • bertbatman
    bertbatman Posts: 8 ✭✭
    edited December 2020

    [personal information removed]this pc number

    Why did this id start to be blocked as commercial use?

    I have 10 pc in my family and what is this use now?

    Look how many times a year I use the connection and this is only in my PC!

    To sell me for money, you first make backward compatibility of the product versions so that you don't have to run to the PC where you already see an outdated version and you can't connect to it.

  • bertbatman
    bertbatman Posts: 8 ✭✭

    and what is it so stupid? Writes in 5 minutes will be disconnected, and blunt will disconnect after 30 seconds

  • bertbatman
    bertbatman Posts: 8 ✭✭
    edited December 2020

    **Please do not post TeamViewer IDs** this pc number

    Why did this id start to be blocked as commercial use?

    I have 10 pc in my family and what is this use now?

    Look how many times a year I use the connection and this is only in my PC!

    To sell me for money, you first make backward compatibility of the product versions so that you don't have to run to the PC where you already see an outdated version and you can't connect to it.

  • TeeElAche
    TeeElAche Posts: 1
    edited December 2020

    Every six months I get a Commercial use detected message. I have installed another remote desktop program because I lose my remote login ability for weeks at a time. I have NEVER used Teamviewer for commercial use. I mostly use it to remote into my home network while I am away from home. What should I do??????