Commercial use - Connection time out



  • IngridB
    IngridB Posts: 0


    I am having the same problem

    Have you found a way to solve it?

  • DBquick
    DBquick Posts: 8 ✭✭

    Thanks to both of you for your comments!

    Hopefully, we get a official feedback soon.

    By the way, I am working also from Germany. Maybe this is a country or continent related issue 🤔

  • MonteChristo
    MonteChristo Posts: 1
    edited February 2021

    Nope, the remote PC is running the latest (at least the check for a new version says so) and the session keeps timing out after 3 or so minutes. TeamViewer is useless to me now. This is on Win 10 Pro 20.04 H2.

  • Heinvomberg
    Heinvomberg Posts: 0

    Hi All!

    I have the same issue with my Win10 version since a view days.

    And no idea, how to fix them.

    Interesting: The IOS version is working properly.

    Will anybody of TV read this blog???


  • PeziSbg
    PeziSbg Posts: 0

    I have the same problem,

    I am using TeamViewer free license since many years, But after the latest update after some minutes the connection has been interrupted. Furthermore, I deleted the program and reinstalled the Free license Version. But the same happened.

    I am predominantly using TeamViewer to connect my smartphone with quick support to my notebook. Sometimes I am helping friends and family members with remote support.

    I am hoping it's only a bug

  • jenskirch
    jenskirch Posts: 1

    Hello fellow sufferers,

    I am also having this problem right now. Based in Germany and taking care of my families PCs and my own ones while I am at my gf's place.

    Getting time outs and blocked from direct reconnects.

    Can't tell when it has started to behave like this, since I am not constantly using it.

    Hopefully it gets resolved quickly.

  • DBquick
    DBquick Posts: 8 ✭✭

    Looks like a big bug!

    Hopefully, we will get a quick response. I wrote a pm to the moderators, maybe it will help us.

    @Moderators: We all have a free license for sure and a commercial use is NOT suspected! @Natascha @JeanK

    (Just to be sure, because I have seen threads of other people regarding this topic which were randomly merged to the "commercial use" topic)

  • MrLargent
    MrLargent Posts: 2 ✭✭

    Same here- one account out of 3 I have been connecting to for many years is now having this issue. I am 100% using for personal/family...

  • dprobst
    dprobst Posts: 0

    Same with me until last week everything ok. Update today 22-2-2021, timeout after some 30 seconds

  • Battousai124
    Battousai124 Posts: 4 ✭✭
    edited January 2022

    Is this how you are trying to bully customers into paying for a commercial license they don't need?

    I have been using TeamViewer for years now and never once had a problem, today however it started.

    I have a stable internet connection, but still, when trying to remotely control my computer that is about 3 meters to my right, because I am a lazy guy, I cannot connect to it for even a single minute, without it giving me the timeout **bleep** and blocks any attempts to reconnect.

    I timed it!!! 51 seconds. 51 seconds is all I get, when I want to use it to control my PC, so I can listen to music with an actual sound system or do anything else.

    Then I get the message, that reconnection attempts are being blocked for 1 minute, of course I wait that minute and of course, after that minute, I get the same message again, with the same 1 minute cooldown.

    I reinstalled the program TWICE!! and absolutely no change in behavior.

    Thank You!


    a former user

  • Frimuz
    Frimuz Posts: 0

    Same Story here. Using it to help a friend with computer problems.

  • Teri_Lee
    Teri_Lee Posts: 0

    Good evening,

    I keep getting logged out of my connection and it says "connection refused due to timeout". I'm not sure why this keep happening or how to fix it.

    Please advise and thank you.

  • DBquick
    DBquick Posts: 8 ✭✭

    Same problem in my discussion. So far, we are waiting for a response

  • Keifus
    Keifus Posts: 4 ✭✭

    I have been having issues with TeamViewer timing out after like 5 minutes I been using the free version and i think maybe someone i connected to installed it commercial and not the private. Can you fix my account back to normal please

  • Tracy1
    Tracy1 Posts: 0

    Same issue here. Worked fine last I am unable to connect for more than a few seconds and then it times out. This is very frustrating as the connection is needed to work from home (and impending deadlines for work are not able to be met due to this new issue). FWIW, I am also in Germany and using a free license for personal use only.

  • urrlich
    urrlich Posts: 4 ✭✭
    edited February 2021

    @Tracy1, I think using TV for doing (paid) work remotely is considered commercial use…

    I'm using it to help (mostly elderly) family members and seeing the same problem.

    Regarding the question of paid vs. free, I would gladly pay something like 5 Euros a month to be able to reliably use it with a small number of remote machines for a limited time. Something like 10 machines and 10 hours per month would be enough.

    Edit: I'm in Germany too.


  • smile_at_me
    smile_at_me Posts: 0

    Same issue here in Switzerland. I suspect this is not related to the country you're connecting from.

  • Darkiger
    Darkiger Posts: 2 ✭✭

    Exactly the same issue for me and I am in Switzerland too. No commercial suspicion.

  • peval
    peval Posts: 2 ✭✭
    edited February 2021

    Same issue in Italy, i agree, it does not matter the country you are in.

    Either a fix comes soon or I have to find an easy alternatives like ** Third Party Product **, ** Third Party Product **, whatever!

  • DBquick
    DBquick Posts: 8 ✭✭

    Dear all,

    I got the following message from the support:

    "I encourage all users experiencing this while being 100% sure to not use TeamViewer for any sort of "working" to fill out the form on Our team will review every submission within a short time."

    Let us keep updated, if this will change anything!

  • Aaditya
    Aaditya Posts: 2 ✭✭

    I have faced the same issue, does anyone have the mail id of the customer support?

    I am a student and I am also using a free license.

  • iamjay
    iamjay Posts: 0

    Whenever I try to connect to my PC using teamviewer it shows some license error and says that my account is having limitations for using teamviewer as I use my account for Commercial purpose.

    But this is not the case, I never used my account for commercial purpose or in fact I use TeamViewer once or twice a month, just to connect to my own device linked with same account.

    How do I fix this, there is no option to contact Teamviewer support aswell.

  • Shinx
    Shinx Posts: 1

    I have been using Teamviewer with free license just fine with my family/friend but today when I tried to connect to my friend computer, Teamviewer blocked me saying that "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later of upgrade your license."

    After that everytime I try to connect, it blocks my connection for one minute. If I connect at 15:31, it says "Connections to this partner will be blocked until 15:32" and so on.

  • peval
    peval Posts: 2 ✭✭

    This is strange.

    It happened to me a couple years ago, i had activated the "start at login" Team Viewer option on my windows computer and i immediately received a notification about potential commercial use detected and i could see this notification permanently in the Team Viewer windows.

    Now i see everywhere "free version", so it does not flag any detection

    Is TV support aware of this? do we still need to go for the reset procedure?

  • Heinvomberg
    Heinvomberg Posts: 0

    This link wouldn't solve our issues.

    Isn't there anybody from Teamviewer for helping us with timeout issues in free versions?

  • schoofol
    schoofol Posts: 0

    Hello I am using the free license (non comercial use only account) until today I had no problem accessing my home computer from my laptop. Today I logged in and then got this message after it logged me out of my PC, "Connection blocked after timeout. Your license limits the maximum session duration to a partner, imediate reconnects are blocked. Please try agian later or upgrade your license".Was there a policy change? I have been using this free account for years with no issues. Thanks for any help

  • Truckeeer
    Truckeeer Posts: 10 ✭✭

    Same here. Timeout after few seconds.

    Server and client are on latest version, Windows to Linux.

  • Superscheibenkleiste

    Same problem here

    NYBBLER Posts: 0

    Even thou the option is off I keep getting kicked from my session after a minute or two. Every update they release has a new problem that doesn't get solved