Commercial use - Connection time out



  • Betelgeuse
    Betelgeuse Posts: 8 ✭✭
    edited September 2021

    I don't think TV gives a **bleep** about this.

    I am looking for alternatives now

  • I got a new Macbook Pro and am running Teamviewer 15.15.5. I am running Personal / Free to be able to connect to my machine I have at home and sometimes helping family & friends. I have no problem running Teamviewer on my iPad, Samsung S10+ or iPhone X but with the new Macbook Pro when I connect to say my machine at home after a minute or even less my session timesout. When I the try to reconnect I get message:

    Connection blocked after timeout.

    Your license linits the maximum session duration to a partner,

    immediate reconnects are blocked. Please try later or upgrade you license.

    What is causing this? I have added my Macbook Pro the list of devices that I use but do I need to do something else?



  • samtfischer
    samtfischer Posts: 1
    edited February 2021

    I’m having this issue too, but I’m not even getting an error message. The issue only happens when I’m accessing my MacBook Pro while the lid is closed. I think it’s a Mac related issue as I have the same problem using *Third party product*

  • paulenigal
    paulenigal Posts: 2 ✭✭
    edited February 2021


    My mother is almost blind.

    We request for admitting her Android unit ID

    and her PC unit

    from(!) mine ID



  • samtfischer
    samtfischer Posts: 1

    I'm running 15.15.5 on Big Sur, and I'm trying to remote in with my iPhone while the lid is closed. It works for about 1 min, but then kicks me off. My laptop seems to constantly flip from being online and offline in the My Computers list. Does anyone have a workaround for this?

  • Leo212
    Leo212 Posts: 0

    I'm using it on my PC for my personal use and recently it no longer allow me to remote control it for more than few seconds everytime.

    On the mobile app I'm getting a message claiming that I'm using it for non-personal use (which is not true) and I should contact support.

    But I can't contact support, I only have access to this forum and I'm not sure if anyone here can help me solving this.

    I'm afraid I'll have to create a new account to get rid of this annoying bug.

  • Gerald74
    Gerald74 Posts: 1

    I followed the whole procedure to get my teamviewer ID reactivated and got a positive response at the end. But Teamviewer still doesnt work - it closes the connection after a few minutes and says its closed for a tim out now. what can I do to solve this problem?

  • Xerboras
    Xerboras Posts: 2 ✭✭

    I have the same problem.

  • ArmandAanekre
    ArmandAanekre Posts: 0
    Answer ✓

    You have to fill out and sign a form here:

    Just explain your use scenario and you should be up and running again in a few days. Happened to me about a year ago. Happened again just now because I was stupid enough to try Teamviewer from my work laptop...

  • I am TeamViewer Free user. I run it on Win10 Pro x64 PC. I noticed yesterday that my remote sessions go into a timeout after about one minute, no matter what I do. The message says "Your TeamViewer session has timed out and will be closed". So it seems that I am not suspected of using TV commercially (I believe that message will explicitly say so in that case).

    I went through TV settings and haven't found anything related to the session time out. So I uninstalled the TV, deleted all various folders left behind, and installed the TV again. The issue persisted. Before yesterday I last used TV roughly ten days to a fortnight ago without a glitch. So cause for the trouble could be the last version I installed yesterday (15.15.5), but I found nothing like that in the forum.

    I'd like to get some advice on how to proceed with troubleshooting.

  • Csu
    Csu Posts: 0

    I've the same issue. I've got this message with an older version. Than I upgrade to the latest version (15.15.5) on both TV sides but nothing changed.

    I'd like to get some help too... Thx.

  • Csu
    Csu Posts: 0

    I've the same issue. I've got this message with an older version. Than I upgrade to the latest version (15.15.5) on both TV sides but nothing changed.

    I'd like to get some help too... Thx.

  • shaylaks
    shaylaks Posts: 0

    same problem.

    they are doing everything so we will purchase license.

  • kwolberg
    kwolberg Posts: 0

    I have the same problem. I log on to my uncle's computer and after a minute I am timed out. I do not see any reason for this happening. Please advise.

  • dvsmp3
    dvsmp3 Posts: 1


    As the title says, TV started to terminate my connection after a few minutes of every session. After that it doesn't allow me to reconnect for a couple of minutes.

    This problem started a couple of days ago. Never happened to me and I've been using TV for years (for private use always).

    I usually connect from my (Windows 10) laptop to my desktop (Windows 7). I have tried reinstalling TeamViewer on my laptop but it didn't help.

    Is this "the new normal" or is there something else I can do to bring the good old TeamViewer back?

    Thank you and best regards

  • Having the exact same issue - starting on Thursday last week. Until then it worked perfectly...

  • Also having the exact same issue starting on Thursday!

  • Hi there!

    I cannot use Teamviewer. I want to use it for managing my home computers, and to help friends, so i've choosen free licence. But teamviewer disconnects as soon as I connect to partner, and whet I try to connect again it say's that the connection is blocked.

    Is there another program like Teamviewer that it actually does what is supposed to do, and it doesn't disconnect as fast as teamviewer does?

    Thank you!

  • Heno
    Heno Posts: 0

    Tonight I have the same problem, but it has never happened before. And I have used Team viewer for years. Sorry I can't help.

    IGORBLANKY Posts: 1
    edited March 2021

    Good day!

    I ask you to unblock my account. For some reason, it was considered commercial by you. I had thoughts of transferring it to commercialization, but due to the virus, it became impossible in the absence of a client base. You can be convinced of this by the fact that I have communication only with two computers - my friends, who regularly require my help. Please unblock my account.

    Inception is grateful



  • Mihai_Ap
    Mihai_Ap Posts: 1

    Why is this happening? Personal noncomercial use for me only. What can i do to get rid of this? PCs of my family.

  • plusterkopp
    plusterkopp Posts: 0

    I have the same problem.

  • plusterkopp
    plusterkopp Posts: 0

    Same problem here. Looks like with all the home office hype, they don't want private users anymore.

  • Black_Blade
    Black_Blade Posts: 1
    edited February 2021

    Have the same issue, I think this is my second or third time getting that, need to contact support and tell them you are not doing any commercial use, and hopefully, they remove it

    Seems like now support is only if you have commercial license.. so not sure how are we suppose to tell them that we don't have any commercial use going on

  • Im using teamviewer on my privat computer via my mobilephone.

    Why do it now show commercial use..?

    I do not use it for commercial use...

    Thanks for answers!



  • mbacklund
    mbacklund Posts: 9 ✭✭

    Looks like the timeout is set on establishing the connection:

    CreateClassicSession::HandleRequestRouteResponse(): Response: Timeout=59

    Why? Fix this already!

  • Exact same issue here, using TV 15.13.6 (private use only), connecting to a Client running same version with unattended access via static password.

  • MarcoTribuz
    MarcoTribuz Posts: 1

    I am this problem too, how i can fix? :) thank you Marco

  • Lith
    Lith Posts: 16 ✭✭
    edited March 2021

    Fix this asap. Stop ignoring it.

  • Hunking
    Hunking Posts: 0

    Hello guys,

    is there any solution against the frecvently disconnection issue by the NOT COMMERCIAL USED free version? Every 1 minutes will be disconnected since about 8-9 days, without the tipical "buy a comercial licence" message, as it was in the past always...

    This problem persists all 5-6 months since approx. 4 years, always the same situation: after contacting the support the account will be after about 1-2 weeks reestablished (but sometimes takes SOME WEEKS or MONTHS till the support gives a feedback and changes the prohibiting of usig free again, get the connection free, what is more then very frustrating!!).

    At the moment I have the same situation again, for days no one has reported back from support, or just solves the problem ... :-(

    For a long time I have had the impression that TeamViewer is trying to eliminate the free accounts in this way and also force the free users to buy the software.

    Shall I look for an alternative because this repetedly issue, or will TeamViewer be able to eliminate this issues?!