link icon
Ask The Community

Commercial use - Connection time out



  • Garjion
    Garjion Posts: 4 ✭✭

    i solved the problem by uninstalling and reinstalling it, making sure to remove all settings, and all files in %temp% , %appdata% and all regestries in regedit. it seems to be working fine now

  • Moonshot72
    Moonshot72 Posts: 5 Newbie

    @Garjion - do you have to remove and reinstall on all machines? I have a headless computer that I remote into from my personal laptop.

  • Garjion
    Garjion Posts: 4 ✭✭

    @Moonshot72 no i only uninstalled and reinstalled on my main laptop. I'm also running a headless server that i remote into but i didn't have to mess with it it seemed uninstalling on my laptop (that was having the issue) and reinstalling did the trick

  • reshores_76
    reshores_76 Posts: 1 Newbie

    Been using Teamviewer for years, now all of a sudden i can connect but only for less than a minute then times out and I can reconnect for at least five minutes.

    Both computers have been updated to same version, internet service is great, no other note except that the session has timed out. Very frustrating.

  • russ75
    russ75 Posts: 1 Newbie

    I have a free-use license, but I am no longer able to use Team Viewer.

    After I connect to my remote computer, I get disconnected with the following error message:

    After waiting until the requisite timeout time, I try again, but get the same error message with one minute added to the timeout time. I have uninstalled and reinstalled Team Viewer, but still get the same message.

    I am unable to connect my two computers. Any suggestions on how to fix this would be appreciated.

  • This just started happening so I rebooted both my home PC's and curious why it is happening?

    I am not getting the flag that i am using it for corporate use, it just diconnects

  • darkgeckio428
    darkgeckio428 Posts: 3 Newbie


    I'm using the free version and cannot seem to hold a connection for more than 30 seconds at a time. I then get kicked out stating I can reconnect in 1 minute but it never works until hours later.

    This is not for commercial use and is mainly used to remote into my friends / family PCs for very short amounts of time.

    Any suggestions?


  • gvarol
    gvarol Posts: 2 ✭✭

    Connections are failing right away, I think it started happening today 4/20/21 . It says block till a time and even after that time the same message with another time.

  • Rabbit31
    Rabbit31 Posts: 1 Newbie

    I amhaving the same problem. I cant imagine why

  • gvarol
    gvarol Posts: 2 ✭✭

    Even after the blocked until time it does not work, repeats the same error and a later time

  • darkgeckio428
    darkgeckio428 Posts: 3 Newbie

    Getting the same error. Please help...

  • darkgeckio428
    darkgeckio428 Posts: 3 Newbie

    Same issue.

  • MarkPC
    MarkPC Posts: 1 Newbie

    I keep getting booted out of my sessions with the licensing message as seen in many posts above. I try to reconnect after a couple minutes, and the time it will be blocked until just keeps moving up. This is annoying. Can't even find any way to contact teamviewer support to resolve this

  • natywaty
    natywaty Posts: 2 ✭✭

    I have a free version and every time I want to connect with another partner only gives me a few minutes, then it logs out from the system.

  • Moonshot72
    Moonshot72 Posts: 5 Newbie
    edited April 2021

    @Garjion @TeamViewer - I tried that just now and I get the same result: a timeout and my sessions close. I am giving it until tomorrow AM and then I am switching to "Third party product" or other tool. This is disappointing...

  • rje118
    rje118 Posts: 1
    Answer ✓

    I am having the same exact issue.....I assist my grandmother with various legal issues on her computer and then all of a sudden today I receive this error....everytime I attempt to connect it kicks me out......any suggestions???

  • natywaty
    natywaty Posts: 2 ✭✭

    I received the same message every time I want to log in and also received a lot of e-mails every minute. I don't know how can I stop this.

  • Rubycat
    Rubycat Posts: 4 ✭✭

    A year ago I signed a paper and sent it back to Teamviewer that I did not use it commercially and they let me back in without timing out or getting the commercial use warning..

    It seems every time I change my home network at all - even just get a new modem or add a router - I get timed out. That's where it is now despite my previous letter. Even double natting seems to over excite their method of detecting commercial se.

  • gtcolony
    gtcolony Posts: 1

    This is the same problem I am having with my Mom, she is in a assisted living home and she limited visitor access. I have no access. I do not use TeamViewer commercially, this program is how I can keep her computer up to date or help her with an issue if she encounters one. I would like to know how to fix this so I can continue to help her.

    Where do I send this letter, to have this situation fixed.

    Thank you so very much.

  • Jjerry
    Jjerry Posts: 0 Newbie


    I use TeamViewer to manage my mother's laptop. But teamviewer claim to have detected commercial usage and have limited sessions to 57s, which is useless. Is there any way to get back to domestic use?

  • Omega_up
    Omega_up Posts: 1 Newbie

    Morning all

    I use a VPN on my pc and connect to it on my phone/laptop and I continue getting a message saying I’m using the program commercial and blocks me

  • Lina_1
    Lina_1 Posts: 2 Newbie

    What dose it means "commercial usage"?

  • Garjion
    Garjion Posts: 4 ✭✭

    @Moonshot72 when you uninstalled it did you delete the registry files, and the files in %temp% and %appdata%?

  • user 234235879
    user 234235879 Posts: 0
    edited April 2021

    I was helping my mother again... not some corporate **bleep**... **bleep** THIS... warn me... ban me... whatever... i'm done with this stupid software... it the millionth time it happens. Also, whenever i try at the time it says in that **bleep** window, it just adds a minute, tried at 12:43 and it popped with 12:44... and so on, **bleep**... SO **bleep** THIS SOFTWARE AGAIN...

  • CraigTrickett
    CraigTrickett Posts: 0 Newbie

    I have tried re-installing teamviewer and restarting my laptop but still no luck. Even at the start of a new day I get this problem.

    Sometimes I can connect but it kicks me out within a few minutes. Other times when I try to connect I get this error.

  • TomBo501210
    TomBo501210 Posts: 1
    edited April 2021

    Still an issue...I appreciate the free version but this is the second time in several months getting Session Timeout within seconds of connecting to a remote PC.

    [removed per Community Guidelines] Love the app but support family and friends on a monthly basis..

    [removed per Community Guidelines]

  • rassel
    rassel Posts: 0

    hi my free account doesn't work. its keep saying commercial use detected

  • Submitted my reset form and now waiting 2 days for an answer. At least it gives me time to consider alternatives, I suppose.

  • ckb707377
    ckb707377 Posts: 1

    I am being timed out immediately, what do I do to correct this?

  • corey515
    corey515 Posts: 1 Newbie

    Im not getting any popups on the remote computer or the local one except that the connection timed out, when i try to reconnect it says my license limits the maximum session duration to a partner. im not getting any messages for commercial use either.