Commercial use - Connection time out



  • Brycey92
    Brycey92 Posts: 1


    I use Teamviewer for personal use, but for the past couple of months, I've received "Connection blocked after timeout" errors briefly after connecting to my computers, or my friends' and families' computers. After that, I can no longer connect to the computer I was remotely controlling when the error appeared.

    Can someone please help?

  • N_JUMP
    N_JUMP Posts: 1

    I use TeamViewer to help a friend and get disconnected after a few seconds. After that I'm not longer able to connect as I get a message indicating that TeamViewer is being used in a commercial environment (non personal use). That is not the case.

  • I can't connect to my friend... says I'm doing commercial... but I'm not!

  • KennyM
    KennyM Posts: 1

     Is this a known issue and is it being addressed?

  • floblo
    floblo Posts: 2 ✭✭


    Teamviewer keeps timing my session out and locking me out of my accounts. I can't access any of my devices anymore remotely, which is a pain in the bottom.

    I use Teamviewer purely for personal use. I just have a lot of devices, from Android phones to PC's (deskop and laptops). It has been a life safer but now I can't use it anymore.

    Can anyone please help me?


  • floblo
    floblo Posts: 2 ✭✭

    I found a post that users can access to request a reset of their account when commercial use is detected

  • MTJK
    MTJK Posts: 4 ✭✭

    where? link?

  • Pete_vanders
    Pete_vanders Posts: 1


    I have enjoyed using teamviewer for awhile now helping my family and controlling my home server from anywhere using my laptop. Tonight i went to help my son print something by jumping on his laptop and i got thrown off the connection and then i could not reconnect. I did a little bit of google doctoring and it seems maybe my laptop has restricted because it detected i may have using the free license outside of the guidelines. which isnt the case I was just using my works corporate network for internet access. I dont know how to resolve this issue?

  • AlC_4more
    AlC_4more Posts: 1

    I have always used my TeamViewer account for personal use to help family and friends. I have never used TeamViewer for profit or ever charged anyone for my help using TeamViewer.

  • pvnnpavan
    pvnnpavan Posts: 2 ✭✭
  • pvnnpavan
    pvnnpavan Posts: 2 ✭✭

    Why am i getting this.. I am using it for personal use only

  • virtualny0
    virtualny0 Posts: 1
    edited June 2021

    I have never used TimeViewer for commercial use, but only for private purposes, e.g. by connecting to my own home server which is located in another country. I don't know why I get popping up a message about commercial use.

  • pegail
    pegail Posts: 1


    I'm using teamviewer for years to help my family and friends with their computers, I never used it within a commercial usage, and since a few days i cannot use it anymore because it Always hang with a popup message saying that a commercial usage has been detected (whereas it is 100% false).

    Would you mind to help me about that?

    Otherwise i will need to find another software to do that...



  • TheOGMrBEE
    TheOGMrBEE Posts: 1

    I am having the exact issue, but I use TeamViewer from my mobile device to connect to my PC in the study. I use TeamViewer in this was as it is way better than RDP (getting RDP with MS creds to work is a nightmare as well). I am now unable to use TeamViewer to this machine (It is Windows 10). I also sometime will help my family with their issues as well, but this happens rather seldom.

    How does one correct this. I do not feel that spending $$$$ to use a free tool, non-commercially, in the way it was intended. Also, please make it easier to submit a support request wrt this specfic issue as it has caused significant frustration for my family as I am now forced to pause the movie or show, make the family sit there, staring at nothing, while I run off to do something on my PC, then come pack to the movie again. Not Cool TeamViewer, not cool. I too have been using TeamViewer for many years.

  • Earj11
    Earj11 Posts: 2 ✭✭

    My computers have been flagged for commercial activity. I have requested a reset 4 times. There are 4 separate computers. I can only use Team Viewer with 2 of the 4. Each time I get an email telling me I have been granted a reset but my computers still have the same problem. I have used Team Viewer for many years with no commercial activity. How do I get Team Viewer to work again?


  • Mper
    Mper Posts: 1

    Since last month when I used my teamviewer account to help a friend now my account is limited in time.

    I always used only for access my parents computer to fix it and to open their skype application so I can speak with them.

    How can it be fixed to return to normallity?

  • JerryUS
    JerryUS Posts: 2 ✭✭

    I have been experiencing the same issue in the last few months also. I use the software to help manage my Dad's Doro phone.

    I have gone through the reset steps, 4 times (listing my two teamview device ids and my dad's doro phone teamviewer id)

    Each time I have received a response from the stating:

    "We have successfully reset the TeamViewer ID(s) you submitted via the form provided earlier.

    We acknowledge that you are using TeamViewer for private use only on these devices."

    When I try to use it I get:

    Connection blocked after timeout

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked, please try later or upgrade your license.

    Connections to this partner will be blocked until HH:MM

    Also I am not sure how to proceed ?

  • AndrewDoc
    AndrewDoc Posts: 1

    Hi All,

    the same to me it will enter in my parent's PC but after 2 minutes it closed the connection without possibility to reconnet. I try to understand how much cost the private license for me but more than 400 euro are crazy since there are a lot of program that works free to do exactly what i need.

    Please solve the matter or give a possibility to buy a private license at cheaper cost.

    waiting comments and follow the claim

  • Earj11
    Earj11 Posts: 2 ✭✭

    Thank you for responding, Jerry. In my case, it appears only two of my computers are affected. Those would be two laptops that I don't use everyday but I do use at least one of them when I go on vacation or visit my daughter out of State. I don't know what the correlation is.

  • johnwmreed
    johnwmreed Posts: 5 ✭✭
    edited June 2021

    I have submitted tickets Six times to Teamviewer Reset to reset my Wife's iPad Teamviewer ID, and it has been approved Six times and supposedly reset:

    "We have successfully reset the TeamViewer ID(s) you submitted via the form provided earlier."

    When I connect to my two desktop computers (also reset and work properly - they can connect to each other) I am still timed out after a minute.

    What can I do to fix this problem?

  • dem_dxdy_ru
    dem_dxdy_ru Posts: 1

    Hello, my TeamViewer guess commercial usage and terminates remote session in a few seconds, but I use it for home purposes. How to solve?

  • 613210163
    613210163 Posts: 1

    My account is not commercials.

    I use TeamViewer only free working.

    It is not work.


  • HOTN
    HOTN Posts: 2 ✭✭

    I just downloaded Team Viewer as a private user, succesfully connected to a friend's remote computer, and the first thing I went to do is move Team Viewer from the part of the screen it was on, on his remote computer, to a part where it was not in the way of the program I was going to remotely use.

    YTouching on Team Viewer's tool bar in the remote computer immediately closed the session (after only around 25 seconds), and ech time I try to reconnect, there is a message like '... reconnect at 0801', so I wait until 0802, hit reconnect, and it says '... reconnect at 0803 ... each time either of us tries to reconnect, it tells us to wait an additional munite or two. What are we doing wrong, or is this is a bug.

    I used TeamViewer ages ago and liked it, but this new experience is really bad, I just want to connect to help him out, yet all we are getting is a message incrementing the time that we have to wait to.

    Is TeamViewer that unstable now, is there a bug, and what do we do to connect?

  • HOTN
    HOTN Posts: 2 ✭✭

    We just got a connection and were immediately kicked out and the error on his machine was 'it appears that it is being sused for commercial purposes. This is an 80 year old man who wants me to show him how to use a particular program, all I did was click the Microsoft Start button on his remote computer. So, I'm now busy looking for something else to download.

  • HOTN
    HOTN Posts: 2 ✭✭

    I've deleted TeamViewer and am closing my account.

  • ngungs
    ngungs Posts: 0


  • presideji
    presideji Posts: 0


    My teamviwer flagged me for commercial usage which was not the case. I use it for personal and private things only. So I raised a "reset ticket". Teamviwer responded the second day. But when I tried to use my teamviwer to connect it still displays "the commercial ussage message". Itried to raise another ticket to teamviwer support as suggested in the email but a massage popped up saying " I have already submitted a request which is being reviewed". Please, can anyone advise on what to do?


  • KennedyR
    KennedyR Posts: 1
    edited June 2021

    My teamviewer will not stay connected for more than a minute. It times out and locks me out for a few minutes, but when I try again it still does the same thing. I've connected to 2 different computers and it does the same thing for both. So it must be something with on my own end... I'm using free version, by the way. It also is not giving me the "commercial detection" notification I've seen people post before.

  • I'm having exactly the same problem. I'm guessing it was a recent update to the software, but who knows.

  • Gazpacholulu
    Gazpacholulu Posts: 1

    Same here, what a complete PITA after years of great service