link icon
Ask The Community

Commercial use - Connection time out



  • FuzzmanKs
    FuzzmanKs Posts: 54 ✭✭

    I assume that you have provided, on the RESET MANAGEMENT form, ALL of the Teamviewer ID's that you connect to. Therefore I can't help but wonder if there is something that is triggering the flagging of your account. Have you scrolled back in this thread a month or two to find any helpful hints? Did you read the first message in this thread along with the Blog that is mentioned in the first message? Some things I've learned that can trigger the flag is connecting to or from a work network system. Connecting to church, personal interest clubs (fishing, ham radio, etc), volunteer organizations...basically anything that is not personal at home connections. It has also been mentioned above that if you have a video conferencing program installed on your device, that may trigger the flag. If you can't find any helpful hints above in this thread, maybe it is a good time to start searching for another free provider. I found one that I have configured as a backup for me.

  • Yenwen
    Yenwen Posts: 1 Newbie

    Dear community,

    I've submitted the declaration for personal use of my TeamViewer account three times...

    I received emails from the TeamViewer team two times that indicated my IDs had been reactivated, but I still failed to connect to my remote device. I submitted the declaration the 3rd time on June 1st, 2021, but I have not received the response and the reset webpage ( still showed that my request is pending.

    A message showed "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked." 

    I would appreciate if any of you can provide insight or suggestion of how to solve this issue...

    Thank you,


  • Abiba
    Abiba Posts: 1 Newbie

    I have the same issue since yesterday after the update! i cannot connect to the devices! and i cannot find how to contact the support!

  • Akusho
    Akusho Posts: 0 Newbie


    I'm sure everyone is sick of these questions, but I've been trying to re-activate my PC for remote use for the past 2 months.

    I have sent two requests to remove the flag for commercial use and both were granted, in one I thought listing my account is enough so the computers under it will be un-flagged, the second time I listed all IDs I use, but I still can't access my computer without timing out.

    Is there anything to do here, or TeamViewer support is just the way it is and I should move on to greener pastures?

  • gee_dee_ell
    gee_dee_ell Posts: 6 ✭✭

    LIkewise, I have been advised on a few occasions that my IDs have been reset and service restored. Most times this has been proven false by not being able to connect for more than a minute or so between laptop and desktop. I did two weeks ago believe TV had cracked the problem, I had bilateral communication between them. However, just yesterday I entered the the TIMEOUT BLOCK zone once more.

    Just WTH is going on with TV algorithms to propagate this misery for users who are "playing fair".

  • garytgtx
    garytgtx Posts: 0 Newbie


    Hi. I have been using free option system for a good few months now, especially over covid lockdowns. I only use it to connect to my dad's laptop, so i can help him to log in, to watch/stream football games, etc. My dad is an 88 year old OAP, with severe memory issues and can struggle with password logins etc, so this has been a brilliant tool for us. I even put a review on trust piolet saying this. I have and would never use it for any commercial use. I recently got a new laptop, but everything worked fine until I 'upgraded to latest version' the other night. it then locked me out on a timer, but every time I went back, it just moved the time on again. Tried again tonight, but it still wouldn't work. 

    I have tried the suggested form, but when I complete it, nothing happens when I press 'crate PDF', so can't get any further than that.

    I don't know what I've done to make it think I'm breaking the rules, but I'm honestly not and hope you can help me with this. Cheers.

  • Elen4ik
    Elen4ik Posts: 1 Newbie

    I'd like to claim that my TeamViewer account is suspected as Commercial, however I'm using it only to access a couple of my own devices and my parents' PCs. I can prove it by providing all the necessary data about each device. Waiting for your comments. Thank You!

  • josepferrer
    josepferrer Posts: 1

    This is not serious, three times that I request that my computers be reset, three times that you tell me that it is done and three times that they are blocked. What's going on ?

  • tdhardy843
    tdhardy843 Posts: 1 Newbie

    My teamviewer free version keeps giving me a message "Connection blocked after timeout" .

    I reached out to support once and sent a form in that I wasn't using my license for commercial use. I received an email that it had been resolved but it didn't.

    I tried uninstalling teamviewer and its settings on both of my computers and reinstalled. Same result.

    I then did the same thing and created another account, again with fresh installs. Same result.

    Is there anything I can do to restore the functionality of the free version or am I at a point that I should look for other software?

  • I'm having the exact same issue. I also wasn't using it for commercial use and was told the restriction had been removed.

  • Karel_Zeman
    Karel_Zeman Posts: 1 Newbie

    Yes, I have the exactly same problem. For computer where I'm connecting to I asked for ID unblocking for 3 times. I received positive answer for all 3 request but connection to this computer is still blocked (Your TeamViewer session has timed out and will be closed). My ID is OK because I don't have problem to connect to another computers.

    Please could somebody from TeamViewer company fix this issue?


  • dwp
    dwp Posts: 2 Newbie

    Where can I find the "Don't tag me as a commercial user" form?

    I miss using this utility, it worked and was easy, but I haven't used it in 2yrs. since I have been flagged as a commercial user. Really?

  • demenicis
    demenicis Posts: 2 Newbie

    I'm trying to provide valuable help to my Mum in brazil, while im in the UK, since about almost a year I my account is being blocked after 1 minute connected.

    I definetelly do not use it commercially, just check how often I use it please.

    I beg for this limit to be removed as I have now a pile of unresolved issue on my mum's side.

    Please help, thanks in advance

    Luiz Demenicis

  • demenicis
    demenicis Posts: 2 Newbie

    Just having this same issue.......flagged as commercial for helping my mum/dad once a week?

    Now my dad died (covid19 + parkingson) and I cannot help my mum doing anything. what a shame ths automatica assumption users are cheatting their usage....


  • sjacobs
    sjacobs Posts: 1

    This suddenly began happening yesterday. After connecting successfully, TeamViewer (ver. 15.18.5) times out after 2 or 3 minutes. Please note that this is NOT related to commercial use. The first time I attempt to reconnect, I receive the following message:

    I get the same message whether I attempt to reconnect immediately or 30 minutes later (the "blocked until ... " time is always 2 mins after my first reconnect attempt).

    Can someone please assist? Thank you.

  • Tobi0711
    Tobi0711 Posts: 1 Newbie


    for months I was able to connect to my home PC from anywhere. Until one Day the message suddebly came up that my account was also being used commercial, which is definitely not the case. Can you help me what should I Do?

    Greetings Tobi

  • PhilipArgy
    PhilipArgy Posts: 2 ✭✭

    I am having the same issue. I am trying to support my 95 year old father and Teamviewer is literally his lifeline. Now it lets me login for about 90 seconds and then just disconnects. When I try to re-connect it says I've breached some time limit and can't reonnect until [current time plus 1 minute]. So I wait until [current time + 2 minutes] but get the same error message but with [current time plus 1 minute] again. So this time I wait until [current time plus 3 minutes] and so the loop goes. If I wait an hour it does let me log back in but only for another 90 seconds before terminating the connection.

    Something is seriously wrong and it has only started happening for me in the last week or so - I've never seen this before and I've been using TeamViewer virtually since it was released.

  • EdoM
    EdoM Posts: 0

    I am trying to reset my computers from being flagged as "Commercial User". I tried to populate 2 computers (this one and the one that I am commenting to) but only one machine populated. When I tried to complete another form, the company stated that I already submitted a form and I have to wait 24-48 hours. Any ideas?

  • chefire
    chefire Posts: 0 Newbie

    Please advise.

  • Groenenzo
    Groenenzo Posts: 0

    I help my blind mother navigate her computer. Why is this counted as commercial use?

  • Good day. Recently, there has been a report of suspicion of commercial use. But I didn't do anything like that. What should I do to get my status canceled?

    with respect

  • chito_u2
    chito_u2 Posts: 1 Newbie

    I only use the program once in a while, not for business.

  • Jerzy50
    Jerzy50 Posts: 1

    Good morning,

    My name is Jerzy Pogrzeże and I am a PhD student. Currently, I was using your program for teaching purposes, to be able to remotely check the progress of my analyzes on computers in my Department, which greatly facilitated and allowed me to save my time. For some time, the program doesn't allow me access anymore.

    Therefore, I would like to ask for a possible unlocking of access to the free version of the thresholds for teaching purposes, so that I can continue my research work.

    Have a nice day.

    Yours faithfully

    Jerzy Pognec, MSc

  • sfederici
    sfederici Posts: 1

    This started a few months ago. I'm using TV on a MacOS BigSur. Every time I open a TV session it closes after 10-15 seconds. I'm using a non-commercial license. Is this a wanted behaviour?

  • jphilippa
    jphilippa Posts: 35 ✭✭

    I have used Team Viewer for years to access a distant PC to offer help. For maybe a fortnight now, I have received a 'time-out' notification, after only a minute; and am then blocked from attempting a new connection.

  • JeanK
    JeanK Posts: 6,529 Community Manager 🌍

    Hello @Miroslav83023,

    You can delete your computers within the Computers and Contacts list.

    Community Manager

  • Trygwe
    Trygwe Posts: 1 Newbie

    Used TeamViewer Free occasionally for several years. Now I am blocked due to commersial use. I have been granted access several times but am each time thrown out with a message about commercial use. My use is exclusively private. What could be wrong? And what can I do. Since it can take several months between each time I use TeamViewer, the pro version is out of the question.

  • noobnoob
    noobnoob Posts: 1
    edited June 2021

    As the title says, how do I fix this? My connection is cut off every 5 minutes which is really annoying since I'm trying to help my mother with her aging laptop that also takes forever to load stuff.

  • j_czerwin
    j_czerwin Posts: 1

    I don't seem to be able to easily find a solution - so I'm going to post this everywhere I can and see if I can get TeamViewer help and/or post other software solutions we can use in a personal application.

    It is crazy that the timeout keeps coming up for no reason. I am not a commercial business, but something in their software is triggering the event and making a timeout in just a minute or two.

    Here is what I have learned so far:

    Solution #1 - Remove the app from all of your computers, and every hint of its existence, and reinstall. Uninstall the app. Then you have to search your hard drive (with hidden files showing) for every reference to TEAMVIEWER. Delete them all, files an folders. Then you also need to go into the command prompt and type REGEDIT. These are important windows values - be careful. Click on the very top line COMPUTER and then Edit>>Find or Control+F. Type in TEAMVIEWER and search. If it is in the left screen - delete it there. If it is in the right screen delete it there. Deleted everything you can. Search again and make sure all is gone. Then when there is nothing left you can delete, close the REGEDIT and reboot your computer. Then download and install again, selecting the free version. This all takes about 20 minutes. I did this on two computers and it solved the problem! ISSUE #1, I then installed the app on my iPhone and connected remote to one of the two computers. BAM! Timeout issue reappeared!!! Now I have to do everything again and not use the iPhone app.

    Updates to come.

  • I'm having the same issue. Never had this happen before. I'm considering other programs. There seem to be good alternatives out there.