teamviewer.com link icon
or
Ask The Community

Wake on LAN not working from shut down after extended off time

I have teamviewer set up on my PC (windows 7, public address), and everything works great (start from sleep, start from hibernation) except . . .  when I shut down & leave the PC off for an extended period of time (more than an hour or so), wake on lan does not work.  I've tried waking from my iPhone app, as well as another PC, neither works. The wake button shows on the phone app/other pc, but when selected, it spins for a bit, then turns back to a button. Strange thing is, wake on LAN works from shut down if I re-start shortly after shutting down, but not after a longer delay.  (wake from sleep/hibernation works flawlessly, regardless of the time it's been inactive) Any suggestions, thoughts or answers??  Thanks in advance!!!

Comments

  • Still looking for help on this . . .  please.

  • I'm having the exact same issue. Works fine for a couple of minutes when I've shut down the PC and then power on from TeamViewer, but if I wait for more than approx 20 minutes it stops working. 

  • Still looking for help on this, if anyone has any ideas??

  • Same issue here, hope some dev can find this thread, I don't want to leave my PC in sleep mode all the time :X

  • bubban
    bubban Posts: 1

    I have the same problem except that I dont even have to wait 20 minutes. If I try to wake up the computer by pressing the "on" button right after the computer goes to sleep, it will work perfectly fine (using public address). However if I wait 5 minutes and try to wake it, it will not work. I need to click on the mouse or keyboard to wake it up.

    Would love if somebody has any suggestions on how to fix this. I´m using Windows 10.

  • Still hoping to hear from someone on this issue . . . everything else runs perfectly except starting from shutdown after 20 minutes or so.  If you have any solutions/thoughts/recommendations, please let me/us know??  Thanks!

  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Hi @TPNussinow

    Unfortunately, WOL is a very device-specific tool.

    TeamViewer can send magic packets to devices and we have the packsender built into the app as well as the ability to bounce them off other devices in the same network.

    But beyond this, it is very hardware dependant and there may not always be an easy fix or a way for us to diagnose it unfortunately. In your case, it definitely seems like the device is going offile and no longer accepting the magic packet after this period of time.

    Try checking out some of one our SuperUsers (Credit to @DomLan ) posts
    He posted here about power states
    And here is a good discussion with another user

    I hope this helps.

    -Scotty

    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • EnuKyP
    EnuKyP Posts: 3 Newbie

    I was only able to wake my PC in Sleep mode. Not sure which one of the following made the trick for waking a Shut-Down PC but I am now able to. Here's what I changed in BIOS on an Asus motherboard:

    • FAST BOOT - DISABLED
    • OS TYPE - WINDOWS UEFI MODE
    • PCI EXPRESS NATIVE POWER MANAGEMENT - ENABLED
    • PCH DMI ASPM - ENABLED
    • ASPM - AUTO
    • REALTEK PXE OPROM - ENABLED

    From a Windows side there are the settings that I change along with the BIOS ones:

    Device Manager --> Network Adapters --> Properties on: Realtek PCIe GbE Family Controller --> Power Management:

    • ALL TICKBOXES - CHECKED

    Device Manager --> Network Adapters --> Properties on: Realtek PCIe GbE Family Controller --> Advanced:

    • SHUTDOWN WAKE-ON-LAN - ENABLED
    • WAKE ON MAGI PACKET - ENABLED
    • WOL AND SHUTDOWN LINK SPEED - 100 Mbps First (was 10)

    Hope this helps

Sign In or Register to comment.