link icon
Ask The Community

User time out even after purchasing TV license - Help

So I recently purchased a server running Windows Server 2019. I installed Teamviewer and learned that I had to purchase a license otherwise I would be breaking the EULA for "Commercial Use"

No problem...So I purchased the cheapest TV license that allows you to license 3 PC's (I believe it was the $300/yr license). Everything was working fine until I needed a partner to connect to the server. Everytime he tried to connect, he would be timed out after 5 min and this error message would appear:

"Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try later or upgrade your license."

He is using the free version of TV on a Windows 10 PC.

Any idea why is this happening? Is it because the partner's connecting to the server are using the free version of TV?

I paid for the license and it is activated on Teamviewer. Before I purchased the license, I did some research and was told as long as the host PC is licensed, connecting partners will not need one.

Any help would be greatly appreciated.


  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @BradTartaglia,

    TeamViewer Remote Access plan is a single user license for connections to 3 designated devices. Please refer to the FAQ and typical use cases in our article

  • BradTartaglia
    BradTartaglia Posts: 2 ✭✭

    I'm still confused... So you're telling me that even after buying a license, Anyone who needs remote access to my server will also need a license?

    What is a solution to this issue?

  • philk07
    philk07 Posts: 2 ✭✭

    Having a similar issue with a free license for connecting to my home 3 PCs. From one of my PC (Heavenly), I have no issue remotely connecting to the other 2 PCs (Taos & HomeTV) without any timeout. But on one of the PC (Taos), I get the timeout message when remotely connecting to either of the 2 PCs (Heavenly or TVHome). I first get the timeout after about 1 minute (attached screenshot, "Your TeamViewer session has timed out...") and it not due to inactivity. Then when I try to remote back in, get the other error message "Connection blocked ..." (attached). The actual lockout time "... until 21:48" is much shorter time than described in the error message. But the 1 minute timeout is consistent.

    All the PCs are Windows 10 and are running the TeamViewer 15.13.6 (32-bit). I have tried to uninstall and reinstall on the PC (Taos) that always gets the remote timeout when accessing the other two PCs but same issue.

    This use to work properly on version 14 before but not sure if the issue started with the initial release of version 15 software release or an update.

Sign In or Register to comment.