teamviewer.com link icon
or
Ask The Community

Trusted device email never received

Hi, 

 I have set up 20+ accounts within my managemnt console but for some reason a few of these accounts never get the email to activate or trust a device. I have used the link to login for the 1st time https://login.teamviewer.com/cmd/joincompany

 but it always then tells me to check my mail for the trusted devices link and  it is this I never receive. Is there another way to get this link? 

Best Answers

«1

Answers

  • I also just now tried on a free account to replicate as that email is a gmail account. That account did not get a email to allow the device to connect..

    Maybe someone can try to access their account from a differant browser or something, then look at the headers and give us a hostname  and ip that the email comes from.

    The only way I can get to management console is:

    From the machine running the teamviewer account, in the teamviewer app,click on connection, then management console. It will open the browser and then let you connect. If I simple open the browser myself and connect, I can not, because of the error about trusted devices. Yet on neither account do I ever get the email.

  • Okay guys I found the issue and how to resolve it. It looks like you have to activate "Two factor authentication". You will have to be at a computer that is already logged into the TeamViewer software. 
    1.) From the software click on "Connection" Then click on "Open Management Console".
    2.) From the Management Console click on your name on the top right of the screen and choose "Edit Profile".
    3.) Now click on "Two factor authentication".  
    4.) You will need a smartphone app to generate the security token and to use when adding computers or for logging on to TeamViewers website.  I use Duo Mobile. The only drawback to the Two Factor Authentication is that you have to use your mobile phone when logging in.

    I sure hopes this helps! I am not sure why Teamviewer hasn't responded with this solution. I was beating my head against the wall until I figured this out.

  • I've started running into this issue just last week.  The email link has always come through in the past without issue.  Checked my inbound SMTP to make sure it wasn't blocked by spam filters.

    While I appreciate the suggestion to enable Two-Factor authentication, I don't see this as an actual solution since I've made no changes to my infrastructure and do not wish to require my mobile device every time I need to add a computer to my list.

  • Radioactiv
    Radioactiv Posts: 1

    Hi!

    I had this issue for serveral weeks .. i changed my email adress and now its working again! 

  • Same for about a year would drive me nuts!

    Changed email address from last working pc (not password) to use a different email. Wow I got confimation of email change email, and add trusted device email. So I downloaded teamviewer on my home server, and noticed it said login with user id, or email!.... so I tried user id/ password. It connected right away with no add device nag!!! Tried to change email back with no luck.  no email at all. Actually it did not even change as it said it did. Add device emails still come to new address. At least it works.

  • I have an account on aol mail but whenever I want to add a computer it says it doesn't recognize the pc and will send an email which I never get. I then set up anoyher acount on gmail and with that account I can add a computer and get the link in the email.

  • [email protected] is the address I received from them

  • WabtecSLM
    WabtecSLM Posts: 1

    I will try that email address.  I agree that two step authentication is not the way.  This software leaves much to be desired.  The documentation is piece meal and depends on the user community to do the work and fix the issues.....I am getting very frustrated!

  • Robama
    Robama Posts: 2

    I have this same problem after my trusty old machine died and I had to reinstall on a new PC.

    I now get the message about sending me a trusted device email that never arrives. No mail in junk folder to anything else to indicate that the email has actually been sent :-(

    I have validated that the email address and password still work by logging in from a browser on a different machine (same machine pops up trusted device email from another browser, also never received).

    I assume there is an issue/filter at the TV end, how can I contact someone to get things working again?

    This is so frustrating! Any help gratefully received.

  • Robama
    Robama Posts: 2

    Hi @JeanK,

    Thanks for the quick reply. The problem I have with 2 factor authentication is that I will always need my phone to login on the PC which is a pain.

    Is it possible to enable 2 factor, add the device, remove 2 factor so I can continue to use it without the need to have a phone nearby all the time?

    It seems there is some kind of email address validator that is being over aggressive given the number of posts about this problem in the community?

    Thanks

  • JeanK
    JeanK Posts: 4,219 Moderator

    Hello @Robama,

    Thank you for your message.

    Unfortunately, what you suggest is not possible. Once you will disable 2-FA, the system will ask you again for the validation e-mail for this particular device.

    You will have to choose between the trusted device system or 2-FA. :-)

    Cheers

    Jean

    French Community Moderator
  • mymaus
    mymaus Posts: 1

    Has this problem EVER been actually solved?  I searched the community and MANY people have the same problem but there is NO response form the Teamviewer people.

    My situation is...I am on the free version. My host systems are set up. I wanted to use my Ipad and my Samsung S5 android based smart phone to access my hosts. My ipad was successfully trusted through the email I received. When I tried to get my phone working, it gets the message that the email is coming and....I never get an email. I reied unictalling and reinstalling TV on the smartphone...no success.

    I read on the community that supposedly, setting up 2 factor authentication would help, but that makes this a major hassle.  Are there any real answers out there? This seems like a VERY simple thing to resolve. Anyone?   Anyone? Bueller?

    Thanks in advance for any help! Tom

     

  • Kalel
    Kalel Posts: 13 ✭✭

    Do we have the solution for this? My friend is not receiving email.

  • Kalel
    Kalel Posts: 13 ✭✭

    Same error

  • JeanK
    JeanK Posts: 4,219 Moderator

    Hello @Kalel,

    Thank you for your message and welcome in the Community! ?

    As you own a TeamViewer license, please contact our support. They will process a whitelisting that will solve your issue. ?

    Best,

    Jean

    French Community Moderator
  • Kalel
    Kalel Posts: 13 ✭✭

    Hi Support,

    Can i get the email address of Support so i can forward my friends concern.

  • JeanK
    JeanK Posts: 4,219 Moderator

    @Kalel to contact our support, please use the following link: https://support.teamviewer.com/a/ 

    You will also find all the information you need in our Knowledge Base article here: How to submit a ticket.

    I hope this could help. ?

    Best,

    Jean

    French Community Moderator
  • wlahs
    wlahs Posts: 3

    Happy July 2020.  Same problem.  I never recieve my email to validate my account or to enable trusted devices.  I have attempted to change email to my gmal account, and that doesn't work either.  I never recieve the email to validate.

    I cannot open a support ticket apparently since I am using ther free version of the software for personal use... but I can't actually use it effectively if I cannot get the validation / trusted devices email.  How can I get my email whitelisted so that I can recieve the emails?

  • I am not getting trusted device or password change issues on my work account**Information removed as per Community Guidelines**.  I have checked our mail server and I do not see anything being blocked, and there is nothing in my spam/junk folders.  I also am unable to log in from a previously trusted devices as I switched laptops a few weeks ago and am unable to log in from the old one.  Can anyone offer assistance?

  • altechsolutions
    altechsolutions Posts: 3 ✭✭

    Hi Support,

    A couple of months ago, I stopped receiving ALL emails from Teamviewer. This includes the "Trusted Device" emails which makes it impossible to use when trying to add new devices.

    Could this please be fixed A.S.A.P.

    Cheers

  • altechsolutions
    altechsolutions Posts: 3 ✭✭

    I just received the Teamviewer Community email, but I don't receive any others.

  • altechsolutions
    altechsolutions Posts: 3 ✭✭

    This is not a solution, it's a work around!

  • I am unable to login to Teamviewer Management Console (web) or add new computers to my account, as I am not receiving the device authorization emails sent form TeamViewer (they are not in Spam or Junk folders). I had to login here with a Free Teamviewer account to start a new topic, and am unable to submit a ticket...

  • Hello!

    I'm unable to sign into my Teamviewer account. The message I have received multiple times is: "To ensure the continued security of your account, you need to first confirm this browser is a trusted device. We have sent you a confirmation email containing a device authorization link. If you don't receive this verification email within a reasonable amount of time, please check your junk or spam folder. Read further information about trusted devices."

    But I never receive an email (and yes, I've checked spam). 

    After reading various messages from other users, it seems this can only be solved by someone from TeamViewer. I'm signed in now with a free account but I need to access my paid account.

    Could someone please contact me to solve this issue?

    Thanks!

    Beth Steckel (**Please Do Not Post Email Addresses**)

  • This issue still occurs. I checked with our Exchange Admin and we are not even receiving emails from Teamviewer for the account signed up. Cannot complete the account activation because I never get the email that is required to complete the account confirmation / activation.

  • rbranko
    rbranko Posts: 1 Newbie

    Hi,

    I have the same problem, I'm not receiving a confirmation email when I try to change my default email address, nor a trusted device confirmation email. It's like my email address is on some kind of block list. I had to open a new free account with new email address, and when I tried to revert email to the old one, I was unable to do so, because confirmation email is not coming through to my first address..

    Is there any way to solve this? Or at least to delete my first account so I can re-use my first email address?

    Thank you

  • GringoTM
    GringoTM Posts: 2 Newbie

    All people same problem....

    I think they need a new sistem, blacklisting ramdomly all emails of al free user can only make "Expand" space of Database, i have make a new account only for write on forum, they have ban forum login too.

  • JeffPeters
    JeffPeters Posts: 3 ✭✭

    We have the same issue with random users within our company. after numerous calls and emails, we found out that the email was blocked on Teamviewer's side due to Anti-Spamming laws in Europe. I am guessing something triggered our emails on their end to put on their anti-spamming list. once they removed our email from that list, the emails began coming through again. Teamviewer couldn't tell us exactly what caused the trigger in the first place.

Sign In or Register to comment.