link icon
Ask The Community

Commercial use - Connection time out



  • Getting this stupid message. I used to love this program but I'm uninstlling it soon from all my devices and going to any of the other free options in the same space as you. I"d name them but like a petulant child you mark them out with *Third Party*. If you're that good you shouldn't be threatened by a competitors name. As a free user you don't care anyhow...I can see you nodding yes. Good ridence. 

  • Hi team viewer representative

    Unfortunately, my account was deactivated. I'm a student at the University of Houston but I was doing my internship at Nvidia now since the laptop from Nvidia has business windows you deactivated my account.
    I'm done with the internship and there is no business windows anymore.
    Please activate my account. This semester I will graduate and I need to work remotely.
    Please let me know if you need more information, I can provide you my limited work authorization that proves I'm a student and right now I was an intern.

    Thanks, I greatly appreciate your help and understanding.


  • So I finally heard something from  TV. I had to actually go to Twitter and call them out for the lack of customer service, in order for them to respond.  After they eventually responded they still said I using TV  it commercially.

    I have uninstalled TV and not renewing my actual commercial account with Teamviewer, that my IT team uses. We will be switching to another product. 

    Maybe we should all go to Twitter and social media and bring this into the public light and let them deal with this marketing nightmare. 

  • In the end I just setup remote desktop to my home pc from my work laptop. setup port forwarding on my router to route to my dekstop private ip, added and inbound firewall rule ini the router, and just use rdp to remote to my router Ip. works just as good. does what i need for now anyways.

  • After using Teamviewer for 2 years of personal use my account was locked for commercial use after the august update to IoS. I submitted a ticket and the account was unlocked. About a month later it was locked again. I use my phone at work on work wifi IP address every now and then and I'm sure that is why it's being locked. Work IP uses a high rate corporate TeamViewer account. 

    Very unfortunate that I had no issues for 2 years and then all the sudden an update and I'm locked with no way to access my home server. 

  • hello,
    i am using teamviewer to conect to my personal google cloud ubuntu virtual machine for my research on reinforcement learning.
    i only used teamviewer for personal use. I never used teamviewer for comercial use. but since last week, i start to have this message, that i am using it for comercial use and i cant connect more than 1 minute before the connection close. then i have to wait 10 minute to reconnect.
    how can we fix this probelm?
    best regards,
  • So today when I tried to help my friend fix something preventing him from using his PC, my TeamViewer session randomly terminated. Upon trying to reconnect I was told I needed to wait 11 minutes to reconnect. When I was finally able to reconnect I was informed that "action" was necessary and that I was using the software as a business customer. The session again terminated after roughly 30 to 40 seconds.

    I do not, and have not ever, charged anyone for fixing their issues over TeamViewer. I do not own a business license. Furthermore, I haven't used TeamViewer in weeks. I help my friends out with their issues at most 3 or 4 times a month. Either your algorithm for detecting "business" users needs to be reviewed by a professional, or someone's on my account without my knowledge.

    Can you guys please reset my account back to a free user and take a look at what part of your algorithm flagged me as a commercial user and actually fix it. Thank you for your time.

    [The log files have been removed as per the community guidelines.]

  • I run a research group at Arizona State University. but use my gmail account [The email has been removed as per the community guidelines.] for my 'free' Teamviewer account.  I use this to remotely access a range of remote computers and my account has been 'flagged as commercial use'.  Who do I contact and what info do I need to provide so that my account is not flagged for commercial use?   Or do I have to use my email address to setup the teamview account?

    Thanks, Jeff

  • DrReed
    DrReed Posts: 1

    Any updates? I have a similar issues after all this time - now, and without any advanced notice, i'm shut out of teamviewer. I use my gmail accout, not my .edu, and don't charge for my services or anything like that. I  have multiple commputers (and of course have my mom and dad on the list so I can fix whatever problem they have).......

    @jyarger What do we do?

  • dsaul
    dsaul Posts: 1

    Found the device ID the reset form is looking for:

    1. In the Teamviewer app, click on the "Computers and Contacts" tab.

    2. In the My Computers pulldown, click on the computer you cannot log into.

    3. In the right panel, click on the gear icon next to the computer name.  Then click on Properties.

    4. The computer ID will be listed in the dialog box!

  • Greg176
    Greg176 Posts: 1

    I’ve been using the free edition of TeamViewer for years to manage my mother’s computer. She lives several states away and she’s been living in a nursing home for several years now. Recently I tried to connect to her computer and was disconnected with a message that it appeared I was using TeamViewer in a commercial environment. I use TeamViewer to perform routine maintenance and to solve problems she has from time to time. I don’t receive any money from my mom for doing this. Please allow us to keep using TV so I can continue to provide her with the help she needs. I have written to TeamViewer repeatedly to request that the commercial ban be removed from my account. I have complied with all your requests and you have either refused or completely ignored my communications.

    If TeamView continues to ignore my requests I intend to file a complaint with the US Federal Trade Commission for falsely advertising that this product is free for personal use. You state on this very same website your definition of what is “Free for Personal Use”:

    Family and friends

    In any case, the use of TeamViewer with family and friends without any financial compensation is considered as personal use.


  • I am having the same issue!

  • I am using teamviewer to occasionally help my friends and family with their computers, and TeamViewer often tells me that it detects commercial use. Sometimes it still let's me through, sometimes it prevents me from connecting. Today I just couldn't connect at all :(

    I suspect there's a bug in detection of commercial use, because my use case is clearly non-commercial, but I wonder, is there anything I can do to work-around?

  • I install temaviewer company option now its expired, i want to install personal one but cannot

  • so, I got the alert that they beleive that I am trying to use teamviewer with my phone, is there a reason why it is only blocked on my phone? I am suprised that they would try to block an iphone.  You can buy a chromebook for a fraciton of the cost to make money that way...  

  • Yeah fianllly got an email from them insisting I am still using it commercially and I can print off a form, sign it and send it back to them with still no guarantee. Got news for you teamviewer - you have lost a long time user, have found aan altrenate product which is free and does everything TV does. But as I work in IT support, I will not be recomending your product to absolutley anyone at all in future evergagain. Whether that is for whatever company i work for or to friends anf family. 

  • I use the program for personal purposes, but when you start it gives a warning and after a remote connection is disconnected after a few minutes. How do I fix this? I use only for personal purposes, not on a commercial basis

  • Yershov
    Yershov Posts: 11 ✭✭

    All who wanted already done it.
    Just ask Google how to change ID?

  • Hello, I got the "commercial use detected" message as well and submitted the form. I waited for a week but didn't get any reply, so I resubmitted it. Eventually after 9 more days, received an email with the subject

    "Your support request: The ID you submitted is invalid/wrong."

    and the body

    " Dear TeamViewer User,

    Thank you for getting in touch with us. We were unable to process your request because the ID you gave us was invalid/wrong. Please fill in another form with the correct ID. Please note that the ID consists of nine numbers and is unique for every device."

    I do not understand why the cant process my request. My ID displayed consists of TEN numbers (not nine) and has the form "1 xxx xxx xxx" (with spaces included) and this is exactly how I submitted the form. Maybe I should not use the "1" and submit it as "xxxxxxxxx" without spaces? Also is there a way to expedite this instead of starting all over again because this long wait is really frustrating..

  • MJAarons
    MJAarons Posts: 4 ✭✭

    I have had exactly the same experience as you have.   

    In May of this year I had also received a "Possible Violation of EULA" email.  It said to ignore the email if I was not in violation of the personal use clause.  Therefore, I ignored that email.

    My understanding from reliable sources is that Teamviewer is trying to "nusance" away non-paying (i.e., personal use) users. If you look at their behaviour that makes perfect sense.

    I think the most effective thing people can do is find an alternative solution.  

  • Robbyguard
    Robbyguard Posts: 9 ✭✭

    wurde freigeschaltet und nach 3 längeren sitzungen wieder gesperrt. ich glaube ihr wollt die User ver**bleep**....n!! oder

  • I am now having the same problem I cannot get to my grandmother's computer or my fiance's computer on a regular basis they live in other states I do troubleshooting through TeamViewer and now can't be connected to them longer than a couple minutes all the computers involved run the latest version of TeamViewer I'm hoping I do not have to actually start searching for another solution please can someone help tell me where to look or what's going on I can connect from my phone to my computer for seemingly hours but any other computer no 

  • Sure yes the easy thing is to ditch teamviewer. However I am looking for a definite answer to my question.

  • rchaud
    rchaud Posts: 4 ✭✭

    Can someone post a link to that form mentioned?  Is this where i can appeal the "commercial use detected" warnings?

  • MJAarons
    MJAarons Posts: 4 ✭✭

    I agree that it would be nice to get an answer.  However, I fear that Teamviewer is sending people on a fool's errand in trying to get their personal use re-enabled. 

    Has anyone successfully completed their form and had their personal use re-enabled?  To date, I know of no one that has been successful.  I would love to hear back from anyone who was successful and learn what, and how long, it took to do so.

    Best of luck.

  • A couple of months ago I put through the formal request to be re-enabled.  It was approved. It worked once, or maybe twice.  Then the "commercial use suspected" started up again.

    Honestly, there's no reason to stay on TV for any private individual using it for informal personal use.  There are other solutions. 

    It would seem appropriate to report them for false advertising.  Alternatively a class-action suit, but since we haven't paid anything, we haven't been defrauded of cash.  Only time.

  • Steve-in-FL
    Steve-in-FL Posts: 27 ✭✭

    @MJAarons wrote:

    Has anyone successfully completed their form and had their personal use re-enabled?  To date, I know of no one that has been successful.  I would love to hear back from anyone who was successful and learn what, and how long, it took to do so.

    Yes. Search for my posts in this topic and you will find a long-ish explanation of what I did. I was unblocked on all 13 IDs that I use, about 4-6 weeks ago. Have not been reblocked since.

    Some people have had good luck and success.


  • rchaud
    rchaud Posts: 4 ✭✭

    Thanks but i had found it right after I posted.

    Right now my account locks up after 5 minutes of use and i have to wait about 10 minutes before i can connect again.  


    i dont know what i did that could be interpreted as COMMERCIAL use. Only thing i could think of is me sometimes connecting to my home PC from my work office on my company's network which goes through a proxy. I also sometimes use my perosnal laptop on my work network when i'm doing my homework

  • HI, im using the personnal team viewer  in between my 2 computer.. it always work great but now when im log in it said commercial use, it will be disconnected in 5 minute.. i didnt click or use it commercial.. what can i do do make it run back again without the message and they disconnecte me every 5 minute..


    Thank you