No sound from remote computer (Linux local and Windows remote)

I use a Linux home computer to access a windows remote computer. I do not get sounds from the windows remote computer when connecting from home.

I have TeamViewer15 on both machines

There is a post from 2017 with similar issue, but it shows the fix as being part of a new installation. Perhaps this has something to do with the mix of Linux and Windows??


  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Hi @Hawksley71 

    Could you please provide a screenshot fo the windows machine (the down right corner with the sound settings) before and during connection? 

    Please hide your ID and password.

    Best regards

  • My Windows machine has external speakers connected through headphone jack.


  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Can you please check if the following boxes is enabled to the menus

     Extras > Options > Remote Control > Play computer sounds and music

     Extras > Options > Meeting > Share computer sounds and music



  • I found that I had the "Play computer sounds and music" checked for "remote control".

    For "meetings", I did not have sounds and music checked, so I checked it and then ended/restarted my connection. The windows machine is the remote machine.

    However, still no sound through the remote connection.

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    ok, there is on detail that it has to do with the apps nature. Many times the apps must be restarted by closing and re-open, in order to apply new settings. Others it may need and windows reboot depends on how each app is working, which libraries need etc.

    Please tell me one detail that didn't mention before. In the Linux machine, you have speakers and you hear sound locally as well?

  • I rebooted the remote machine, but no change in status for the sound.

    The local Linux machine has great sound.

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    Here is a possible quick fix that is copied from another source:

    Go to "Extras" → "Options" → "Audio Conferencing" → "Voice Playback".  Change it to any device other than the one you are using for local audio.

  • I tried each of the options (other than default), but still no sound.

  • Vatsilidis
    Vatsilidis Posts: 655 ⭐Star⭐

    It is possible to uninstall the app on both machines, reboot and instal again the latest version?

    You can see here the how-to-uninstall correctly.

  • I will try the uninstall on the remote machine when I return to the office next week.

    For the local machine, I did not see instructions for Linux, but I think I can figure it out.

  • Same problem here but with inverted machines (Windows Local and Linux remote). Has anyone a soulution? Running latest version of TV on both machine (on remote there is the host version).

  • vinRocha
    vinRocha Posts: 1

    I'm facing the same issue here. I cannot hear anything from the remote computer.

  • I'm having the exactly same issue (wIndows 10 Pro remote + Linux Mint 19 local)

  • api-tv
    api-tv Posts: 1

    Teamviewer(15.7.6 Jun 22 2020) on linux has no Extras > Options > Remote Control option, only three:

    Extras > Options > General

    Extras > Options > Security

    Extras > Options > Advanced

    So, the checkbox Play computer sounds and music of Options for remote control of other computers in Extras > Options > Remote Control is unavailable in linux now.

  • So this means that there is no way to fix this issue? Because I am also having the same issue.

  • anthony_761
    anthony_761 Posts: 0

    I also have these options only... this is anoying because I remenber few weeks ago I had sound from my ubuntu 20.04 remote computer and Teamviewer 15.15.5

  • DSUK
    DSUK Posts: 1

    I am running TeamViewer on Zorin (Linux) and could not get sound (in either direction - client to hear me, or me to hear client). My client was and an Apple Mac.

    I had the TeamViewer App -> TeamViewer Options -> Remot control -> Play computer sounds and music ENABLED

    Is this broken?

    NAME="Zorin OS"




    PRETTY_NAME="Zorin OS 16.1"