Posted by EtagiBI
Henagon

Gray screen insted of app interface wnen opened via TeamViewer

Hello,

When I try to launch Blender app on a remote PC via TeamViewer, I get a gray screen. It seems that Blender can’t render the interface.

fd832c6af77c4ed2d234cafd0a4c0933872ec65e.png

The remote PC works on Windows 10 Pro and has no monitor. 

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Gray screen insted of app interface wnen opened via TeamViewer

Dear @EtagiBI ,

Thank you for your message.

Typically, monitors or notebooks display shall report their data (such as what resolution they support) to the graphic card once they are connected.
The monitor itself does not need any power, as the HDMI / DVI / VGA cable itself provides enough power.
Unfortunately, there are some monitors that will only pass their data to the graphic card when they are turned on/have power.
In this case, the graphic driver shall decide what it wants to do when the monitor is not detected. There have been 3 cases detected thus far:

1) Everything works as before, but with minor restrictions on the available resolutions.
2) Window contents that are drawn hardware-accelerated (e.g. browser content or 3D applications / games) are no longer drawn (you cannot see the application).-> your case.
3) Nothing is drawn anymore (screen is black).

TeamViewer grabs the screen as it is currently displayed.
In other words, if Windows did not draw anything, TeamViewer cannot grab the screen, so you will only see a black screen. Unfortunately, we cannot do anything against that.

The only workable solution here is to prevent the monitor from being not detected.
This can be achieved either by the fact that the monitor is always on or by using a monitor that is recognized by Windows even when it’s turned off.
It may also help to connect the monitor in another way (e.g. via DVI instead of HDMI, or with another adapter, if one was used).
Alternatively, a dummyplug can also help.
In theory, it may also help to use a different version of the graphic card drivers or a fixed-resolution monitor driver to solve the black screen problem or the problem with the hardware acceleration. Other graphic card driver settings could help, but we do not know what settings that could be exactly. But it would most likely have something to do with the energy-saving mode.

If you have any further questions, please do not hesitate to contact us again.

Giovanni
Enterprise Solutions Engineer

If my reply answered your question, help out other users and click the "Accept as a Solution" button below.
You can also say thanks by clicking on the "Thumbs Up" button! (Kudo)
1 Reply
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Gray screen insted of app interface wnen opened via TeamViewer

Dear @EtagiBI ,

Thank you for your message.

Typically, monitors or notebooks display shall report their data (such as what resolution they support) to the graphic card once they are connected.
The monitor itself does not need any power, as the HDMI / DVI / VGA cable itself provides enough power.
Unfortunately, there are some monitors that will only pass their data to the graphic card when they are turned on/have power.
In this case, the graphic driver shall decide what it wants to do when the monitor is not detected. There have been 3 cases detected thus far:

1) Everything works as before, but with minor restrictions on the available resolutions.
2) Window contents that are drawn hardware-accelerated (e.g. browser content or 3D applications / games) are no longer drawn (you cannot see the application).-> your case.
3) Nothing is drawn anymore (screen is black).

TeamViewer grabs the screen as it is currently displayed.
In other words, if Windows did not draw anything, TeamViewer cannot grab the screen, so you will only see a black screen. Unfortunately, we cannot do anything against that.

The only workable solution here is to prevent the monitor from being not detected.
This can be achieved either by the fact that the monitor is always on or by using a monitor that is recognized by Windows even when it’s turned off.
It may also help to connect the monitor in another way (e.g. via DVI instead of HDMI, or with another adapter, if one was used).
Alternatively, a dummyplug can also help.
In theory, it may also help to use a different version of the graphic card drivers or a fixed-resolution monitor driver to solve the black screen problem or the problem with the hardware acceleration. Other graphic card driver settings could help, but we do not know what settings that could be exactly. But it would most likely have something to do with the energy-saving mode.

If you have any further questions, please do not hesitate to contact us again.

Giovanni
Enterprise Solutions Engineer

If my reply answered your question, help out other users and click the "Accept as a Solution" button below.
You can also say thanks by clicking on the "Thumbs Up" button! (Kudo)