Announcements

********

First Step Guides

********

  1. Are you new to TeamViewer and Home Office and need some help? Check out our FAQ here.
  2. New to the Remote Access Plan? Find our first steps FAQ here.
  3. Are you new to blizz and online meetings or classes and need some help? Check out our FAQ here.

********

Highlighted
Posted by
Henagon

Premium licence and deployment and usage.

Hi. We bought Premium licence to upgrade our Teamviewer 9 commercial licenced installations. I created a startup script in GPO that uninstalls Teamviewer 9 and then installs TeamViewer_Full.msi, that was downloaded from Teamviewer console.

I am installing it with /qn IMPORTREGFILE=1 switch to deploy also settings which are saved in reg file.  (installed TeamViewer_Full.msi on my pc, cinfigured it and exported reg file)

The problem is as follow. If I install the msi file by double clicking on it,  in About, i got licence info : PaidLicence and Expires date, as well as channel use. But when I install it with /qn IMPORTREGFILE=1, in About, there is no info about licence, just empty. Should i bother about that, as it works as expected - doesnt say anything about missing licence?

Also I dont quite understand how to use Premium licence, we are multiple admins that will need to connect to client pcs. Do every admin need to have account in management console, and then needs to login to the TW? Or it can be usable without need to login?

Also - when installed with IMPORTREGFILE=1, I cannot log in to the TW, as the email address field is inactive. Is this normal behaivior?

Thank You!

5 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Premium licence and deployment and usage.

Hello @kpcz,

Thank you for your message. ✌

Regarding the empty About TeamViewer window, you can ignore this. This window has sometimes display issues. As long as it works as expected, you do not have to worry about it.

The best practice to use a Premium license is to create a company profile and create a user for each person/admin that will use your license. 👌

You will find all the information you need in our Knowledge Base article here: Premium and Corporate license Administration

I hope this could help. 🍀

If not, do not hesitate to ask your questions here.

Cheers,

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Highlighted
Posted by
Henagon

Re: Premium licence and deployment and usage.

Hi. Thank You for Your answer. Just one more question regarding:

The best practice to use a Premium license is to create a company profile and create a user for each person/admin that will use your license. 👌

Does every admin created in console, needs to log in to the teamvwiewer instace from which he will make connections? As it is not possible, because email field to log in is disabled on teamviwer after deployment.

Posted by Moderator Moderator
Moderator

Re: Premium licence and deployment and usage.

Hello @kpcz

Yes, every admin created in your company profile will have to log in into their account in the TeamViewer console so your license is recognized and ready to be used.

It's possible that someting went wrong during the deployment. If the problem persists, even a restart of the TeamViewer service, please contact our support for help: https://support.teamviewer.com/a/

If you need any further information, please let me know. 🙏

Best,

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
2 Replies
Highlighted
Posted by
Henagon

Re: Premium licence and deployment and usage.

Found, it depends on setting in Netowkr Settings:

Our policy
Incoming Lan connections: accept excusively
Email field is disabled, and we cannot log in to teamvwier.

if policy changed to:

Incoming Lan connections: accept
Email field is active, and can log in.

So how to log in to teamvwier to recognize the licence and use setting Incoming Lan connections: accept excusively ?

Highlighted
Posted by Moderator Moderator
Moderator

Re: Premium licence and deployment and usage.

Hello @kpcz,

Regarding the recognition of your license, it is only necessary to log in once (via internet,  LAN setting set on deactivated or accept) so the system knows you are using the Premium license in LAN mode on a specific device.

The use of TeamViewer in Lan mode and having access to the comupter and contact list (being log in in the TeamViewer account) is only possible with the settings set on accept.

I hope this could help.

Best,

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.