Announcements

********

First Step Guides

********

  1. Are you new to TeamViewer and Home Office and need some help? Check out our FAQ here.
  2. New to the Remote Access Plan? Find our first steps FAQ here.
  3. Are you new to blizz and online meetings or classes and need some help? Check out our FAQ here.

********

Highlighted
Posted by
Henagon

Startup Screen Does not Display ID and Password

When I start up teamviewer I see a window with my ID and password on the left, some tabs on the left hand navigation and top navigation with "connection", "extras", "Help" and "feedback". I am using a free license.

I was trying to help a colleague of mine on his computer at home and I instructed himt o download the software as I have done for other people multiple times. However when he starts up his teamviewer, his window looks very different. FIrst of all he was forced to sign in (I usually do not). His screen looks like this screenshot below. No ID or password for me to enter, and no topline navigation or tabs on the side. Just this "Computers and Contacts" area on the right. Any idea why this looks different than every other instance of teamviewer I have seen and how to get ID and Password to display so I can help him with his computer issue?

Teamviewer 1 Capture.JPG

2 Replies
2 Replies
Highlighted
Posted by
Henagon

Re: Startup Screen Does not Display ID and Password

Anyone with any insight on this?

Highlighted
Posted by
Henagon

Re: Startup Screen Does not Display ID and Password

Anyone??