Highlighted
Posted by
Henagon

TV15 and deployment and host assignment

Hey there.

Until now we had Tv12 corporate licence and our company buy new TV15 licence.
Now we have to migrate from 12 to 15.
Ok, there is no problem. from policie i can set new update.

Problem appears when we want install deploy and finally assign.
Installation works almost fine, but there is problem with host. and we are using admin rights.

We have 10+ customized host's so this means many of computers.
But problem is when i whant to install customized host with our logo, informations and that was working great Tv 12 with teamviewer_assignment.exe.

In manual is written that if i what to do this, i have to use configuration_ID.
I use that, i use the rest every possibly idea but with no success.

Every time i chose i get normaly host -  default, not our.
I check i do not know for how many times apitoken, configuration id, save custom host,  download, overwritte it. But in the end, there is alqways isntalled with default TV appearance.

the second issue is, that in manual is written if i use configurationid and apitokone, host file knows in which group should "computer" belong, but it is working only if i written under assign. option --group OU_SOME_COMPUTERS.

examples:
msiexec.exe /i "\\something\TeamViewer_Host.msi" /qn CONFIGURATIONID=XXXXXXX APITOKEN=XXXXXXX-XXXXXXXXXXXXXXXXX ASSIGNMENTOPTIONS="--grant-easy-access --reassign  --group OU_SOME_COMPUTERS"

msiexec.exe /i "\\something\TeamViewer_Host.msi" /qn APITOKEN=XXXXXXX-XXXXXXXXXXXXXXXXX ASSIGNMENTOPTIONS="--grant-easy-access --reassign  --group OU_SOME_COMPUTERS"

msiexec.exe /i "\\something\TeamViewer_Host.msi" /qn APITOKEN=XXXXXXX-XXXXXXXXXXXXXXXXX CONFIGURATIONID=XXXXXXX ASSIGNMENTOPTIONS="--grant-easy-access --reassign  --group OU_SOME_COMPUTERS"

msiexec.exe /i "\\something\TeamViewer_Host.msi" /qn CONFIGURATIONID=XXXXXXX ASSIGNMENTOPTIONS="--grant-easy-access --reassign"

I'm open for every additional inforamtion.

 

Best regards.

 

 

5 Replies
5 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: TV15 and deployment and host assignment

Hello @Marekk,

Thank you for your message. 🙌

The command lines you are using look good. No technical issue here. 👍

The customization is granted though the TCP port 443. Could you check if you have open this port in your network? This might cause the issue here.

You will find all the information about ports in our Knowledge Base article here: TCP Port 443 

I hope this could help. 🍀

If not, do not hesitate to ask your questions here. 👇

Best regards

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Highlighted
Posted by
Henagon

Re: TV15 and deployment and host assignment

JeanK first of all, thanks for quick reply.
I was trying to resolve issue with different kinda network, otherwise, i have normal access to all ports, 80, 443 and 5938.
I'm cooperating with our system administrators, just for any case, they prepare me full open network, but without any success.

Highlighted
Posted by
Henagon

Re: TV15 and deployment and host assignment

In desperate time i try also create new custom host and deploy it with msiexec and there is the same problem.

Also i try it with assignement with teamiveer.exe and also with out any success.

Highlighted
Posted by Moderator Moderator
Moderator

Re: TV15 and deployment and host assignment

Hello @Marekk,

Could you please also make sure to allow the following on your firewall/network: 

  • master*.teamviewer.com
  • router*.teamviewer.com
  • Customdl.teamviewer.com (UI Customisation, Logo, etc.)
  • webapi.teamviewer.com (Assignment + Policies).

I hope this will help, please let me know how it goes. 🍀

Best regards

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Highlighted
Posted by
Henagon

Re: TV15 and deployment and host assignment

JeanK, thanks for reply.

I was in contact with our IT administrator and he ask me, if i can get for every written adress valid ip's?

We did response ror let esay master*teamviewer.com

Thanks and best regards.

Marko