Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Photon

Installin TeamViewer v.15 on Ubuntu v.14_04 x64

Guys,

Is there a way to install the last version of TeamViwer ( version 15.0.8397) on Ubuntu 14_04 (x64)? I need to make some tests in this specific Ubuntu version.

I've tried to install but I get the following message: "dependency is not satisfiable libqt5gui5 qt56-teamviewer". Before opening this topic I've already tried to install following other topic's tips, but nothing worked.

Someone could help me, please? Is there another app to substitute TeamViewer in this case?

Thanks a lot!

1 Reply
1 Reply
Highlighted
Posted by
Tetragon

Re: Installin TeamViewer v.15 on Ubuntu v.14_04 x64

hi,

ubuntu 14.04 uses by default Qt5.2; and is no longer supported by TV.

nevertheless you can try - at your own risk - a libqt5 backport PPA

I tried the following:

- installed a Ubuntu 14.04 using  ubuntu-14.04.6-desktop-amd64.iso in a VM
- configured https://launchpad.net/~beineri/+archive/ubuntu/opt-qt597-trusty PPA

sudo add-apt-repository ppa:beineri/opt-qt597-trusty
sudo apt-get update

 - installed qt5.9 packages:

sudo apt install qt59-meta-minimal 

 - downloaded TV .tar distribution ( https://download.teamviewer.com/download/linux/teamviewer_amd64.tar.xz ) and extracted it

- used ldd to find out the missing libs: 

LD_LIBRARY_PATH=/opt/qt59/lib ldd teamviewer/tv_bin/TeamViewer

 

- installed more qt59 libs:

sudo apt install qt59x11extras qt59quickcontrols

- start TV using:

LD_LIBRARY_PATH=/opt/qt59/lib teamviewer/teamviewer

- UI shows up ; it took a while til the UI reported 'Ready to connect'

- used TV on my normal box to connect to the Desktop of the newly installed Ubuntu in the VM.

may be this helps

br
Roland