Highlighted
Posted by
Henagon

Local computer lock screen after inactive timeout

I use TeamViewer 15.4.4445 on Linux Mint 19. Because of the coronavirus epidemic, we all switched to distance education. When I listen the speaker using TeamViewer and not move mouse and not press keys on keyboard my screen locked as inactive. I need to enter password to continue. Can TeamViewer send dummy active signal such as VLC player when I look film to prevent screen lock?

4 Replies
4 Replies
Highlighted
Posted by
Tetragon

Re: Local computer lock screen after inactive timeout

Highlighted
Posted by
Henagon

Re: Local computer lock screen after inactive timeout

Your solution about VLC application but I havn't problem with VLC, I have problem with TeamViewer. VLC as example and it has option "Disable screensaver". I need such option in TeamViewer preferences.

Highlighted
Posted by
Tetragon

Re: Local computer lock screen after inactive timeout

just exchange vlc with teamviewer:
       xset s off; teamviewer; xset s on;

either in a bash script or a desktop file

Also Mint might give a configuration option to disable the screensaver locally.

Highlighted
Posted by
Henagon

Re: Local computer lock screen after inactive timeout

I don't need a ctutch solution. Also I don't want to disable screensaver at all. It is a problem of TeamViewer application that haven't options to disable screensaver during active session.