Highlighted
Posted by mcon
Henagon

Teamviewer stopped working for me

TeamViewer stopped working for me, presumably after some system upgrade; Im on a fairly up-to-date Debian GNU/Linux (Sid).

I am using it not very often, so I'm unsure exactly when and how things went wrong.

Today I tried to start the GUI and it silently failed; gui.log shows:

/opt/teamviewer/tv_bin/TeamViewer: /opt/teamviewer/tv_bin/RTlib/qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /usr/lib/x86_64-linux-gnu/libQt5WebKitWidgets.so.5)
/opt/teamviewer/tv_bin/TeamViewer: /opt/teamviewer/tv_bin/RTlib/qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /usr/lib/x86_64-linux-gnu/libQt5WebKit.so.5)
/opt/teamviewer/tv_bin/TeamViewer: /opt/teamviewer/tv_bin/RTlib/qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5)
/opt/teamviewer/tv_bin/TeamViewer: /opt/teamviewer/tv_bin/RTlib/qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /usr/lib/x86_64-linux-gnu/libQt5WebChannel.so.5)
/opt/teamviewer/tv_bin/TeamViewer: /opt/teamviewer/tv_bin/RTlib/qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /usr/lib/x86_64-linux-gnu/libQt5Positioning.so.5)
/opt/teamviewer/tv_bin/TeamViewer: /opt/teamviewer/tv_bin/RTlib/qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /usr/lib/x86_64-linux-gnu/libQt5Sensors.so.5)

Can someone suggest what to check?

UPDATE: it seems directory "/opt/teamviewer/tv_bin/RTlib" does not exist, neither on my machine nor in "teamviewer_14.6.2452_amd64.deb".

What am I missing?

 

Thanks in Advance

MCon

6 Replies
Highlighted
Posted by rolandg
Trigon

Re: Teamviewer stopped working for me

i just used apt to install the teamviewer  .deb file, and it automatically identifies the depending packages:

# apt install ./teamviewer_14.7.1965_amd64.deb

... libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5positioning5 libqt5printsupport5
    libqt5qml5 libqt5quick5 libqt5sensors5 libqt5svg5 libqt5webchannel5  libqt5webkit5 libqt5widgets5 libqt5x11extras5 ...

Highlighted
Posted by mcon
Henagon

Re: Teamviewer stopped working for me

apt install whatever.deb

Will not work (unless "whatever" happens to be the NAME of a package). `apt` does *not* accept filenames.

Completely removing all TeamViewer leftovers and doing:

gdebi path/to/teamviewer/package/teamviewer_14.7.1965_amd64.deb
... or...
dpkg -i path/to/teamviewer/package/teamviewer_14.7.1965_amd64.deb
apt install -f

... will actually solve the problem.

Posted by rolandg
Trigon

Re: Teamviewer stopped working for me

3 Replies
Highlighted
Posted by mcon
Henagon

Re: Teamviewer stopped working for me

I'm curious to know what distribution You are actually using.

On my Debian Sid `apt` does *not* behave that way.

mcon@cinderella:~$ ls -l Downloads/teamviewer_14.6.2452_amd64.deb 
-rw-r--r-- 1 mcon mcon 13966020 Oct 21 20:59 Downloads/teamviewer_14.6.2452_amd64.deb
mcon@cinderella:~$ sudo apt install Downloads/teamviewer_14.6.2452_amd64.deb 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package Downloads

Installing using `dpkg -i` or `gdebi` works as expected though (but needs later fixing with `sudo apt install -f`).

Regards

Highlighted
Posted by rolandg
Trigon

Re: Teamviewer stopped working for me

i did the experiments using   Debian GNU/Linux 10 (buster)

I installed the VM using  debian-10.1.0-amd64-netinst.iso

Highlighted
Posted by rolandg
Trigon

Re: Teamviewer stopped working for me

put a    ./     in front of Downloads/...