Posted by Ross_Chevalier
Henagon

How to connect to machine running older macOS

Hi,

I am a personal version user.  My wife has a machine that cannot run a newer version of macOS due to an application dependency, plus the machine is older and cannot run later versions.  (The application was very expensive and works just fine and she hasn't the funds to upgrade it).  Today I tried to connect to fix a certificate problem for that machine and Teamviewer told me to do a remote update.  This failed because the OS version on the computer is too old for the latest Teamviewer (14.x).

Do I have to find another remote solution for this one machine that I connect to maybe once every 60 days?  It strikes me as really stupid that my current teamviewer is being locked out from connecting to this machine simply because it is on an older OS and cannot even install the latest Teamviewer.

How does this get rectified?  I know that I am not paying for the use of the software.  I get that, but it has worked for years, and I don't need it enough to warrant its business license cost.

We do pay for Teamviewer at my place of business and I approve those purchases.  I will be disinclined to do so in the future because of this foolishness.  Please provide a workable solution that is simple to implement.

Thank you

3 Replies
3 Replies
Posted by Moderator Moderator
Moderator

Re: How to connect to machine running older macOS

Hello @Ross_Chevalier,

Thank you for your message.

Unfortunately, for our free users, we do not have any workaround for this issue.

You will find all the information you need in our Knowledge Base article here: Enjoy using the best version of TeamViewer we made so far! - How to proceed?

Paying customers can remain using their purchased version.

I thank you for your understanding.

Cheers

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Posted by Ross_Chevalier
Henagon

Re: How to connect to machine running older macOS

Thank for the prompt response.  Sadly it does not help me and I will have to find an alternative.  I realize that my personal experience is irrelevant to you, but I find the decision to leave users who cannot afford to keep replacing machines, OSes and applications very disappointing.

I did view the link.  It makes no mention of limits based around OS version and it should be updates to reflect these limits as users will believe that they are in good stead when in fact they are not.  

I think that you have made a business error, but understand that my perspective does not matter.

Posted by H2D
Electron

Re: How to connect to machine running older macOS

Same issue here.

I have old mac with tons of old apps and software. What should I do? Everything was working fine until recently. Now TeaViewer limits sessions to 5 mins and asks to update, which my mac simply can not do.

TeamViewer 9 is the very max for the system, so what should I do??? I can't update Teamviewer up to 14 and even when I do "check for updates" Team viewer gets back to me saying that the current version is the latest possible for the system.