Highlighted
Posted by
Photon

Incompatible Versions

Hi, I have the commercial version of teamviewer 12 and serve more than 300 clients remotely, some clients upgrade to version 14 and I get no access for lack of compatibility. Is there a way to remotely downgrade this client? Thank you very much in advance.

4 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Incompatible Versions

Hello @Andrenk

Thank you for your message.

Unfortunately, it is not possible to downgrade the versions of TeamViewer clients.

However, to avoid this in the future, we highly recommend you to set up a TeamViewer policy that prevents the update.

The policy you need need to add is: Install new versions automatically.
Please set up this on No automatic updates.

All the TeamViewer client you are managing won't update automatically and stay in version 12.

I hope this could help. If not, do not hesitate to ask your questions here.

Cheers,

Jean

French Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution button below. ✅
You can also say thanks by clicking on the Thumbs Up button!
Thanks for being an active member of our Community!

Posted by
Digon

Re: Incompatible Versions

 had the same issue so I deleted the non compatible version then installed the version that was the same as what I have (V12.xxx) after installing the matching version I could NOT connect to it. What could be wrong?


@JeanK wrote:

Hello @Andrenk

Thank you for your message.

Unfortunately, it is not possible to downgrade the versions of TeamViewer clients.

However, to avoid this in the future, we highly recommend you to set up a TeamViewer policy that prevents the update.

The policy you need need to add is: Install new versions automatically.
Please set up this on No automatic updates.

All the TeamViewer client you are managing won't update automatically and stay in version 12.

I hope this could help. If not, do not hesitate to ask your questions here.

Cheers,

Jean


 

2 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Incompatible Versions

Hi @giojohn

Thank you for posting.

Can you kindly make sure that both sides of remote connection are using the same version of TeamViewer 12 please. If the remote side can not reinstall TeamViewer 12 by any reasons, customised QuickSupport can be one of the options for connection solution. 

For more information about TeamViewer QuickSupport, feel free to check out the following KB articles:

  1. The QuickSupport module

  2. QuickSupport and SOS button

  3. Are the QuickSupport (QS) and QuickJoin (QJ) modules secure? 
  4. How to download and start the QuickSupport module with different Browsers

 

Alternatively, feel free to contact TeamViewer Sales Team if you are interested in the latest features and software version of TeamViewer

Hope the information above would be helpful.

Regards

Ying_Q

Highlighted
Posted by
Digon

Re: Incompatible Versions

I downloaded the version from the internet, put it on a USB stick and installed the same Version on all systems to include the laptop that will be used to remote into the other computers. Got any other ideas up your mouse sleeve


@Ying_Q wrote:

Hi @giojohn

Thank you for posting.

Can you kindly make sure that both sides of remote connection are using the same version of TeamViewer 12 please. If the remote side can not reinstall TeamViewer 12 by any reasons, customised QuickSupport can be one of the options for connection solution. 

For more information about TeamViewer QuickSupport, feel free to check out the following KB articles:

  1. The QuickSupport module

  2. QuickSupport and SOS button

  3. Are the QuickSupport (QS) and QuickJoin (QJ) modules secure? 
  4. How to download and start the QuickSupport module with different Browsers

 

Alternatively, feel free to contact TeamViewer Sales Team if you are interested in the latest features and software version of TeamViewer

Hope the information above would be helpful.

Regards

Ying_Q