Announcements

Learn how to activate your Remote Access plan here!

Highlighted
Posted by
Henagon

Remote Access License Support

Hi, I have an existing Remote Access License paid for since March. I am trying to access support for this license; over the phone it tells me to submit a ticket, but when I click on the support link to submit a ticket, it takes me to the community group.

I have looked at my account, and it lists my license type as 'Free', however I have activated my license, and if I try and reactivate it, a message comes up saying it has already been activated. So this doesn't make sense.

The reason this has come up is that I have been trying to upgrade my subscription, but for the last 2 hours I just have a message on my account saying "Thanks for your purchase.
Your contract will be updated with the next few minutes". I also tried calling sales, but after another hour on hold I gave up.

Any help would be appreciated; right now everything about TeamViewer seems very poor - the product, the support, and every associated function - so my conclusion is to cancel my TeamViewer subscription and use an alternative! 

3 Replies
Highlighted
Posted by Community Manager
Community Manager

Re: Remote Access License Support

Hi @AccessInd 

Can you send me a private message with the email-address you are using that gets the message that it is free, but at the same time that the license has been activated already. Thanks!

Esther

Community Manager

Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started

Highlighted
Posted by
Henagon

Re: Remote Access License Support

Hi

I have the same problem but have also been charged twice. The site support is abysmal.

Highlighted
Posted by
Henagon

Re: Remote Access License Support

Hi there,

I'm having the exact same issue, I have a license and says its been activated in my account but in my Teamviewer it still shows as free license (non-commercial use). When I go to licenses in my management console, I cant see the license. I try to activate it using the license code I have in my invoice and it says its invalid..

Please help!