link icon
Ask The Community

Delays in typing in Cyrillic

Hi all!

I have Ubuntu 20.04 installed as a virtual machine on Synology DS718+. I run the latest TeamViewer (15.9.4) on Ubuntu and connect to it from Windows / iOS / Android.

If I type Cyrillic letters (while being connected to Ubuntu via TeamViewer) then I have huge lags between the moment when I press a key on a keyboard until the typed key is shown in the Ubuntu's interface. In case I type one letter in Cyrillic I have a lag which is approx. 1 second, but in case I type several letter then the lag is very long (more than 5 seconds, depending on how much text I type). Therefore, it is practically impossible to type text in Cyrillic. There are no issues when I type Latin letters (while being connect to Ubuntu via TeamViewer).

I've tried to connect to Ubuntu through other protocols (VNC and RDP) - there are no such lags. Moreover there are no lags if I connect to Ubuntu via Synology's web browser interface. Therefore, my suggestion is that there is something wrong with TeamViewer, but I don't know whether this is just a bug or there is an important reason why there should be such lags.

Does anyone know why these lags are happening and how to get rid of them?

Best regards,
Nikolay Kiselev

Sign In or Register to comment.