teamviewer.com link icon
or
Ask The Community

How can I use TeamViewer in a WinPE?

Hi Support / @all,
I have build an emergency Windows 10.0.14393(1607)-64 with WinBuilder from TheOven.org. Project-Page: http://heise.de/-3467556
That EmyWin is a 'Windows Preinstallation Environment' WinPE, pimped with usefully tools.

Now I wont to include the TeamViewer, but it wouldn't run :-(
First I try the portable version, what is good for many tools in WinPE, it fails.
At last I try the setup EXE with the 'noinstallation' option from GUI and it fails too with the following LOG (extract row 092...104):

...
2016/12/26 01:01:26.500 1312 524 G1! GUI running in system account, trying to restart it.
2016/12/26 01:01:26.500 1312 524 G1!! CToken::WTSQueryUserToken(): Querying token failed with error code 1008, Errorcode=1008
2016/12/26 01:01:26.500 1312 524 G1+ WindowsSessionEnumerator::EnumerateLocalSessions(): Discovered 2 sessions
2016/12/26 01:01:26.500 1312 524 G1 CToken::LogAllLocalSessions(): Session id 0, name Services, state Disconnected
2016/12/26 01:01:26.500 1312 524 G1 CToken::LogAllLocalSessions(): Session id 1, name Console, state ConnectQuery
2016/12/26 01:01:26.500 1312 524 G1! CToken::GetUserToken(): Exception caught when querying user token for session 1 (WTSQueryUserToken() failed!, Errorcode=0)
2016/12/26 01:01:26.500 1312 524 G1 CToken::GetUserToken(): Attempting to fallback and obtain user token from session process
2016/12/26 01:01:26.516 1312 524 G1+ ProcessWin::CreateProcessInternal: CreateProcess B:\Temp\TeamViewer\TeamViewer.exe WithToken
2016/12/26 01:01:26.516 1312 524 G1+ ProcessWin::CreateProcessInternal: Create environment block for 'Window Manager\DWM-1'
2016/12/26 01:01:26.516 1312 524 G1! ProcessWin::DumpCreateProcessFailed: CreateProcess WithToken failed using CreateProcessWithToken, ApplicationName: 'B:\Temp\TeamViewer\TeamViewer.exe', CommandLine: '"B:\Temp\TeamViewer\TeamViewer.exe" --noInstallation', Env: 'Window Manager\DWM-1', StartupInfo: 'WinSta0\default', LastError: '1060'
2016/12/26 01:01:26.516 1312 524 G1!! Failed to restart GUI: exception: ProcessWin::CreateProcessInternal(): CreateProcessWithToken failed!, Errorcode=122, Errorcode=122
2016/12/26 01:01:26.516 1312 524 G1!! GUI started in System account and can't be restarted under a different user., Errorcode=122
2016/12/26 01:01:26.516 1312 524 G1 Chat::Stop: Stopping chat
...

Q: Is there a way to run TeamViewer >=12.0.72365 in WinPE with 'system account' only?

Btw. **Third Party Product**-2.6.0 works

THX & Happy New Year

Comments

  • elbea64
    elbea64 Posts: 70 ✭✭
    I do not use WinPE, therefore i can't tell you if or how it would work, but your LOG gives some hints.
    It looks like WinPE is running under the local system account with no user account. This produces the error 1008 on line two. TeamViewer tries to switch from system account to a user account but there is none.
    I don't know why TeamViewer refuses to run under system account, but the solution would be to create a user account in WinPE, which i don't know if it is possible or to force TeamViewer to run under system account, where i also don't know if it is possible at least without TeamViewer devs.
    »We are all born unique, but most of us will die as a copy.«
  • Hi elbea64,
    thanks for reply.
    Yes, it's a fact, in WinPE exist only a SystemAccount 'Default' that run's with highest privileges. It is not planned to create a different account at runtime or before at build.

    Is it possible to forward the question to technical support?
    At time I do not know how?

    thx

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!