Why Can't I Control my Android Device?

This discussion has a more recent version.
Scotty Posts: 493 Staff member 🤠

android.jpgWhy can't I control my Android device?  Can't TeamViewer make it possible?

Note: Posts asking about compatibility with android devices will be moved into this post

TeamViewer is capable of both viewing the screen and remotely controlling a range of Android devices. However, we, unfortunately, are not able to support all manufacturers or ROM's for these features, especially remote control.

Screen Sharing

  • Screen sharing is available for all Android devices running Android 5.0 or higher.

Remote Control

Cannot download Add on from the play store / AOSP

  • There are a small number of devices that are on our supported manufacturers list that are supported but are unable to download the add-on from the Playstore. This also occurs to some AOSP devices that may also be supported but you need to download from the website.

-Website Downloads-
Android Host Download

Android QuickSupport Download


  • We do support some AOSP devices. If you are running on AOSP it is best to download the app from our download page instead of the play store. If you installed from our website but cannot control your device, it is not one of these AOSP devices and it cannot be modified to allow access.

Custom ROMs

  • TeamViewer does not officially support custom ROMs. 

But why not just make it possible?
To allow full remote control of a device, we need cooperation from the manufacturers themselves which we do not have for all manufacturers.

As this does require the manufacturers support, we cannot simply commit to making this possible as we cannot do it alone. You can support us by reaching out to the manufacturer of your mobile device and let them know you want them to be compatible with TeamViewer.

What can I do to control my unsupported device?
If your device is unsupported, we are currently not able to provide you with this feature. 

However, you still have access to file transfer and other great features. Also - we would like to encourage you to support us by reaching out to the manufacturer of your mobile device and let them know you want them to be compatible with TeamViewer.

I am a manufacturer, how can I get my device supported?
If you are a manufacturer and would like to work with us to support your devices, please contact us via this form.


Senior Moderator
Did my reply answer your question? Why not accept it as a solution to help others?

Best Answer



  • nicola
    nicola Posts: 3 ✭✭

    Smartphone: LGE Nexus 4
    Android: 5.1.1

    After having estabilished the connection to the device, the screen is correctly displayed, but clicking is not working. Anything I can try?

  • bartlanz
    bartlanz Posts: 315 ✭✭✭
    1. Double check you have the correct version of TeamViewer Host installed
    2. Restart the phone
    3. Startup Host on the phone
    4. Restart your computer

    Also you may want to try the Quick Support version instead? See if that works. If that works and the host does not. I'd suggest contacting TV support directly to see if they know about an issue.

    If my post was helpful, Please throw me a Kudos.
    If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
    Bart Lanzillotti
  • RLThomaz
    RLThomaz Posts: 1

    Hello everybody,

    I'm under a proxy in my university and I can't connect TeamViewer RC or Host, even though my proxy settings are fine. Every other application still works.

    Is there anything I could do to solve this?

    Best regards,


    Edit 1: I'm also under proxy on Windows 10, however TeamViewer works fine.

  • Hello guys,

    I'm running Windows 10 Pro on my desktop computer. I downloaded TeamView QuickSupport as shown in the following video: https://www.youtube.com/watch?v=xFN1rI70IWg

    In the video it is straightforward. Once you have access you can move around the phone. However, i an only view my phone. I can't do anything. Now my phone knows my mouse is there and the same BLUE HAND that shows up on my computer shows up on my phone.

    I can also transfer files to my phone. But again, i can do anything with the phone itself the way i normally would using my mouse. I can't open anything, i can't swipe or move an icon. Nothing.

    My phone is a Moto G4 Plus and I'm running Android 6.0.1

    I would appreciate you help and suggestions.



  • Scotty
    Scotty Posts: 493 Staff member 🤠

    Hi JacobPressures,

    Thanks for your post!

    Unfortunately, we do not have full control for all android devices and Motorola is one of the manufacturers we are currently unable to support.

    The list of fully supported manufacturer can be found here: https://www.teamviewer.com/en/help/341-how-can-i-control-my-android-device-with-teamviewer

    I am sorry for the any hassle.


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • tvman8000
    tvman8000 Posts: 6 ✭✭

    android 4.4.4    kernal ver 3.10.0    vender software version HX 3128 android 4.4.4     get message   this device supports the additional remote control features OS firmware AOSP5

  • Aaron_Boshers
    Aaron_Boshers Posts: 47 Staff member 🤠

    Dear RLTomaz,

    Thank you for your post.

    There shouldn't be an issue with what you are describing.

    Could you please try to disable UDP on both devices since they both are behind the proxy.

    On remote control app | Gearwheel | Advanced | Enable UDP

    On the Host | Three dots in the top right corner of the white card | advanced | Enable UDP 

    This should force the app to go over TCP and be able to function with the Proxy correctly.

    Best Regards,

    Aaron Boshers
    Senior Enterprise Solutions Engineer

    If my reply answered your question, help out other users and click the Accept as a Solution button below.
    You can also say thanks by clicking on the Thumbs Up button! Thanks for being an active member of our Community!
  • Katharina
    Katharina Posts: 135 [Former Staff]

    Hi tvman8000, 

    Thank you for your post. 

    I was wondering whether you could maybe post a slightly more detailed description of the problem you are encountering? I am sure this would help our other users to better understand the problem and allow them to make helpful contributions.

    Thank you in advance!

    All the best, 


  • primusii2000
    primusii2000 Posts: 3 ✭✭

    Hi guys! I'm just having the same problem with my cousin's android box. The older box he had was piece of cake for connectong remotely thru QS. But with the new one, I keep receiving this message but won't download addon. Any help would be appreciated...

  • primusii2000
    primusii2000 Posts: 3 ✭✭

    I found a solution for your problem friend. Man, it took me days but finally did it! Ok, if you already have your quicksupport app downloaded, keep it. Now, go to Play Store and download Team Viewer Host. When you open it, it will ask you to install the addon. When you finally get it downloaded and installed, go to QS again and open it. You will see that the message will not be shown again, and now you can connect remotely to your android box. Wallaaaaa!! Yessss!!!

  • Joni
    Joni Posts: 2 ✭✭

    I've got the same problem using Motorola Moto G 2nd edition running Android 6.0.

    When I click on my PC (Windows 10) a finger appears on both devices for a moment, but nothing happens anymore.

    Is there something I do wrong or how this problem can be solved?

  • evo676
    evo676 Posts: 1

    I have the exact same problem on my Acer tablet, the blue hand appers momentarily but clicking the mouse does nothing

  • gman
    gman Posts: 1

    running the latest verison of TeamViewer, mouse click is still not working on Android after all troubleshooting steps have been followed.

  • Same exact issue, this issue is actually related with an android device not supporting remote control as it is not on the list of supported android devices. The device we have is an octa core dragon touch 10.6" tablet running android 5.1, model number X10REF

    we purchased the tablet here

    [Link removed]


    it would be really bad if it is not possible to remote control this device as unanttended access as this was the main reason we purchased teamviewer.

    please help, thanks!

  • sorCrer
    sorCrer Posts: 1

    I've been controlling a remote Huawei Android device with QuickSupport for the past few days. Today the device updated and now I get 'This device supports screen sharing only'. Any one have a smiliar issue?

  • Hanan96
    Hanan96 Posts: 1

    I had sucesfully login with team viewer account on my computer, and then connect to my android devices. I'm using xiaomi redmi note 3 .

    howewer, I can only seen the screen of my android phone, I cant click nor drag anything there from my computer

    how can I made mouse interaction works?

  • tsyganov
    tsyganov Posts: 1

    I have installed Host app on my Xiaomi Mi5 and when i connect to my phone using TeamViewer on my PC it tells me that my android device supports only screen sharing. How can i enable full control of my device?

  • Same here: proxy is configured on my Android phone... When I need to use TeamViewer, I have to use my mobile internet connection.

    My laptop, on the same network (same proxy) works fine tho.

    I tried disabling UDP... No success :(

  • RK1
    RK1 Posts: 1

    i too facing same problem with mi3 on miui8

    please advise the solution. in the other phonesof miui7 it worked.

  • blkatbyhh
    blkatbyhh Posts: 1
    Moto G 2014 LTE (Thea), running LineageOS Nightly build, After latest updates, teamviewer host became screen sharing only and cannot be controlled remotely.
  • I have a huawei P10 and P9 with the same issue, can connect however only screenshare.

  • nisiwi
    nisiwi Posts: 2 ✭✭

    Same problems on Huaweu P9 and P9+

  • Ugo
    Ugo Posts: 1

    Same problem with XIAOMI note 4. Is there anyone who has found how to solve this?

    @RK1 wrote:

    i too facing same problem with mi3 on miui8

    please advise the solution. in the other phonesof miui7 it worked.


  • Scotty
    Scotty Posts: 493 Staff member 🤠

    Hi Worldofankit

    Unfortunately Xaomi devices are not supported for screen sharing. We need the manufacturers co-operation for this which we do not have with Xaomi.

    Please check our Android FAQ here


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • akiem
    akiem Posts: 1

    I also have this issue with my lenovo yoga.

    as i see in this post people have this problem one year long.

    Does anybody know if this problem can be fixed, or where i can find suport from teamviewer team?.


  • rhcrd0
    rhcrd0 Posts: 3

    which is the solution? i have moto g4 play and i cant control my own device what can i do?

  • same issue on Sony XZ Premium too.

  • nisiwi
    nisiwi Posts: 2 ✭✭

    Recent update to TeamViewer Host causes a new component to be installed on the mobile when connecting remotely and finally allows remote control of Huawei devices!!