teamviewer.com link icon
or
Ask The Community

Teamviewer 14 issue on Raspberry Pi 4 - raspbian buster

When attempting to install Teamviewer host on a raspberry pi 4 using raspbian - buster, the following error is generated after sudo teamviewer setup is completed

The framebuffer console seems to be unavailable or has the wrong format. For
connections to framebuffer consoles to work please make sure that /dev/fb0 is
accessible and configured to at least 16-bit depth.

On my raspberry pi 2, installing Teamviewer on the same raspbian buster image works fine.

Any ideas?

Comments

  • JoLander
    JoLander Posts: 1

    I faced the same issue, but was able to overcome the problem by setting the option:
    enable_tvout=1 in the rpi4 config file (/boot/config.txt).

    After a reboot, the device /dev/fb0 was available and I can access my rpi4 by teamviewer.

    The only problem left is the screen resolution in the teamviewer window.
    It's stuck at 720x480 and by now I was unable to influence this resolution.
    There are some settings in the config.txt file, but none of them had any influence.
    It's ok if you working in text mode only, but when you start with GUI, its a funny small window.

    Joe 

  • Thank you @JoLander !  This got me working!

    For anyone else reading this:

    1. Edit the /boot/config.txt file
      • Append enable_tvout=1 in the [rpi4] section
    2. Reboot the pi
    3. (if exists) delete existing TeamViewer device
    4. Setup TeamViewer
      • Run the command sudo teamviewer setup and follow the instructions to (re-)link the device to your account
    5. Setup pi to boot to Desktop - autologin
      • Run sudo raspi-config
      • Select Boot options -> Desktop/CLI
      • Select Desktop - autologin
      • Hit ok and finish
    6. Reboot the pi

    It should now work - I had to wait like 2-3 minutes for everything to start

    Thnank you again for this suggestion!  Now if only the window could be re-sized larger, as you mentioned.


  • @JoLander wrote:

    the only problem left is the screen resolution in the teamviewer window.
    It's stuck at 720x480 and by now I was unable to influence this resolution.
    There are some settings in the config.txt file, but none of them had any influence.
    It's ok if you working in text mode only, but when you start with GUI, its a funny small window.

    Joe 


    I solved this problem by following the guide from this URL: https://askubuntu.com/questions/453109/add-fake-display-when-no-monitor-is-plugged-in. The only issue is, that now  I've automatically two simultaneous Teamviewer connections to my host (one session to the host and another one to the user) when I connect to my PI. But this seems only to be an optical problem.

    Basically install a dummy driver:

    sudo apt-get install xserver-xorg-video-dummy


    Then write it in the /usr/share/X11/xorg.conf.d/xorg.conf file (create one, if it does not exist):

    Section "Device"
    Identifier "Configured Video Device"
    Driver "dummy"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    HorizSync 31.5-48.5
    VertRefresh 50-70
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x800"
    EndSubSection
    EndSection


    Then restart the computer.

    Freddy

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!