TV 15 Host Assignment with no user logged in

I deploy TV 15 Host with the PDQ-Deployment-Tool in our company. We are using the Microfocus-Client to login to our workstations. When no user is logged in i cant assign the host if im logged in its no problem. We deploy TV15 with the TeamViewer_Host_Setup.exe and after that we assign it with the TeamViewer.exe in C:\Program Files (x86)\Teamviewer\

Here the command line im using:

TeamViewer.exe assign --api-token xxxxxxxxxxx [--group-id xxxxxxxxx --grant-easy-access --reassign --alias %COMPUTERNAME% --proxy internet:8080]

I searched and tried a lot but i need your help because i cant find a solution. Its important for us because we often need to install a lot of workstations and we dont have the time to login into every workstation.


  • JeanK
    JeanK Posts: 6,893 Community Manager 🌍

    Hello @Mordor2003

    Thank you for your message.

    Firstly, we recommend using the .msi package to rollout TeamViewer on your machines.

    Here, you will find the download to it: Download MSI package

    Here, you will find all the instructions on how to proceed: Mass deployment improvements

    If you have already deployed TeamViewer and just need to assign the devices to your account, please use the following command line:


    C:\Program Files (x86)\TeamViewer\TeamViewer.exe" assign --api-token=YOURAPITOKEN --proxy internet:8080

    timeout /t 5

    net stop teamviewer

    net start teamviewer

    I hope this could help. If not, do not hesitate to ask your questions here.




    Community Manager

  • Sorry for my late response. The same problem appears. Ive tried it with a logged in user and everything works fine. When im not logged in the installation works but the assignment dont work. We are in a Novell (Microfocus) environment so we are using the novell client to login to our workstations. Ive also tried to install it (logged out) without the novell client and the assignment works. So its definitely a problem to assign when you are logged out and a novell client is installed.

    Now the command line parameters are:

    msiexec.exe /i "TeamViewer_Host.msi" /qn APITOKEN=xxxxxxx-xxxxxxxxxxxxxx ASSIGNMENTOPTIONS="--group-id g0000000 --grant-easy-access --reassign --alias %COMPUTERNAME% --proxy internet:8080"

    Ive tried it with three different credentials "Local System" our domainadmin and a local user.

    I need help.

  • @JeanKany clue?

  • JeanK
    JeanK Posts: 6,893 Community Manager 🌍

    Hello @Mordor2003,

    Thank you for your message. ?

    With these parameters it should work. ?

    Please submit a ticket to get one of our engineers investigate further regarding your issue.
    You will find all the information you need in our Knowledge Base article here: How to submit a ticket 

    I thank you in advance for your understanding, but I cannot help you further here. ?



    Community Manager

  • BCP_Council
    BCP_Council Posts: 1
    edited December 2020

    Hi there I am having exactly the same problem as @Mordor2003 - Did it ever get resolved.I have logged a ticket. we are using the Host msi and want to assign laptops to our master list at the time of deployment of the msi.