teamviewer.com link icon
or
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉


Check out our brand-new Portuguese Community 👉 here 👈.

Upgraded to Corporate Subscription - now TV says our trial has expired???

 

 

We recently upgraded from TV 10 to TV 15 Corporate.

We have uninstalled the old versions of TV10, and installed the new TV15.  When attempting to connect to remote comptuers - we are given the following message:

"The trial license of your connection partner has expired. As your connection partner uses TeamViewer commercially, either one of you(one of the connection partners) needs a valid TeamViewer license."

We have done a complete install of TV15, activated the license under "extras", and all our user are listed in the 'user management' section in the main panel, and all user have authenticated.  

Can anyone please shine some light on this issue?

Thanks for any help.

Comments

  • JeanK
    JeanK Posts: 4,832 Senior Moderator

    Hello @Falken79,

    Thank you for your message and welcome to the TeamViewer Community! ?

    The activation process has changed from v10 to v15. It is not possible to activate a license in version 15 through Extras --> Activate license.

    Please follow the instructions here:

    Once you have activated your license, I highly recommend you to check this article as well:

    This will show you the best practices on how to manage your Corporate license and to get the maximum out of it.

    I hope this could help. ?

    If not, do not hesitate to ask your questions here. ?

    Best regards

    Jean

    French Community moderator

    ---

    Did my response answer your question? Help out others and select it as the Accepted Answer

  • roberto_sf_v10
    roberto_sf_v10 Posts: 5 ✭✭

    Same problem here as Falken79 but have a business license for version. Follow the instructions by going to (https://) login.teamviewer.com

    The web management console on the top right under my name it reads "Business." Then it goes to the process of opening the full windows install program. But the installed app read "Free." So the activated legacy 10 business lic on the web is not being sent or synced with the locally installed program. And cannot find how to fix this.

    How do i fix this problem these two problems?

  • Ying_Q
    Ying_Q Posts: 1,264 Moderator

    Hi @roberto_sf_v10,

    Thank you for reaching out to us.

    As your TeamViewer account is successfully activated with the license, Kindly sign in the licensed account again on TeamViewer client please. And please ensure to sign in the licensed account all the time before initiate any remote control connections.

    To check whether it is fully licensed, kindly go to TeamViewer -> Help -> about TeamViewer -> License, it should display with your license accordingly.

    Hope it would be helpful!

    Best regards,


    Community Moderator/中文社区管理员

  • roberto_sf_v10
    roberto_sf_v10 Posts: 5 ✭✭

    It doesn't. It says Free license. I tried logging off and on, unistalling and reinstalling but it continues to say Free license.