[Update: 13.1.8286] June Update - more & better

DanielStm Posts: 224 Staff member 🤠


Dear friends of the Tux,

we have a plethora of additions and improvements in this release, so the best summary I could come up with is: more and better.
This brings us a big step closer to having a feature-complete native (non-Wine) version of TeamViewer.

Computers & Contacts
Many have longed to see the day to actually be able to add computers, contacts and groups to the list. That day has come.
Removing contacts is also possible and in the properties dialog you can change the name and group of an item.
Shared Groups are now shown properly.

Remote Control
You will notice the toolbar has gained quite a bit of size:
In the View tab you can change scaling, quality and remote screen resolution.
You can also pop out multiple remote screens in separate windows and fullscreen each one.
If supported by the target, screen, input and wallpaper can be disabled.
The Communicate tab allows switching sides and opening the in-session chat.
In the Files & Extras tab, you'll now find Session Recording.
Also notice the tiny toolbar: If you slide out the main toolbar, you can still go fullscreen, switch screens (if multiple), chat (if active), control recording (if active) and drag the tiny toolbar out of the way.

Tiny toolbar with chat open and recording activeTiny toolbar with chat open and recording activeSession Chat
Note that the other side is not implemented yet, so you can not use the in-session chat when connecting to a native Linux client yet. Chatting to Windows, or to Linux QuickSupport or TeamViewer 12 for Linux works fine and should cover most usage scenarios.

Session Recording
Of course, when recording sessions, a player is also needed. You can find it in the Extras menu of the main TeamViewer dialog. Actually, the player has already existed, but now it also has a toolbar.
TeamViewer also supports automated recording, but the settings are not yet available in the options dialog. To activate it, close TeamViewer (e.g. via the status icon) and add the following lines to /home/$USER/.config/teamviewer/client.conf to automatically start and save recordings:

[int32] AutorecordRemoteControl = 1
[strng] SessionRecorderDirectory = "/home/user/myRecordings"

Of course, don't forget to mkdir /home/$USER/myRecordings ... :robotwink:
However, if the file cannot be written for some reason, you'll find it in /tmp.

Connecting to a Windows machine using a domain userConnecting to a Windows machine using a domain userWhat's More
Passwords are temporarily remembered when connecting twice to the same device and connecting via Windows credentials is now supported: When connecting to a Windows machine, click on Advanced to authenticate as a Windows user (e.g. Administrator). Note that this has to be enabled on the Windows machine in TeamViewer options, security.

The middle mouse button is now transferred.
We've also removed a few bugs, most notably the UI that was broken on some 32 bit distros.

As always, packages are available via repositories and on the TeamViewer Linux download page.

All the best,


Further Reading

Linux Knowledge Base

Linux Developer


  • externa1
    externa1 Posts: 2 ✭✭
    Thats great (especial the contacts modification option i was hardly missing )
    but i still have display problem with the main gui on hiDPI display

    Can this be addressed in future version ?

  • Warleek
    Warleek Posts: 1


    does that update include verification for commercial uses? I'm using the free version to connect from work to my personnal computer, to do admin on my personnal project (non commercial) and since today I can't do that anymore, TeamViewer is telling me that it is a commercial use.

    Is that normal?

    For the rest the managment of computers is easier now Thanks.

  • mozo
    mozo Posts: 28 ✭✭

    This is great Update and we finally have the middle button! But the hotkeys spamming is still here :( Are there plans to fix this very annoyng bug?

  • thg
    thg Posts: 1

    After the latest update the GUI isn't launching anymore.... 


    teamviewer 1 ↵

    CheckCPU: SSE2 support: yes
    Checking setup...
    Launching TeamViewer ...
    Starting network process (no daemon)
    Network process already started (or error)
    Launching TeamViewer GUI ...
    [1] 20875 abort (core dumped) teamviewer
    ╭─thg@thg-think2 /opt/teamviewer/tv_bin
    ╰─➤ teamviewer -info 1 ↵

    TeamViewer 13.1.8286 (DEB)

    TeamViewer ID: XXXX20379

    teamviewerd status n/a (error)


  • montjoshua
    montjoshua Posts: 3 ✭✭
    Connecting via Windows credentials ?????
  • haonc
    haonc Posts: 1

    Dear All, 

    I still cannot use Ctrl key when i connect to Windows Desktop from my Ubuntu.

    Hope you solve this issue soon!

    Thanks & Best Regards,


  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @externa1: HiDPI: Please open a new topic and add some details, e.g. distro and a screenshot. Thanks!

    @thg: GUI not launching: If a reboot ain't fix it, please open a new topic.

    @Warleek: Commercial use is detected by our infrastructure, not the client. So it's also not a Linux specific topic. I think it should be discussed in the general forums.

    @mozo, @haonc: Ctrl key problems: I just commented on it here: Ctrl + <key> problem

    @montjoshua: Windows credentials, are we kidding you? :robotvery-happy:
    No! I updated the text to explain it and also added some nice pictures for you :robothappy:


    Linux Developer
  • mozo
    mozo Posts: 28 ✭✭

    Thank you Daniel :)

  • jesusvpct
    jesusvpct Posts: 3
    Thanks for this great update! I have a trouble until now on all 13 versions. It does not allow me to write letters with accents on remote control, for example, letters á, é, í, ó, ú. I hope that this will be solved soon. Thanks!
  • montjoshua
    montjoshua Posts: 3 ✭✭
    Sorry "Advanced", completely overlooked :-(
  • izll
    izll Posts: 3

    Thanks, but with Ubuntu 18.04 LTS x64 still high cpu usage from now with TV square maximized and minimized (logo is not pulsing). Any idea why it can be?

  • izll
    izll Posts: 3
    Hmm, something happened, and the CPU usage reduced... Sorry.
  • After updating the version of my TeamViewer to 13.1.8286, I can no longer access any computer, because the application crash:

    $ teamviewer
    Init ...
    CheckCPU: SSE2 support: yes
    Checking setup ...
    Launching TeamViewer ...
    Launching TeamViewer GUI ...
    Targeting failure (recorded core image)

    I use Ubuntu 64bits in version 16.04.4

  • johnnyB
    johnnyB Posts: 5 ✭✭

    Nothing is working for me on ubuntu 16.04. Cannot link computer to account because button is disabled, cannot connect to computer and contacts because button is disabled. Cannot set up password because when I click the contextual menu nothing happens

  • kiwi
    kiwi Posts: 1

    This is great progress and I appreciate the native Linux effort. However for the last 6 months I haven't been able to connect to any Android device. Judging by the community threads I am certainly not alone in this and they all seem to have gone unanswered. Come on guys, at least please give us an answer as to what is happening . . . . . . 

  • _Andreas_
    _Andreas_ Posts: 19 Staff member 🤠

    @kiwi wrote:

    This is great progress and I appreciate the native Linux effort. However for the last 6 months I haven't been able to connect to any Android device. Judging by the community threads I am certainly not alone in this and they all seem to have gone unanswered. Come on guys, at least please give us an answer as to what is happening . . . . . . 

    Sorry for that. The reason for not being able to connect to Android devices is that this functionality is not in there, yet. Nevertheless, it is one of our top items in our todo list, so I hope the ability to remote into Android devices will come back soon.

  • stefanbc
    stefanbc Posts: 2

    Hi Daniel,

    it took me some inverstigating and talking to your hotline to figure out that the presentation mode is entirely missing in the recent version. In the recent post you state that another feature is missing.

    I am badly missing a list of major feature that are not present in the release for quick reference. I think any linux user would appreciate a "ToBeDone" kind of list for every release. So even if this release is labled "preview", it is annoying for a commecialy distributed product, that the customer needs to figure out by himself, if the feature, he needs is already implemented. Also being left without an alternative is unstisfactory. Why don't you distribute a wine based client as long as the native client is feature incomplete? This would have saved me a lot of working time.

    Please don't get me wrong and I am very happy that TeamViwer is supporting Linux that well (and constantly!). But here customer communication is lacking quality, esp. for a commercial product!

    Best wishes


  • cxx31
    cxx31 Posts: 2

    My thoughts exactly; it's absolutely fantastic to see the effort going into building a native Linux version from scratch!

    However, a simple table that shows gaps between TV13 Linux's client and other platforms' such as Windows, along with some rough timeline for implementation would be very useful for everyone involved....

    My key missing feature: meetings (one to many). Don't see any mention of this anywhere?  Has it been abandonned?  Please, no!  On Linux, TV _was_ one of the only pieces of software that implemented this; whereas there are a gazzilion of chatting/IM apps, yet that latter feature seems to have prioritized in TV13/Linux...


  • gsus
    gsus Posts: 1
  • olig
    olig Posts: 1
    On the download page it's still v13.1.3026
  • Hello,

    Thank you for the great update. However, the option Disable TeamViewer Shutdown in the Advanced option doesn`t work. I can still exit TeamViewer having that option ticked. Could you please check again?

    Thank you very much!

    Best regards,

  • The Start with Windows doesn't work either.

  • Willi
    Willi Posts: 1

    I am still waiting for the meeting functionality. The Linux version is a preview since 6 month, I can't believe that. In this case it is better to say: "Currently we don't support Linux".

    There is no transparente communiction about the missing features, and no roadmap.

    How long do we have to wait for the meeting functionality on Linux,?
    One year or more?

  • _Andreas_
    _Andreas_ Posts: 19 Staff member 🤠

    Hi Willi!

    Meeting unfortunately was one of the least requested features. That does not necessarily mean that it will never be included, but it may take a while until it is done and running smoothly. If you only want to join a meeting, you can do so using the old TV12 Client (you can install the portable tar.gz alongside your normal TeamViewer installation). We meanwhile recommend to use blizz (https://www.blizz.com) for meetings, on Linux you can join a blizz meeting using the Web Connector (although admittedly that also does not allow you to present your screen). We are aware that TeamViewer Meeting is currently one of the few viable meeting solutions on Linux, so we hope we will pick it up sooner or later and bring it back.

    Best regards,


  • wschlich
    wschlich Posts: 7 ✭✭
    Yeah, the English download page https://www.teamviewer.com/en/download/linux/ shows 3026, where the German download page https://www.teamviewer.com/de/download/linux/ shows 8286 :-)
  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @olig, @wschlich: Well, never trust what you read on the Internet, they say. It deceives you. Especially English pages. It tells you 3026 and before you know it, you end up downloading 8286.


    Linux Developer
  • Allnet911
    Allnet911 Posts: 4
    First of all, thanks much, Daniel, for your tireless efforts on behalf of the Linux community, and the steady progess of the Linux development team in providing a Linux version that matches the Windows version in terms of features and look and feel. In the past, some of the things that impressed me so much about TeamViewer were the identical look and feel and features set of TeamViewer across different platforms, I assume largely due to using Wine in the case of the Linux version.

    So I did a fair amount of whining when so much of that went away with TeamViewer 13. At the time, I didn't give a lot of thought to the increasing challenges of staying with a Wine implementation, and the additional challenges incurred by deciding to go with a full-native Qt-based version, and the further upcoming challenges posed by Wayland.

    Challenges, challenges, challenges.

    There was a time when I was concerned that TeamViewer was heading in the direction of bailing from Linux due to the far smaller customer base, but in thinking it through, I suspect that the Linux community is actually a pretty signifcant customer base for TeamViewer. This would be because many Windows users probably just use the Remote Desktop Support app built-in to Windows. And given the fact that Linux is the OS of choice for so many of the major server farms (e.g., Google, Yahoo, AOL, etc. ... I think), I assume that TeamViewer has a good customer base for at least some of those organizations. So I worry no longer.

    So now, I'd just like to point out a couple of issues I'm having with 13.1.8286, in the hopes that this will be useful information for the development team. The biggest problem I have at the moment is that TeamViewer crashes occasionally, which is a little embarrassing when it happens in the middle of supporting a customer. But that's ok, I just blame it on you guys. ;)

    My remote support box, where I run 13.1.8286, is a basic Dell Optiplex Core 2 Duo machine with 8 GB RAM running Linux Mint 19 Xfce. I know, such ancient, but IT support folks are always the last to upgrade to current hardware, eh?

    A non-problem, but perhaps worth noting, is that the fonts in the Computers & Contacts window are larger than before and look "weird" at that size, "weird" being professional nomenclaures, of course. Dunno if it's a TeamViewer thing, or a Linux Mint 19 thing, and haven't yet had the time to dig into it further.

    Finally, since I missed the last survey, the one feature I would love to have next would be the Remote Note feature, because that's so much more boss than leaving a Windows Sticky Note. :)

    Thanks again for all your help. If there's anything I can do to provide more troubleshooting information for 13.1.8286 in my environment, just ask.

    Jim Hopkins, Allnet911
  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @jesusvpct: Dead keys / accents: I added this to our bug tracker. Thanks!

    @izll: No, sorry. Please describe in detail in a new thread and tag me.

    @CarlosValente: Sorry for the late reply. Your options are to downgrade (apt install teamviewer=13.1.3026), and/or wait for the next update. If the next update will not fix it, please open a new topic with detailed description and tag me.

    @johnnyB: This sounds familiar, at least if you have a 32bit distro. I'd suggest the same as for Carlos atm.

    @stefanbc, @cxx31: Andreas already answered to that. I just want to add that it is really important that the demand for missing things is made known to us. Either here or with sales/support.

    @lovelylions: Yeah, you're right. It works properly for the TeamViewer Host, but has not been adapted for the full TeamViewer. I added it to our bug tracker.
    "Start with Windows" can hardly work :robotwink:, but "Start TeamViewer with system" should work very well. If not, please explain the issue in detail in a new topic and tag me.

    @Allnet911: Thanks for the warm words :robotembarrassed:, we appreciate it :robothappy:
    In general, I consider it to be pretty stable. I think most of the crash reports we got stem from the same little bug. It's possibly fixed in the upcoming release, but those "occasional" ones are sometimes tricky to hunt down. But I'm confident my colleague extinguished that one.
    I put stickies on the request list.


    Linux Developer
  • heinke_o
    heinke_o Posts: 1

    Blizz might be a great thing.... but the download page redirects me to: https://lb.tvcdn.de/blizz/ and says: 

    403 Forbidden

  • drh27
    drh27 Posts: 4 ✭✭

    This is great progress - thank you! In testing, it appears that shift+tab to backtab isn't working (at least for me). Is this a known issue yet to be resolved? I've tested in two different programs on the remote host (QuickBooks and Excel).

    Client is Linux Mint 18.1 Cinnamon 64-bit
    Remote host is Windows 10 Pro 64-bit

    I'm using TeamViewer to do remote bookkeeping for clients, so backtab is something I really can't do without.  Looking forward to upgrading in earnest as soon as this last item is resolved.