teamviewer.com link icon
or
Ask The Community

Waitforconnectfailed on a headless RaspberryPi 4B

SandroMiccoli
SandroMiccoli Posts: 1
edited September 2021 in Linux only

Hello all,

I think I read all of the topics in this forum that had the error WaitForConnectFailed on it and I'm out of ideas on what to do now.

My setup is:

Client (Headless Raspberry Pi 4B)
RPi release: Raspbian GNU/Linux 10 (buster)
TV: TeamViewer 15.10.5 (DEB)
Kernel release: 5.4.72-v7l+
Operating System: GNU/Linux
Architecture: armv7l

Viewer
Windows 10
TeamViewer 15.10.5

The installation of TeamViewer on the RPi was successful (I ran teamviewer passwd and teamviewer setup) and I can see the machine on "My Computers" on Window's TeamViewer. However, when I try to connect I get the WaitForConnectFailed error message.

I noticed my framebuffer was 16bits and changed it to 32bits, still the same error.

Tried connecting my computer to another network (my phone's 4G), since others said it could be a router issue, same error.

I changed my /boot/config.txt and it's currently like this:

framebuffer_width=720
framebuffer_height=480
framebuffer_depth=32
framebuffer_ignore_alpha=1
hdmi_force_hotplug=1
hdmi_group=1
hdmi_mode=85
dtparam=audio=on
[pi4]
max_framebuffers=2


fbset returns:

mode "720x480"
geometry 720 480 720 480 32
timings 0 0 0 0 0 0 0
rgba 8/16,8/8,8/0,8/24
endmode


I've tried downgrading to TeamViewer 11 as other topics pointed out, but it didn't work either.

Any directions? Are there any specific settings I need to do for the headless connection to work?

Pretty lost here...

Comments

  • Hello,

    same problem here with a Pi 3.
    Did you find a solution?

    Cheers,
    Rainer

  • Prempena
    Prempena Posts: 1 Newbie

    Hi,

    Did you finally saved the issue ? I've also got a WaitForConnectFailed on my Raspberry Pi 4?

    Thanx,

    Pascal

  • TerjeMjelde
    TerjeMjelde Posts: 1 Newbie

    Same problem here. Raspberry Pi 4, and TeamViewer refuses to let me in when I am running headless. Once I boot the Pi with a monitor connected everything works just fine. I would love to see a solution for this, as this makes TeamViewer quite useless for the particular project I am working on right now.

  • Le_bo2d9
    Le_bo2d9 Posts: 1

    Hi, I found a solution.

    You have to force your hdmi output

    add the line " hdmi_force_hotplug=1" in the file /boot/config.txt


    Kind Regards

    Koen