teamviewer.com link icon
or
Ask The Community

Change Language (Mac to Windows)

I am using a Mac with English and Greek keyboard. In order to change language I use the crtl-space keyboard shortcut. When I am connected to another pc I cannot use this shortcut to change language. Also if I change the remote computer's language using shift-alt combination, my Mac continues to send characters in my mac's selected language. This started happening after a TeamViewer update during November or December.

My OS is macOS Catalina v10.15.7 and I have installed the latest version of TeamViewer

I also tried a clean installation of TeamViewer

Best Answer

  • Esther
    Esther Posts: 4,112 Former Community Manager
    Answer ✓

    Hi @AGeorgopoulos

    Thanks for posting and Welcome to our Community.

    I think there was a small change in the behavior: If you want to change the keyboard on your Mac while being connected to a Windows device, you need to disable the Setting Send system key combinations under Actions first. See:

    If the setting is enabled all your shortcuts will be transferred to the Windows machine.

    If disabled, your local shortcuts stay on the mac (except for Command C/V).

    Hope that helps,

    Esther

    Former Community Manager

Answers

  • Esther
    Esther Posts: 4,112 Former Community Manager
    Answer ✓

    Hi @AGeorgopoulos

    Thanks for posting and Welcome to our Community.

    I think there was a small change in the behavior: If you want to change the keyboard on your Mac while being connected to a Windows device, you need to disable the Setting Send system key combinations under Actions first. See:

    If the setting is enabled all your shortcuts will be transferred to the Windows machine.

    If disabled, your local shortcuts stay on the mac (except for Command C/V).

    Hope that helps,

    Esther

    Former Community Manager

  • AGeorgopoulos
    AGeorgopoulos Posts: 2 Newbie

    The option was not enabled.

    I tried enabling and then disabling and now it seems that it is working fine

    I hope that I will have to change the option in every connection.. 😅

    Thanks for the quick response!

  • Esther
    Esther Posts: 4,112 Former Community Manager

    Thanks for the feedback! Looks like it needed a small "reboot" 😅 - I´ll pass the info to the team so that they are aware!

    Thanks again,

    Esther

    Former Community Manager