link icon
Ask The Community

[Update: 13.2.13582] Summer release

DanielStm Posts: 224 Staff member 🤠


Dear Linux community,

today we're releasing TeamViewer 13.2 for Linux. The second point release again syncs our development with that of the other platforms and brings some general improvements.

In-session chat is now available on both sides and should thus be more useful, especially when supporting someone on a Linux machine.

Another area of work has been the keyboard. Some have pointed out that key combinations (involving Ctrl, Shift, Alt) don't always work well. As this does not affect everybody all the time, it is not easy to tackle. We made some changes, but it seems that there is still room for improvement. If you (still) experience such issues, please comment in Ctrl + <key> problem.

As most of the general functionality is now available, it has been decided that TeamViewer for Linux leaves the preview stage and becomes a regular product. Consequently, future releases can be expected to be in-sync with the other platforms.

The benefits of the native Linux client are obvious: The simple reason that on a 64 bit system you now naturally use the 64 bit package, might be the key factor why the installation rate went up - less people downloading the wrong package. The repository on the other hand has proven to be very helpful to keep people up-to-date.
The Qt-based UI also enabled us to add support for the 9 languages that were missing before, totalling 33 languages now. Wine did not handle non-latin scripts that well.
We have also put some effort in improved system integration. The notification icon got some love, and connections to the login screen should work better - at least if the login screen does not run on Wayland. While we have done some foundation work for Wayland, we're currently awaiting general remote control support in Wayland. This is also the reason why it's not mentioned in the survey below.

We're aware that some features are still missing. During the last months we have added features according to the need expressed by our users in a survey last December. Now we're asking for your valuable feedback again. If you would like to shape the future of the Linux client, please consider to participate in our survey.
It's only 3 questions and every voice counts. Thanks!


This Survey is no longer active. Thanks for your participation and interest in TeamViewer. Have a look in the community to get the latest news on TeamViewer for Linux TeamViewer Linux Community Survey Close Date : 10/02/2018

Further Reading

Linux Knowledge Base

As always, packages are available via repositories and on the TeamViewer Linux download page.

All the best,

Linux Developer


  • Thanks ! There is so much to wait about Teamviewer Linux version,
    I'm waiting for next updates and available to help on beta test or something like this.

    My regards

  • I'm getting this error on Fedora:

    "package teamviewer-13.2.13582-0.x86_64 cannot be verified and repo teamviewer is GPG enabled: failed to lookup digest in keyring for /var/cache/PackageKit/27/metadata/teamviewer/packages/teamviewer_13.2.13582.x86_64.rpm"

    Can you please help?

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @abatistas1709: I assume you're doing a fresh install (not an update)?

    In this case, you can either just ignore the question, or you can  download the public key file here and import the key by using the following command as root:

    rpm --import TeamViewer_Linux_PubKey.asc 

    Your system will then trust packages signed by TeamViewer and it should install fine.

    I'll have to add that note to our current installation notes (it was there in the old version).

    Hope this helps! Cheers,

    Linux Developer
  • @DanielStm,

    In fact, I received a system notification about a Teamviewer update and when I tried to do it, I got the error I mentioned earlier.

    Thanks for helping.

  • Finally, same feature as other platform ! Thank you very much ! No doubt this native linux client was an excelent idea, tricky and economicaly not so profitable at start but YEAH, it's done. I will tell to all my workmate on Ubuntu (16.04 or 18.04) they can switch now from TM 12 to native TM 13. (FYI on previous release I've always encounter CTRL + SHIFT key problem, I'll check on this one)
  • mwildam
    mwildam Posts: 16
    FYI: On the standard download site there is still the previous version and the link above (Hint: Download and try it right now, ...) does not show up something different. However, from the repository I got the update notification.
  • DavidRH
    DavidRH Posts: 1

    Something seems to be wrong though...

    The sign-in button doesn't do anything?

  • mwildam
    mwildam Posts: 16
    In the meantime the new package download shows up on the teamviewer download page.
  • kode54
    kode54 Posts: 12 ✭✭

    I'm on Ubuntu 18.04.1, running with the Pantheon desktop environment from Elementary OS, and I find that the popup menus and approval dialogs do not appear at all. This is a new change, since updating from 13.1.

    Further issue: When my partner connects with remote control, possibly using the Spanish keyboard layout, my local Bluetooth keyboard's layout is permanently broken, even surviving a reboot, until I plug in a second USB keyboard, then both keyboards are reset to the US layout.

  • QPG
    QPG Posts: 21 ✭✭

    I saw a reply in the previous update release thread that suggested that middle click now works properly.

    Middle click does not work on 13.2.13582. I tested both Linux to Linux and Linux to Windows wihout success.

  • galvrz
    galvrz Posts: 15

    I am having a similar issue. If I close TV I can sign in, but it will not remain signed in, if my computer goes to sleep I get signed out and have to put my password in again. I finally got tired and reverted to the previous version. Hopfully the next version will work better.

  • JNA
    JNA Posts: 6
    DanielStm wrote:


    In-session chat is now available on both sides and should thus be more useful, especially when supporting someone on a Linux machine.

    Great News! That's just the missing feature that prevented full switch to TV13 on our remote hosts! 


  • calpub
    calpub Posts: 2


    On Linux Mint 17.3 64bits, I could use this new version once, just after the install. Next time I boot up my computer, I could not log in anymore : The login window does not let me type in my password, and in the main window, there is no session ID nor password displayed.

    Reverting to version 12...


  • Hi,

    I'm being having a problem with login, as already confirmated user and previssiusly logged in Software.The client  sometimes disconnect by yourself and logoff my account.

    When trying manual login again nothing occours. And I only can login again after kill or reopen the software.

  • In my setup (manjaro), I had to install a dependency, nss-mdns, and it fixed the grayed login issue!

  • The reason I tried ver 13 and then returned to 12 is "command line" support. I created shortcuts with password so I can easily log to family/friend PC when needed, and it is irritating  to have them locate Teamviewer and dictate login info, making mistakes do to miss-spelling.

    DO you at ALL plan to implement command line support for LInux vevrsion?

  • StefanS1
    StefanS1 Posts: 3 ✭✭

    testing teamviewer-suse-13.2.13582-0.x86_64 (still using V6 with commercial license)

    found following error:

    - chat is not working: can not send any message, only received messages shown

    missing (old) feaure:

    start connection with command line parameters -i <ID-or-IPaddr-hostname> -P <password>

  • Does this summer release support Audio from Remote Host?  I just installed, and had ab=n incoming connetction, and the guy was able to text-chat with me, but i was not able to hear his voice.

  • exactt
    exactt Posts: 22

    this doesn't help here. @DanielStm Will this ever be fixed? Last release we had the super annoying Ctrl-key issue. Now this login issue. It is really a pita to boot up Windows in a VM just to use Teamviewer...  :-( :-(

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @DrLove73, @StefanS1: command line support may return at some point, but is rarely requested. DrLove, in your case, if I undestand correctly, you could also put the IDs and passwords of your family PCs in the Computers & Contacts list. You could also assign those devices to your account and grant easy access. This way, your account has direct access, without the need for a password.

    @StefanS1: can you please explain the chat issue in a new thread in detail and tag me?

    @adimetrius: remote audio (hearing the sounds played on the other side) was never in the Linux version, but you seem to mean audio chat. This is also currently not available.

    @exactt: What exactly is the login-issue you're referring to? It works fine for me. Might also be a good idea to open a new topic with detailed description.


    Linux Developer
  • RomikB
    RomikB Posts: 5
    Great, but unfortunate work with issues, as all versions after 9. For example this version need sudo login and service restart after reboot to start working.
  • Can no longer login. Password field is greyed out. I logged in just fine under the assign account, but box is still greyed out and doesn't show assigned computers. Looks like this update breaks it.

  • Hi, I have been running personal teamviewer since version 13 became available. I see version 14 is now available. On ver. 13 I could never get video's sound to transmit to remote site. Video played like a silent movie. I run Linuxmint and tried it connecting to win10 and other linux machines but the same result. Has this been fixed in Version 14 of Teamviewer?
  • rok
    rok Posts: 22 ✭✭


    What about the feature "offine since.." that was present in the computer and contact list for offline entries in teamviewer 12? Will it be back?


    Thank You

  • StefanS1
    StefanS1 Posts: 3 ✭✭

    Hi @DanielStm,

    of course we know the "Computer&Contacts" list, but we have currently an own program, allowing full automatic connection (to internal) Hosts (Windows TV: v6 !) via internal IP-address by simple starting TV via command line options.

    Computer list or management console are fine, we use for external hosts, but not sufficient  easy use for this internal hosts.


    best regards