teamviewer.com link icon
質問投稿する

CentOS版teamviewerコマンドでの設定変更

fukkoshi
fukkoshi 投稿:5 ✭✭

ネットワーク設定-受信LAN設定をコマンドのみで「同意のみ」(LANからのアクセスのみ)にしたい。

どのようなコマンドを打てばよいしょうか?

タグ付けされた:

ベストアンサー

  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]
    回答済み✓

    @fukkoshi さん

    ご投稿ありがとうございます。

    誠に恐れ入りますがコマンドのみで「同意のみ」の設定を行うことが出来かねてしまいます。

    [int32] LanOnly = 1を global.confに追加することで「同意のみ」の設定が可能とのことでしたので、お試しいただくことは可能でしょうか。

    こちらの情報がお役に立てれば幸いです。

    Former Japanese Community Moderator
  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]
    回答済み✓

    @fukkoshi さん

    ご投稿ありがとうございます。

    テクニカルサポートチームと確認をしましたところ、接続不良が発生している可能性があるとのことです。ただLAN接続に関しては正常に稼働している様子です。

    またバージョン15からバージョン12への接続をされていらっしゃいますが、バージョン12のソフトウェアを、改善とバグの修正がよりされているバージョン15へ上げていただき、最新のバージョン15同士で遠隔操作をお試しいただき不具合がないかお試しいただくことは可能でしょうか。

    またこの先のサポートは個別対応により細かく分析をさせていただく必要があるとのこでございます。

    ライセンスをお持ちの場合はサポートチケットにて端末よりサポートコレクターの取得を行いお問い合わせをお願いいたします。(サポートコレクターの取得方法はサポートチケットマニュアルに記載がございます。)

    個人利用の場合誠に恐れ入りますが、コミュニティのみを利用して接続不良の個別検証が出来かねてしまいますため、両端末を最新版にして接続をお試しいただきますようお願いいたします。


    Linuxユーザーのみなさまへ

    同じご状況をご経験された方で解決方法や何か情報をご存知の方がいらっしゃいましたら是非こちらにご返信くださいませ。

    以上、こちらの情報がお役に立てれば幸いです。

    よろしくお願いいたします。

    Former Japanese Community Moderator
  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]
    回答済み✓

    @fukkoshi さん

    ご返信ありがとうございます。

    以下テクニカルサポート部からの回答です。

    TeamViewer15インストールにあたり、依存ファイルのインストールが必要になります。RHELでは、TeamViewerはワークステーションまたはサーバーのサブスクリプションでのみインストールできます。 RHEL Desktopサブスクリプションでは、すべての依存関係(つまり、qt5-qtdeclarative)を解決できるわけではありません。

    さらに、epelリポジトリを有効にする必要があります。

    必要な手順:

    #RHEL7の準備

     wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

     yum install ./epel-release-latest-7.noarch.rpm

    #RHEL8の準備

     wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm

     yum install ./epel-release-latest-8.noarch.rpm


    基本的ににログファイルをコミュニティ上にて掲載することはご遠慮いただいておりますが、今回特別にテクニカルサポート部と確認をさせていただき回答させていただきました。コミュニティはユーザー同士でTeamViewerに関する情報を共有し合う場として提供させていただいております。コミュニティガイドラインにてお伝えしておりますが、コミュニティモデレーターからの返信を必ずお約束することは出来かねますことご了承くださいませ。やはりベストな方法は両端末最新版にしていただきご状況の確認をしていただくこととのことでございます。

    何か新たに情報が入り次第コミュニティにてお知らせいたしますが、早急な個別サポート対応が必要な場合はこの先ライセンスが必要となりますことご了承くださいませ。

    ご不便をお掛けいたしますが何卒よろしくお願いいたします。

    Former Japanese Community Moderator

答え

  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]
    回答済み✓

    @fukkoshi さん

    ご投稿ありがとうございます。

    誠に恐れ入りますがコマンドのみで「同意のみ」の設定を行うことが出来かねてしまいます。

    [int32] LanOnly = 1を global.confに追加することで「同意のみ」の設定が可能とのことでしたので、お試しいただくことは可能でしょうか。

    こちらの情報がお役に立てれば幸いです。

    Former Japanese Community Moderator
  • fukkoshi
    fukkoshi 投稿:5 ✭✭

    @Yuri_T

    早速のコメント、ありがとうございます。

    /etc/teamviewer/global.confの最終行に教えていただいた行を追記しました。

    更新後、OS後と再起動してみたところ、サーバ側でパケットの受け取りはできるようになりましたが、接続は確立できないままでした。

    サーバ側、クライアント側のログを張らせていただきますので、ご意見いただけますと幸いです。


    サーバ側(接続される側)のログ:/var/log/teamviewer12/TeamViewer12_Logfile.log(該当箇所抜粋)

    2021/01/21 18:41:51.617 1654 4151147328 S  Activating Router carrier

    2021/01/21 18:41:51.617 1654 4151147328 S!! RemoteSession[4]::setClientID(): trying to set ClientID from 0 to 0, IP クライアントのIPアドレス

    2021/01/21 18:41:51.617 1654 4151147328 S  CommandHandlerRoutingLan[4]::EncryptLANConnection(): Encryption started

    2021/01/21 18:41:51.617 1654 4151147328 S  TerminalServer: Starting Direct LAN Connection

    2021/01/21 18:41:51.617 1654 4151147328 S!! TerminalServer: No session found

    2021/01/21 18:41:51.617 1654 4151147328 S!! CTerminalServer::StartDesktopProcess(): External connection failed for ID 4294967295, SessionFound=0 UserLoggedIn=0 LoginScreen=0 MultiUserFallbackMode=0 SessionID=4294967295 User= IsConsole=0 IsReliable=0 userWithGUI=0

    2021/01/21 18:41:51.617 1654 4151147328 S  SessionID=1024 Name= State=WTSIdle Detailed state=WTS_SESSION_UNLOCK User= Console=0 RDPClientIP= RDPClientName= DyngateID=0 GUIRunning=0 IsUserLoggedIn=0

    2021/01/21 18:41:51.617 1654 4151147328 S  SessionID=1000000 Name= State=WTSIdle Detailed state=WTS_SESSION_UNLOCK User=root Console=0 RDPClientIP= RDPClientName= DyngateID=0 GUIRunning=0 IsUserLoggedIn=0



    クライアント側(接続しようとする側)のログ:C:\Program Files\TeamViewer\TeamViewer15_Logfile.log(該当箇所抜粋)

    2021/01/21 18:42:38.880 7240 3904 G1  Trying connection to サーバのIPアドレス, mode = 1

    2021/01/21 18:42:38.957 7240 4816 G1! CParticipantManagerBase::SetMyParticipantIdentifier(): pid invalid: [0,68194686]

    2021/01/21 18:42:38.973 7244 7572 S0  Activating Router carrier

    2021/01/21 18:42:38.973 7244 7572 S0  CTcpConnectionBase[4]::ConnectEndpoint(): Connecting to endpoint サーバのIPアドレス:5938

    2021/01/21 18:42:38.988 7244 7572 S0  CommandHandlerRoutingLan[4]::EncryptLANConnection(): Encryption started

    2021/01/21 18:42:38.988 7244 7572 S0  Carrier[4]::CmdEndSession(): Received CMD_ENDSESSION with reason: UnspecifiedError

    2021/01/21 18:42:38.988 7240 6904 G1  LoginOutgoing: Terminated by client



    ※サーバとクライアントの時計は差があり、50秒ほどクライアントの方が早いです。

    クライアントのログを見る限り暗号化しようとして失敗しているようです。


    各位、ご意見の程よろしくお願いいたします。

  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]
    回答済み✓

    @fukkoshi さん

    ご投稿ありがとうございます。

    テクニカルサポートチームと確認をしましたところ、接続不良が発生している可能性があるとのことです。ただLAN接続に関しては正常に稼働している様子です。

    またバージョン15からバージョン12への接続をされていらっしゃいますが、バージョン12のソフトウェアを、改善とバグの修正がよりされているバージョン15へ上げていただき、最新のバージョン15同士で遠隔操作をお試しいただき不具合がないかお試しいただくことは可能でしょうか。

    またこの先のサポートは個別対応により細かく分析をさせていただく必要があるとのこでございます。

    ライセンスをお持ちの場合はサポートチケットにて端末よりサポートコレクターの取得を行いお問い合わせをお願いいたします。(サポートコレクターの取得方法はサポートチケットマニュアルに記載がございます。)

    個人利用の場合誠に恐れ入りますが、コミュニティのみを利用して接続不良の個別検証が出来かねてしまいますため、両端末を最新版にして接続をお試しいただきますようお願いいたします。


    Linuxユーザーのみなさまへ

    同じご状況をご経験された方で解決方法や何か情報をご存知の方がいらっしゃいましたら是非こちらにご返信くださいませ。

    以上、こちらの情報がお役に立てれば幸いです。

    よろしくお願いいたします。

    Former Japanese Community Moderator
  • fukkoshi
    fukkoshi 投稿:5 ✭✭

    @Yuri_T


    お世話になっております。

    ご確認ありがとうございます。一度teamviewer-host-15.13.6-0.x86_64を入れようとしたところ、下記ログで失敗してしまっています。

    ファイル間違えてますかね?


    [[email protected]サーバ(Centos8) ~]# dnf -y install teamviewer-host_15.13.6.x86_64.rpm

    timescale_timescaledb                        [===                              ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [===                              ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [  ===                             ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [   ===                           ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [     ===                          ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [      ===                        ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [        ===                       ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [         ===                     ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                        [           ===                    ] --- B/s |  0 B   --:-- ETAtimescale_timescaledb                      100% [===============================================================] 1.2 kB/s | 833 B   00:00 ETAtimescale_timescaledb                                                         244 B/s | 833 B   00:03   

    エラー: 

     問題: conflicting requests

     - nothing provides libQt5WebKit.so.5()(64bit) >= 5.5 needed by teamviewer-host-15.13.6-0.x86_64

     - nothing provides libQt5WebKitWidgets.so.5()(64bit) >= 5.5 needed by teamviewer-host-15.13.6-0.x86_64

    (インストール不可のパッケージをスキップするには、'--skip-broken' を追加してみてください または、'--nobest' を追加して、最適候補のパッケージのみを使用しないでください)


    別件の関係もあり、15の再インストールのテストは1/26(火)に行う予定になります。

    実施してみてわからないことがあればこちらに継続して記載させていただきます。

    ※サポートチケット無いのでコミュニティで完結させたい所存です。


    以上、よろしくお願いいたします。

  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]
    回答済み✓

    @fukkoshi さん

    ご返信ありがとうございます。

    以下テクニカルサポート部からの回答です。

    TeamViewer15インストールにあたり、依存ファイルのインストールが必要になります。RHELでは、TeamViewerはワークステーションまたはサーバーのサブスクリプションでのみインストールできます。 RHEL Desktopサブスクリプションでは、すべての依存関係(つまり、qt5-qtdeclarative)を解決できるわけではありません。

    さらに、epelリポジトリを有効にする必要があります。

    必要な手順:

    #RHEL7の準備

     wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

     yum install ./epel-release-latest-7.noarch.rpm

    #RHEL8の準備

     wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm

     yum install ./epel-release-latest-8.noarch.rpm


    基本的ににログファイルをコミュニティ上にて掲載することはご遠慮いただいておりますが、今回特別にテクニカルサポート部と確認をさせていただき回答させていただきました。コミュニティはユーザー同士でTeamViewerに関する情報を共有し合う場として提供させていただいております。コミュニティガイドラインにてお伝えしておりますが、コミュニティモデレーターからの返信を必ずお約束することは出来かねますことご了承くださいませ。やはりベストな方法は両端末最新版にしていただきご状況の確認をしていただくこととのことでございます。

    何か新たに情報が入り次第コミュニティにてお知らせいたしますが、早急な個別サポート対応が必要な場合はこの先ライセンスが必要となりますことご了承くださいませ。

    ご不便をお掛けいたしますが何卒よろしくお願いいたします。

    Former Japanese Community Moderator
  • fukkoshi
    fukkoshi 投稿:5 ✭✭

    @Yuri_T

    お世話になっております。

    下記の流れでインストールすることは出来ました。


    コマンドログを記載しておくことで今後新規インストールする人の役に立つと良いなと思ってます。

    #dnf remove teamviewer.x86_64.rpm #ver12をアンインストール

    #wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-8.noarch.rpm

    #dnf install ./epel-release-latest-8.noarch.rpm #インストール済み表示が出た。

    #dnf install ./teamviewer-host_15.13.6.x86_64.rpm  #ver15インストール成功


    #cat /etc/teamviewer/global.conf #確認したところ、

    #[int32]LanOnly = 1 #は最初から記載済みでした。


    サーバ側(接続される側)のログ:/var/log/teamviewer15/TeamViewer15_Logfile.log(該当箇所抜粋)

    2021/01/27 13:45:48.998 7173 140387649754880 S  Activating Router Carrier

    2021/01/27 13:45:49.144 7173 140387649754880 S  CommandHandlerRoutingLan[6]::EncryptLANConnection(): Encryption started

    2021/01/27 13:45:49.144 7173 140387649754880 S  DesktopProcessStarterLinux::StartSystemProcessInSession(1591159457,/opt/teamviewer/tv_bin/TeamViewer_Desktop)

    2021/01/27 13:45:49.146 7173 140387649754880 S  DesktopProcessStarterLinux: user for process launch: root (0)

    2021/01/27 13:45:49.146 7173 140387649754880 S  CreateProcess '/opt/teamviewer/tv_bin/TeamViewer_Desktop' as user root (0)

    2021/01/27 13:45:49.146 7173 140387649754880 S  ProcessControlBase[4]: Start Desktop process in session 1591159457, pid 91124

    2021/01/27 13:45:49.147 7173 140387649754880 S  CParticipantManagerBase::SetMyParticipantIdentifier(): pid=[183768094,-890625157]

    2021/01/27 13:45:49.147 7173 140387649754880 S  SessionControl::StartIncomingSession: PartnerIP = クライアントのIPアドレス

    2021/01/27 13:45:49.147 7173 140387649754880 S  ConnectionGuard: incoming remote control in sessions: 1591159457(1)

    2021/01/27 13:45:51.392 7173 140387736854720 S  HandleSigChld: Child was dumped: 91124 signal 11

    2021/01/27 13:45:51.393 7173 140387736854720 S  ProcessControlBase[4]: Process 91124 in session 1591159457 has terminated

    2021/01/27 13:46:03.384 7173 140387649754880 S  Estimated RTT to 0: 28 ms, Reliability: 3, Carrier: 1




    クライアント側(接続しようとする側)のログ:C:\Program Files\TeamViewer\TeamViewer15_Logfile.log(該当箇所抜粋)

    2021/01/27 13:46:40.507 9732 4908 G1  Trying connection to サーバのIPアドレス, mode = 1

    2021/01/27 13:46:40.548 9732 12656 G1! CParticipantManagerBase::SetMyParticipantIdentifier(): pid invalid: [0,-1442566887]

    2021/01/27 13:46:40.549 9732 15840 G1  VoIP: Receiver: Added session -1442566887

    2021/01/27 13:46:40.549 5640 6292 S0  CParticipantManagerBase::SetMyParticipantIdentifier(): pid=[172630563,-1442566887]

    2021/01/27 13:46:40.550 5640 6292 S0  Activating Router Carrier

    2021/01/27 13:46:40.550 5640 6292 S0  CTcpConnectionBase[73]::ConnectEndpoint(): Connecting to endpoint サーバのIPアドレス:5938

    2021/01/27 13:46:40.578 9732 12652 G1  CParticipantManagerBase::SetMyParticipantIdentifier(): pid=[172630563,-1442566887]

    2021/01/27 13:46:40.772 5640 6280 S0  CommandHandlerRoutingLan[52]::EncryptLANConnection(): Encryption started


    でセッション切れてるみたいです。

    パスワードも聞かれていないのでうまく接続セッションが開けていないようです。

    下記コマンド結果を見ると待機はしてるようですが、遠隔操作までは行けていないようです。


    [[email protected]サーバホスト名 ~]# netstat -nao|grep :5938

    tcp    0   0 0.0.0.0:5938      0.0.0.0:*        LISTEN   off (0.00/0/0)

    tcp6    0   0 :::5938         :::*          LISTEN   off (0.00/0/0)


    皆様、何かご存知でありましたら情報頂けますと幸いです。

    以上、よろしくお願いいたします。

  • Yuri_T
    Yuri_T 投稿:2,256 [Former Staff]

    @fukkoshi さん

    ご返信また詳細なご状況を説明いただきましてありがとうございます。

    社内で確認をさせていただきまして、本件個別でサポートチケットを介して対応させていただくこととなりました。

    引き続きチケットを介してLinuxを担当しているテクニカルサポート部より回答させていただきますので、今しばらくお待ちいただきますようお願いいたします。ご不便をお掛けしており申し訳ございません。

    その他コミュニティ内で回答できることがございましたら、私からも更新させていただきますので何卒よろしくお願いいたします。


    コミュニティをご利用のユーザー様へ

    本件似たようなご状況をご経験されている方で、情報共有が可能な方がいらっしゃいましたら是非ご投稿をお願いいたします。皆様からのご投稿お待ちしております。

    Former Japanese Community Moderator