link icon
Ask The Community

Commercial use - Connection time out



  • Lith
    Lith Posts: 16 ✭✭
    edited February 2021

    After a 25 February update of TeamViewer, Free Licence users will be logged out after about 30 seconds when connecting to any other computer. The user will get a message that says "Your TeamViewer session has timed out and will be closed". You will then be blocked from reconnecting for a couple of minutes.

    If you try again after a while or restart client, you will once again get the same timeout and block.

    This is obviously a bug and has been reported in several threads, but the forum moderators seems to ignore the problem and instead merge these threads with "commercial use thread".

    The reason behind this "timeout" is NOT that users are flagged as commercial. This issue is NOT related to commercial use. Thats not the issue here and users dont get that message. We get a message about TIMEOUT, not about anything detected or any commercial suspicions.

    Forum moderators, stop merging threads. You are just confusing people.

    Some response from the dev team would be nice and a ETA of a fix?

  • Efe
    Efe Posts: 6 Newbie

    This thread will be merged as well lol

  • andrewagrosser
    andrewagrosser Posts: 0 Newbie

    I am encountering this issue as well.

    It is proving impossible to provide support to my mother as a result.

    TeamViewer - Please work on addressing the bug.

  • BenLomax
    BenLomax Posts: 2

    Same here...

  • Diablomania
    Diablomania Posts: 1

    Hello. There is some mistake about one of my PC. I'm not using it for commercial, but I got limits. Can you help me pls?

  • Lith
    Lith Posts: 16 ✭✭

    Yeah, seriously. These moderators are completely stupid. There is no logic, no thought.

    0 Hopes of this company to solve this issue anytime soon with this method.

    You can merge me to now. GL

  • aihab
    aihab Posts: 1 Newbie

    im a free user and i use TV to help friends and family sometime with their issues , recently i just get disconected after 1 minute with TV prompting me that its commercial use and that i reached my limit

  • Boti
    Boti Posts: 0 Newbie

    i have the same issue, what is the solve

  • decop
    decop Posts: 6 ✭✭

    Hello !

    the connection lasts 1 minute then ejection with message:

    Connection blocked after expiration of response time.

    Your license limits the maximum duration.

    Reinstalling the program does not fix anything

    thank you for your collaboration

  • Verena73
    Verena73 Posts: 2 ✭✭

    I have the same problem!

  • user1234
    user1234 Posts: 0 Newbie

    Have same issue i cant connect to my home server anymore and when i manage i get booted almost instantly

  • Arey
    Arey Posts: 1 Newbie

    I can just connect the other computer for 30 seconds. What's the problem?

  • Darkiger
    Darkiger Posts: 2 ✭✭

    I am trying to send TeamViewer the request of non commercial use, but it keeps on asking me to enter my ID. When I do it and click Generate PDF, nothing happens and my ID is AGAIN requested ... totally unable to generate the PDF

  • Lunneborg
    Lunneborg Posts: 7 ✭✭

    same for me today. again

    had same problem 2 days ago and yesterday i could use it but not today.

    i use it to logon to my gameserver that i have in my baisment and no keboard or monitor or mouse

  • Lunneborg
    Lunneborg Posts: 7 ✭✭

    this is the 3rd day i have this same problem.

    worked some times yesterday but now its the same problem.

  • Betelgeuse
    Betelgeuse Posts: 8 ✭✭
    edited September 2021

    I don't think TV gives a **bleep** about this.

    I am looking for alternatives now

  • I got a new Macbook Pro and am running Teamviewer 15.15.5. I am running Personal / Free to be able to connect to my machine I have at home and sometimes helping family & friends. I have no problem running Teamviewer on my iPad, Samsung S10+ or iPhone X but with the new Macbook Pro when I connect to say my machine at home after a minute or even less my session timesout. When I the try to reconnect I get message:

    Connection blocked after timeout.

    Your license linits the maximum session duration to a partner,

    immediate reconnects are blocked. Please try later or upgrade you license.

    What is causing this? I have added my Macbook Pro the list of devices that I use but do I need to do something else?



  • samtfischer
    samtfischer Posts: 1 ✭✭
    edited February 2021

    I’m having this issue too, but I’m not even getting an error message. The issue only happens when I’m accessing my MacBook Pro while the lid is closed. I think it’s a Mac related issue as I have the same problem using *Third party product*

  • paulenigal
    paulenigal Posts: 2 ✭✭
    edited February 2021


    My mother is almost blind.

    We request for admitting her Android unit ID

    and her PC unit

    from(!) mine ID



  • samtfischer
    samtfischer Posts: 1 ✭✭

    I'm running 15.15.5 on Big Sur, and I'm trying to remote in with my iPhone while the lid is closed. It works for about 1 min, but then kicks me off. My laptop seems to constantly flip from being online and offline in the My Computers list. Does anyone have a workaround for this?

  • Leo212
    Leo212 Posts: 1 Newbie

    I'm using it on my PC for my personal use and recently it no longer allow me to remote control it for more than few seconds everytime.

    On the mobile app I'm getting a message claiming that I'm using it for non-personal use (which is not true) and I should contact support.

    But I can't contact support, I only have access to this forum and I'm not sure if anyone here can help me solving this.

    I'm afraid I'll have to create a new account to get rid of this annoying bug.

  • Gerald74
    Gerald74 Posts: 1 Newbie

    I followed the whole procedure to get my teamviewer ID reactivated and got a positive response at the end. But Teamviewer still doesnt work - it closes the connection after a few minutes and says its closed for a tim out now. what can I do to solve this problem?

  • Xerboras
    Xerboras Posts: 2 ✭✭

    I have the same problem.

  • ArmandAanekre
    ArmandAanekre Posts: 0
    Answer ✓

    You have to fill out and sign a form here:

    Just explain your use scenario and you should be up and running again in a few days. Happened to me about a year ago. Happened again just now because I was stupid enough to try Teamviewer from my work laptop...

  • I am TeamViewer Free user. I run it on Win10 Pro x64 PC. I noticed yesterday that my remote sessions go into a timeout after about one minute, no matter what I do. The message says "Your TeamViewer session has timed out and will be closed". So it seems that I am not suspected of using TV commercially (I believe that message will explicitly say so in that case).

    I went through TV settings and haven't found anything related to the session time out. So I uninstalled the TV, deleted all various folders left behind, and installed the TV again. The issue persisted. Before yesterday I last used TV roughly ten days to a fortnight ago without a glitch. So cause for the trouble could be the last version I installed yesterday (15.15.5), but I found nothing like that in the forum.

    I'd like to get some advice on how to proceed with troubleshooting.

  • Csu
    Csu Posts: 0 Newbie

    I've the same issue. I've got this message with an older version. Than I upgrade to the latest version (15.15.5) on both TV sides but nothing changed.

    I'd like to get some help too... Thx.

  • Csu
    Csu Posts: 0 Newbie

    I've the same issue. I've got this message with an older version. Than I upgrade to the latest version (15.15.5) on both TV sides but nothing changed.

    I'd like to get some help too... Thx.

  • shaylaks
    shaylaks Posts: 0 Newbie

    same problem.

    they are doing everything so we will purchase license.

  • kwolberg
    kwolberg Posts: 0 Newbie

    I have the same problem. I log on to my uncle's computer and after a minute I am timed out. I do not see any reason for this happening. Please advise.

  • dvsmp3
    dvsmp3 Posts: 1 Newbie


    As the title says, TV started to terminate my connection after a few minutes of every session. After that it doesn't allow me to reconnect for a couple of minutes.

    This problem started a couple of days ago. Never happened to me and I've been using TV for years (for private use always).

    I usually connect from my (Windows 10) laptop to my desktop (Windows 7). I have tried reinstalling TeamViewer on my laptop but it didn't help.

    Is this "the new normal" or is there something else I can do to bring the good old TeamViewer back?

    Thank you and best regards