Unknown Session error

Nocy123 Posts: 3 ✭✭
edited June 2023 in Mobile


I get "Unknow session" when im trying to connect to my android phone.

I have windows 11 64 bit


  • .Carol.fg.
    .Carol.fg. Posts: 1,023 Moderator

    Thanks for your question @Nocy123 !

    And welcome to our Community! 🙌

    Connection issues can be caused by different reasons, so we will need more details to troubleshoot this case.

    • Is your Android phone on our list of supported manufacturers?
    • Was it working before and stopped working, or is it the first time you're trying to connect with this device?

    I'm looking forward to your feedback! 🙋‍♀️

    Best, Carol

    Portuguese Community Moderator

  • Nocy123
    Nocy123 Posts: 3 ✭✭

    This is the first time im using it on my windows 11 computer and with the new big update from TeamViewer

  • .Carol.fg.
    .Carol.fg. Posts: 1,023 Moderator

    Hi @Nocy123 ,

    Thanks for the additional details!

    • What is the direction of the remote connection? Are you trying to connect from your Android to Win 11, or Win 11 to Android?

    📌Please remember that to start a remote session you must sign in with your TeamViewer account.

    Let us know if you still have issues after doing the login with your account. 🙋‍♀️

    Best, Carol

    Portuguese Community Moderator

  • Nocy123
    Nocy123 Posts: 3 ✭✭

    I dont need to be login if i have the session code. But it dosent work even if i would login

    Windows 11 to android

  • .Carol.fg.
    .Carol.fg. Posts: 1,023 Moderator
    edited June 2023

    Hi @Nocy123 ,

    Thanks for the additional information.

    Just for clarification: please know that the device that is starting the connection (windows 11) must be logged in in order to start a remote session.

    • Without the sign-in, TeamViewer Remote allows a user to join the session waiting room, but the supporter still needs to start the session which requires a login.

    After sending the session link to the Android device, the remote partner can click the link to install the QuickSupport app.

    If QuickSupport is already installed on the mobile, it will redirect to it automatically.

    During the installation, you may be asked to install the manufacturer Add-On or Universal Addon for compatibility. Also, you may be asked to Allow in the Android settings the option to Display over other apps.

    Once the Android has the correct configuration, the supporter will be able to start the connection for the remote side to allow the connection.

    • Does the message unknown session is happening after the remote side clicks Allow?
    • Have you tried to restart the internet router of the devices?

    I hope the information above can help.

    I'm looking forward to your feedback! 😄

    Best, Carol

    Portuguese Community Moderator

  • Sergey_Barmaley
    Sergey_Barmaley Posts: 1

    I have absolutely the same issue with any connection from Win 11 (to Win 10, to Android tablet). App is up to date on all the devices.

    I am trying to connect using remote machine Id/password.

    Actually, it does not even get to the step with password. It just cannot connect.

  • .Carol.fg.
    .Carol.fg. Posts: 1,023 Moderator

    Hi @Sergey_Barmaley ,

    Thanks for reaching out to our Community!

    Have you tried uninstalling and installing TeamViewer again?

    If not, you can follow our guide for advanced uninstall, and then download it again from our website.

    Let us know how it goes! 🙋‍♀️

    Best, Carol

    Portuguese Community Moderator

  • TechAzn
    TechAzn Posts: 1

    I'm new to the forums, but I might have found a possible fix to the unknown session issue. It seems you might need to register for a free TeamViewer Account after updating to the latest version of TeamViewer. I wish I took a screenshot, but if you go back to the classic view of TeamViewer & try to remote into a PC you'll get an error stating you need to register for an account to make an outbound remote connection. I'm going to try & login to my dad's computer later in the week & see what happens. I'll post updates later.

  • righteousjoe
    righteousjoe Posts: 1

    Teamviewer used to be the best and easy to use. nowadays its just too complicated. been using it for more than 3yrs, was working perfectly but after updating it, its just too complicated

  • gzgenm
    gzgenm Posts: 1
    edited November 2023

    You had a working product and now made it **bleep** and unuseful.

    100500 mails 25348683468 asks for trusting, UI says "unknown session".

    I hope your company will come to the end soon. And I personally go to your competitors. **bleep**

  • TennesseeJT
    TennesseeJT Posts: 1

    I agree: TeamViewer is now USELESS! First the suddenly "detect" NON-commercial systems as "business systems" and try to force no more use of the 'Free' version, even though it is just an old work PC that is NOT a business system at all. Now, they FORCE you to login, before allowing any session to be connected? That's crazy! It's overreach.