Problembeschreibung
Wenn Sie versuchen auf einem iPad mit iOS13 oder neuer eine TeamViewer (Classic) Verbindung mit dem Safari-Browser zu starten (sei es über einen per E-Mail zugesandten Sitzungslink oder eine Benachrichtigung von Ihrem MDM/EMM), werden Sie möglicherweise aufgefordert, eine .dmg- oder .zip-Datei für TeamViewer (Classic) QuickSupport herunterzuladen, obwohl Sie die TeamViewer (Classic) QuickSupport App bereits installiert haben. Nach dem Download wird das Paket nicht installiert und Sie können keine Verbindung aufbauen.
Ursache
Auf einem iPad ist der Safari-Browser so konfiguriert, dass er standardmäßig die 'Desktop Ansicht' anfordert. Daher werden Sie zur MacOS App weitergeleitet, welche jedoch die falsche Plattform ist.
Workarounds (wählen Sie A oder B)
So lange wir an einer dauerhaften, universellen Lösung arbeiten, gibt es zwei mögliche Workarounds für dieses Problem:
A. Die mobile Ansicht anfordern
Wenn der TeamViewer (Classic) auf dem Browser startet, gibt es oben links ein 'AA'-Zugriffsmenü, welches Ihnen erlaubt die mobile Ansicht anzufordern (siehe Abbildung unten). Bitte wählen Sie um die Verbindung zum richtigen QuickSupport zu leiten 'Requesting the Mobile Site'.
Fahren Sie mit Punkt C fort.
B. Den Safari Browser so konfigurieren, dass er nicht die Dektop Ansicht anfordert
Dieser Workaround würde für alle Seiten, die von Safari angefordert werden, greifen und nicht nur für TeamViewer (Classic).
1) Gehen Sie in die Einstellungen des iPads
2) Scrollen Sie zu den ‘Safari’ Einstellungen und klappen Sie ‘Request Desktop Website’ aus
3) Stellen Sie sicher, dass die Option 'REQUEST DESKTOP WEBSITE ON' nicht für alle Websites aktiviert ist:
C. Neustart
Nachdem Sie den Anweisungen unter A oder B gefolgt sind, starten Sie die TeamViewer (Classic) Verbindung erneut. Sie werden aufgefordert, die Verbindung zuzulassen und die Übertragung zu starten.