Read this article in Chinese | French | German | Japanese | Spanish 


This article applies to older TeamViewer versions (up until 15.3) on Fedora 29 and higher.

General

Until Fedora 28 TeamViewer is able to make connections without any special configuration of the operating system. With Fedora 29 the Fedora project changed the dbus implementation which affects TeamViewer up until version 15.3.

HintPlease update to TeamViewer 15.4 or newer to resolve this issue.

The problem

Incoming connection doesn't get trough to the TeamViewer client:

fedora31_incoming.png

The initiator of the connection sees the following error:

fedora31_error.png

The source of this issue is the active dbus-broker service.
This can be figured out with the following command:

systemctl status dbus.service

dbus-broker.png

Solution

The good news is Fedora did only change the default dbus setting and it's possible to change it back without any complications for other applications and services on the system.

Execute the following commands as an administrator:

systemctl disable dbus-broker.service
systemctl --global disable dbus-broker.service
systemctl enable dbus-daemon.service
systemctl --global enable dbus-daemon.service

#Now reboot the system so that the settings are getting reloaded reboot

Realated articles

Version history
Revision #:
11 of 11
Last update:
October
Updated by:
 
Labels (1)